ITE 8211F IDE controller - Vista driver does not allow CD/DVD burning

Discussion in 'Windows Vista Hardware' started by Ron, May 30, 2007.

  1. Ron

    Ron Guest

    Abit IB9 motherboard with an ITE 8211F IDE controller onboard. Vista loads
    the native Vista driver fine and the drives show up as DVDRW drives in
    Windows Explorer. But under PROPERTIES, there is no RECORDING tab.
    Therefore I cannot use the native Vista burning function. This is on a
    clean install of Vista Business.

    XP on this machine works fine (ITE controller is functioning). Tried 3
    different burners and they all exhibit this behavior. These burners work
    fine on another Vista machine with a native IDE controller. So the ITE
    driver in Vista looks to be the issue. has no Vista driver.
    Writing to Abit has elicited no response.

    The ITE 8211F/8212F controller is common to many 945/965 chipset boards.
    Has anyone found a fix for Vista and this IDE controller?
    Ron, May 30, 2007
    1. Advertisements

  2. Ron

    freddy Guest


    I can only suggest some steps to take to help ensure that something apart
    from the controller driver isn't the problem:

    In Device Manager, check under Properties for this controller to see whether
    its functioning properly, or whether some other message appears that could
    indicate an issue.

    Check the BIOS settings for the controller to confirm they are proper.

    Update Vista by downloading and installing all available updates at the
    Microsoft update website.

    As a final step, consider updating the BIOS to the latest version available
    at the manufacturers website.

    These steps are necessary to help pinpoint the issue, since there are other
    possible causes for the problem. It is to early to assume a driver issue
    because we've no confirmation of that possibility at this time. Others may
    have additional ideas.
    freddy, May 30, 2007
    1. Advertisements

  3. Ron

    R Guest

    Thanks for your help Freddy.

    Device Manager shows all drives functioning properly with no conflicts or
    driver issues. The ABIT BIOS is the latest official release (1.2). Vista
    is updated fully -- no new drivers.

    Frustrating since the other OS (XP) in this dual-boot config works
    perfectly. It looks to be an issue with Vista and the ITE controller.
    R, May 31, 2007
  4. Ron

    freddy Guest


    I'm mostly interested in what Device Manager shows about the controller,
    though it's good that it shows the drives are functioning properly. Nothing
    wrong with that.

    Take another look in Device Manager and view the Properties for this
    controller we're discussing, because you're expressing some doubt about it.
    Look under the driver tab. Is there a way you can determine whether the most
    recent driver for that device is being used? Try clicking on the Update
    Driver option to see what happens. Follow on-screen prompts.
    freddy, May 31, 2007
  5. Ron

    R Guest

    It is using the native Vista ITE driver. Tried updating via Windows Update
    and there is no newer driver.

    Loaded Nero 7 Ultra and it sees all the drives properly! But Vista still
    cannot use them as burners with the native Vista burning utility.
    R, Jun 1, 2007
  6. Ron

    freddy Guest


    Well, I agree it's confusing. How does one show that the problem is the
    controller when one can't find anything wrong with it? All associated
    devices and drivers are functioning properly and no newer drivers are
    available. So, what's wrong? I don't know.

    Between us, there is only one more thing that I can think of doing. That
    is, in Device Manager, remove the drives and the controller and reboot.
    Maybe Windows will detect some corrective action when it boots that fixes the
    issue. I just don't know, but it doesn't cost much to try that.

    If that doesn't do anything, try troubleshooting by searching the Internet
    using google. You may find that some one with the same problem posted the
    answer. If you don't care to bother with that, try some other forum that
    deals with technical issues. You can use google to find such forums.
    Another approach is to reinstall Vista using the repair option. Sometimes
    that fixes strange issues. Just some ideas. Your imagination likely is just
    as good as mine.
    freddy, Jun 2, 2007
  7. Ron

    freddy Guest

    freddy, Jun 2, 2007
  8. Ron

    Ron Guest

    Ron, Jun 7, 2007
  9. Ron

    freddy Guest

    Hi Ron,

    Great that you located an explanation. That's the first I heard of it.
    According to the explanation as to cause in the Microsoft KD, quote:

    This problem occurs because the SCSIport driver does not populate the
    correct number of bytes for an IOCTL_STORAGE_QUERY_PROPERTY Request Packet
    (IRP) when the device does not return a correct serial number.


    From that, I have difficulty identifying the cause. Seems to be something
    about the SCSIport driver reporting the wrong serial number, which caused
    your drive to be misidentified. Over my head. I don't see how that has
    anything to do with IDE controller, but as I say, it's over my head.

    I don't see how that has anything to do with Vista ,either. It looks as if
    the SCSIport driver reported the wrong serial number to Vista. Why that
    happened, I don't know. Anyway, I hope this takes care of your problem.

    I've been checking back to your post on a daily basis trying to see what
    happened, and it's good to see you're getting there. Some of these
    situations are indeed mysterious.
    freddy, Jun 7, 2007
  10. I noticed the problem seems to be with SCSI controllers from my internet research so I tried whatever I could short of flashing BIOS (installing uninstalling drivers, software, etc , using MS Knowledge base registry hacks, everything). Eventually I noticed I have a few virtual drives on my system from where I used to copy my games to the HD and run them as virtual disks to keep from having to keep switching disks. The software I used was Farstone's Gamedrive (which I think is called VirtualDrive now). This software emulates a cd by emulating a SCSI drive. I simply went to Explorer, found one of the offending drives, right clicked it, selected properties and navigated to drivers and uninstalled the drivers and checked the box in Vista to 'delete driver files'. Everything works perfect now. I guess I see why people hate Vista now. This was like solving a problem in a linux distro. Having to find the solution that fits your situation, and then solving it on your own by chance. Windows users aren't used to having to do that, which is why there are so many tech support jobs available. :) That said, I've found dozens of solutions to this problem and it seems to vary with hardware, so mine may not work for you, but be secure in the fact that your solution will involve a SCSI drive controller driver.
    Hilton T Young, Sep 20, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.