IUpdateDownloader::Download() returns 0x80240044

Discussion in 'Windows Update' started by CtA, Jun 11, 2009.

  1. CtA

    CtA Guest

    Hi,
    IUpdateDownloader::Download() returns 0x80240044 on logged on user as in
    User Group, Same call works fine when logged on user is in Admnistrator group.

    But MSDN documentation does not mentioned about this, also I could not find
    description for the error code.

    Any help?

    Thanks n Advance.
    CtA
     
    CtA, Jun 11, 2009
    #1
    1. Advertisements

  2. CtA

    MowGreen Guest


    0x80240004 WU_E_NOT_INITIALIZED
    Object is not correctly initialized.

    OK ... so, you're trying to use a script in *what* doing *what* ?
    Nevermind ... I'll go search MSDN ...
    http://msdn.microsoft.com/en-us/library/aa386134(VS.85).aspx


    MowGreen
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen, Jun 12, 2009
    #2
    1. Advertisements

  3. CtA

    CtA Guest

    Are you sure about that?
    I asked about 0x80240044, but you replied about
    0x80240004(WU_E_NOT_INITIALIZED)
    I'm trying to get driver update for specific hardware, everything works fine
    for user in Administrator group, i want to do same thing for a user in
    Standard User group.

    Thanks
     
    CtA, Jun 12, 2009
    #3
  4. Are you referring to WSUS?
     
    PA Bear [MS MVP], Jun 12, 2009
    #4
  5. CtA

    CtA Guest

    Underneath it is same, but I'm not sure about that, i'm refering to Windows
    Update Agent COM API
     
    CtA, Jun 12, 2009
    #5
  6. If the client is updating via WSUS (as the error suggests), it really isn't
    the same & you should be posting in the WSUS-specific newsgroup:
    microsoft.public.windows.server.update_services
     
    PA Bear [MS MVP], Jun 12, 2009
    #6
  7. CtA

    CtA Guest

    Any question regarding Windows Update Agent COM API belongs to this
    newsgroup or not?

    As long as somebody could shed some details could help others.
     
    CtA, Jun 12, 2009
    #7
  8. CtA

    MowGreen Guest

    No. I dropped a 4 and posted nothing worth checking out, CtA.
    FWIW, I can't find anything about the error, 0x80240044, either.
    All I found were the MSDN articles on the IUpdateDownloader Interface.
    You've probably checked them out, too.
    Sorry about that.

    Perhaps you should try the "Send comments about this topic to Microsoft"
    link and see if you get a response.


    MowGreen
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen, Jun 12, 2009
    #8
  9. Have you tried setting the ElevateNonAdmins registry option? I'm not sure
    whether it affects the COM API, but it seems reasonable to suppose that it would.

    <http://technet.microsoft.com/en-us/library/cc708449.aspx>

    http://technet.microsoft.com/en-us/library/cc708449.aspx

    If the problem was lack of permission, I'd have expected to see error code 5
    rather than an apparently undocumented code, but you never know.

    You could also try using Process Monitor to see if there's an underlying file or
    registry error occurring:

    <http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx>

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    If so, it might give you some hints.

    It seems unlikely that the issue is related to whether you're using WSUS or not.
    It could, however, be worth asking in the WSUS newsgroup as well, because most
    folks wanting to do this kind of technical WU stuff tend to be in a corporate
    environment and therefore use WSUS. However, I don't hold out much hope; I'm
    not aware of anyone in either group who has worked with the COM API much.

    Harry.
     
    Harry Johnston [MVP], Jun 14, 2009
    #9
  10. For the record, while the Windows Update Agent error codes happen to be
    documented in the WSUS section of the MSDN, they apply equally well to
    conventional Windows/Microsoft Update as well.

    Harry.
     
    Harry Johnston [MVP], Jun 14, 2009
    #10
  11. Did you find any documentation for 0x80240044? If so, can you post a link?
     
    PA Bear [MS MVP], Jun 14, 2009
    #11
  12. No, I didn't. :-(

    I can only assume it's either an error code that was never expected to actually
    appear, or that it is new to the latest version(s) of the WUA. Most likely the
    latter.

    Harry.
     
    Harry Johnston [MVP], Jun 15, 2009
    #12

  13. Agreed. And it probably doesn't have much meaning without its context
    with the other log messages or file and registry accesses anyway.
    That's why I'd use ProcMon to supplement whatever diagnostics
    the OP is getting. E.g. doing that could expose something like a
    security issue or other access issue which would make moot
    whatever the reported result code is.


    ; }

    Robert
    ---
     
    Robert Aldwinckle, Jun 15, 2009
    #13
  14. CtA

    Snekethan Guest

    I did ran process monitor, it does not help much.
    My guess is that it is trying to download to Windows Update Cache where some
    low-level component checks privilege of current logged on user, then, it
    returns undocumented (Machine) Access Denied error instead of returning
    common ACCESS_DENIED error.

    i have checked the registry, ElevateNonAdmins is already set to 1.
     
    Snekethan, Jun 22, 2009
    #14
  15. CtA

    T-Log Guest

    Hello All,

    I am also experiencing the same frustrating issue while calling unmanaged
    WUA 2.0 COM+ code from managed .NET

    I am using Windows Update Agent 2.0 API and the
    IUpdateDownloader.BeginDownload() or IUpdateDownloader.Download() methods
    both return 0x8024044 when called with a user which doesn't have the
    administrator priviledges...

    it's important to mention that my application is 100% functionnal with a
    administrator user.

    I've tried to monitor my process using procmon without any luck although
    here something interesting. The RegistryQuery operation to COM+
    LaunchPermission key caused a buffer overflow...



    64218 1:52:30.3764267 PM svchost.exe 904
    RegQueryValueHKCR\AppID\{653C5148-4DCE-4905-9CFD-1B23662D3D9E
    \LaunchPermission BUFFER OVERFLOW Length: 144

    653C5148-4DCE-4905-9CFD-1B23662D3D9E = wuauserv DCOM

    Also I've tried to add the problematic user to Distributed COM group in case
    it was a permission issue with DCOM Windows Update Agent but no luck...

    Help guru's help!
     
    T-Log, Jun 29, 2009
    #15
  16. T-Log,

    I'm afraid that as far as I know there aren't any Gurus around when it comes to
    using the WUA COM interface.

    My best guess would be that this behaviour is by design, for security reasons.
    If my guess is correct, the only way to solve your problem would be to divide
    your code into a user component (if needed) and a service component, as you
    would need to do for any other administrative task.

    Harry.
     
    Harry Johnston [MVP], Jun 30, 2009
    #16
  17. CtA

    Guest

    CtA,

    I came across this post: http://microsoft.public.development.device.drivers..dtm.narkive.com/kkpzP4wn/pnp-device-id

    Can you please email me about it?
    elwell1 [AT] gmail [DOT] com
    Kevin
     
    , Jun 11, 2013
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.