javascript does not work for nonadmin in IE7?

Discussion in 'Internet Explorer' started by alexms, Oct 23, 2006.

  1. alexms

    alexms Guest

    It looks like JavaScript stopped working for a "Users" member after a switch
    to IE7.
    If IE7 is run from an admin account (or is runas'ed as admin from that same
    account), everything is ok; when run from a user, all "onLoad" and/or "alert"
    fail.

    Happens on w2k3s SP1 in a non-domain (workgroup) environment.

    Any idea why?

    Can I change something in secpol.msc to fix it?
    Will a switch to a domain help?
     
    alexms, Oct 23, 2006
    #1
    1. Advertisements

  2. alexms

    BillD Guest

    here javascript works fine as limited account
     
    BillD, Oct 23, 2006
    #2
    1. Advertisements

  3. alexms

    alexms Guest

    here javascript works fine as limited account
    What do you mean by "here"?
    What is the environment?

    I am pretty sure that the culprit is JavaScript, onclick etc. never work,
    which is strange: I believe IE7 does not change jscript.dll's accessibility.

    The debugger breaks in on the first onLoad(...) but that does not explain
    anything, "Object required" message is all I have.

    OLE/COM object viewer doe snot show anything special about JScript engine...
     
    alexms, Oct 23, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.