Jerky DVD Playback under Vista Home Basic - Dell Inspiron 1150

Discussion in 'Windows Vista General Discussion' started by phil, Oct 22, 2007.

  1. phil

    phil Guest

    Hi,

    I hope you can help. I have a Dell Inspiron 1150, which has an AMD
    Turion 64 Processor and 1GB Ram, running Windows Vista Home Basic. The
    machine is about 1 month old and has all the latest patches appleid
    via windows update.

    When I playback DVDs using WinDVD that shipped with the laptop, the
    playback is intermittantly frozen, whilst the sounds often continues.
    Often, after a few seconds, the video catches up by playing the
    missing video in a sort of high speed, fast-forward mode, until the
    video and sound catch up. At times, even the sound freezes, and the PC
    struggles to respond to mouse clicks like the processor is being
    hammered. The interruptions occur about every 20-30 seconds.

    I have also installed BBC iPlayer (had to do a little registry hack to
    get it to play before you ask about Vista support, but it seems okay -
    DVD skipped prior to iPlayer install), and this has exactly the same
    problem.

    I have tried to improve it by turning off wireless networking, Anti-
    virus (AVG Free), Windows Defender etc, it still doesn't improve. I
    don't have much other software installed.

    I have also installed the latest Video Drivers for the ATI card that
    is installed.

    Any ideas?

    Thanks in advance.

    Phil
     
    phil, Oct 22, 2007
    #1
    1. Advertisements

  2. phil

    Abi Narayan Guest

    Hi

    This could be due to Missing or Outdated DVD (MPEG 2) Video Codec,

    I recommend you to use VLC player! Free and works fine, no codec needed to
    install

    Download VLC Player here www.videolan.org/vlc/download-windows.html

    Thanks

    Abi
     
    Abi Narayan, Oct 22, 2007
    #2
    1. Advertisements

  3. phil

    R. McCarty Guest

    This problem can occur if the Optical drive's operating mode has been
    changed due to repeated errors. Normally, an Optical drive will run at
    or above UDMA Mode 2. If the "Step-Back" operating mode to avoid
    errors has occurred the mode may now be in a slower PIO mode. To
    resolve this you sometimes have to remove the ATAPI/IDE controller
    that hosts the optical and then allow Windows to re-detect it and the
    Optical drive. Most recent controllers have an Advanced (TAB) in the
    details box of the device that shows connected device's operating mode.
     
    R. McCarty, Oct 22, 2007
    #3
  4. phil

    MICHAEL Guest

    * :
    Have you installed all updates? Especially, these two?

    http://support.microsoft.com/?kbid=938194
    http://support.microsoft.com/kb/941649

    Also, you could trying using the free GOM Player and
    see how it does. http://www.gomplayer.com/main.html

    R. McCarty's reply is good information, too.


    -Michael
     
    MICHAEL, Oct 22, 2007
    #4
  5. phil

    Charlie Tame Guest


    Have we turned of indexing - in the hard drive properties there is a
    checkbox, try unchecking that and see if it helps. You might also turn
    of indexing via that the "Search" properties but the drive issue was one
    huge problem for me.

    Does the HDD light keep flashing? If it's on the same Bus as the DVD,
    and I don't know the answer to that but "If" then that will disrupt
    reading of the DVD
     
    Charlie Tame, Oct 22, 2007
    #5
  6. phil

    phil Guest

    Thanks guys, all sorted now. I followed your instructions on hard
    drive indexing and also downloaded a new player!

    Thanks
     
    phil, Nov 12, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.