KB883939 Install Failed w/log

Discussion in 'Windows Update' started by 3gemail, Jul 8, 2005.

  1. 3gemail

    3gemail Guest

    I tried to install KB883939 manually because it keeps asking to
    reinstall. I ran it with the /log option and got the following can
    someone help????? Please.

    [install.log]
    0.781:
    ================================================================================
    0.781: 2005/07/07 16:18:25.703 (local)
    0.781: c:\81df2d35604a496cf0c9\update\update.exe (version 6.1.22.4)
    0.796: Hotfix started with following command line: /log:c:\install.log
    1.093: In Function TestVolatileFlag, line 11660, RegOpenKeyEx failed
    with error 0x2
    1.093: In Function TestVolatileFlag, line 11692, RegOpenKeyEx failed
    with error 0x2
    1.093: DoInstallation: CleanPFR failed: 0x2
    1.093: SetProductTypes: InfProductBuildType=BuildType.IP
    1.093: SetAltOsLoaderPath: No section uses DirId 65701; done.
    1.109: DoInstallation: FetchSourceURL for
    c:\81df2d35604a496cf0c9\update\update_SP2GDR.inf failed
    1.109: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll
    failed: 0xe0000102
    1.125: BuildCabinetManifest: update.url absent
    1.125: Starting AnalyzeComponents
    1.125: AnalyzePhaseZero used 0 ticks
    1.125: No c:\windows\INF\updtblk.inf file.
    1.125: OEM file scan used 0 ticks
    1.234: AnalyzePhaseOne: used 109 ticks
    1.234: AnalyzeComponents: Hotpatch analysis disabled; skipping.
    1.234: AnalyzeComponents: Hotpatching is disabled.
    1.234: FindFirstFile c:\windows\$hf_mig$\*.*
    1.265: AnalyzeForBranching used 0 ticks.
    1.265: AnalyzePhaseTwo used 0 ticks
    1.265: AnalyzePhaseThree used 0 ticks
    1.265: AnalyzePhaseFive used 0 ticks
    1.390: AnalyzePhaseSix used 125 ticks
    3.593: AnalyzeComponents used 2468 ticks
    3.593: Downloading 0 files
    3.593: bPatchMode = FALSE
    3.593: Inventory complete: ReturnStatus=0, 2484 ticks
    4.203: CreateUninstall = 0,Directory = C:\WINDOWS\$NtUninstallKB883939$

    4.203: Num Ticks for invent : 3094
    4.203: VerifySize: Unable to verify size: Source = NULL:
    c:\windows\inf\HFX3D.tmp
    4.218: Copied file: c:\windows\inf\branches.inf
    9.656: Allocation size of drive C: is 4096 bytes, free space =
    61400776704 bytes
    9.671: Drive C: free 58556MB req: 5MB w/uninstall 0MB
    9.671: CabinetBuild complete
    9.671: Num Ticks for Cabinet build : 5468
    9.671: DynamicStrings section not defined or empty.
    9.671: FileInUse:: need to restart already, turn off
    10.687: LoadFileQueues: UpdSpGetSourceFileLocation for halmacpi.dll
    failed: 0xe0000102
    14.640: System Restore Point set.
    14.703: Copied file: C:\WINDOWS\system32\spmsg.dll
    14.781: PFE2: Not avoiding Per File Exceptions.
    15.000: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\update_SP2QFE.inf ->
    c:\windows\$hf_mig$\KB883939\update\update_SP2QFE.inf.
    15.109: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\spuninst.exe ->
    c:\windows\$hf_mig$\KB883939\spuninst.exe.
    15.250: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\spmsg.dll ->
    c:\windows\$hf_mig$\KB883939\spmsg.dll.
    15.390: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\spcustom.dll ->
    c:\windows\$hf_mig$\KB883939\update\spcustom.dll.
    15.421: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\KB883939.CAT ->
    c:\windows\$hf_mig$\KB883939\update\KB883939.CAT.
    15.546: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\update.exe ->
    c:\windows\$hf_mig$\KB883939\update\update.exe.
    15.625: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\updspapi.dll ->
    c:\windows\$hf_mig$\KB883939\update\updspapi.dll.
    15.687: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\update.ver ->
    c:\windows\$hf_mig$\KB883939\update\update.ver.
    15.765: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\updatebr.inf ->
    c:\windows\$hf_mig$\KB883939\update\updatebr.inf.
    15.765: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\eula.txt ->
    c:\windows\$hf_mig$\KB883939\update\eula.txt.
    15.781: ProcessSetupContentSection: PROCESS_SETUP_CONTENT_OP_INSTALL:
    Copied c:\81df2d35604a496cf0c9\update\branches.inf ->
    c:\windows\$hf_mig$\KB883939\update\branches.inf.
    15.812: DoInstallation: Installing assemblies with source root path:
    c:\81df2d35604a496cf0c9\
    15.812: Num Ticks for Copying files : 6141
    15.843: Num Ticks for Reg update and deleting 0 size files : 31
    16.031: UpdateSpUpdSvcInf: Source [ProcessesToRunAfterReboot] section
    is empty; nothing to do.
    19.000: RebootNecessary = 0,WizardInput = 0 , DontReboot = 1,
    ForceRestart = 0
     
    3gemail, Jul 8, 2005
    #1
    1. Advertisements

  2. If it keeps asking to reinstall it means that something is regressed
    or the update was only partially done. Unfortunately, AU is not designed
    to recognize this case.

    Try *uninstalling* the update and then reinstalling it.
    If you're still having trouble after that your log will have to show
    a number of copy steps (including deferred copy steps)
    which aren't happening now.

    You are creating your own log? Do you still have the original KB883939.log?
    Comparing the two could show you what is missing from this one
    and might even reveal how a regression/partial update occurred.

    ....
    This is where the copy steps to System32 should be occurring.
    A Reboot should be necessary to do the deferred copy steps.

    If you have any security software which might be blocking those
    copy steps disable it before starting the install phase and leave
    it disabled until after the boot.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jul 12, 2005
    #2
    1. Advertisements

  3. 3gemail

    Peter Guest

    I have also been having problems with KB883939. The installation is
    successful, with no apparent errors, but the log file always has the
    "In Function Set VolatileFlag, line ######, RevOpenKeyEx failed with
    error 0x2" error. If this was isolated to just one computer, I would
    reformat and reinstall Windows 2000, but this is happening on quite a
    few computers, and my customers are looking to me for some sort of
    resolution. A search of the Microsoft web site has proven fruitless.
    Has anyone not only encountered this particular problem, but also
    resolved it?
    Thanks.
    Peter


     
    Peter, Jul 20, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.