KB917537 loop

Discussion in 'Windows Update' started by Bruce Chastain, Jul 12, 2006.

  1. OK, so what you need to do is create an empty dummy file at the location
    C:\WINDOWS\System32\inetsrv\asp.dll
    and let the updater update it. Then the update will go away for ever.
     
    Robin Walker [MVP], Jul 17, 2006
    #81
    1. Advertisements

  2. Bruce Chastain

    Rick Guest

    I've just had the same problem. I stopped IIS, re-ran the update, and the
    update installed correctly. Restarted IIS and all is ok - it may be a problem
    with the update not stopping IIS services correctly before applying (i.e. IIS
    locks out the dll update)
     
    Rick, Jul 17, 2006
    #82
    1. Advertisements

  3. Bruce Chastain

    Mike Thommes Guest

    I copied the asp.dll file from an unaffected system to
    %systemroot%\system32\inetsrv and this problem went away. I believe the
    ...\inetsrv directory had been created previously by an install of the IIS
    admin tools. These tools, I believe, were removed some time later but the
    removal must have been incomplete.

    Mike Thommes
     
    Mike Thommes, Jul 17, 2006
    #83
  4. I'm experiencing the same issue on windows 2003 server. This is what appears
    in the event viewer.

    Event Type: Error
    Event Source: NtServicePack
    Event Category: None
    Event ID: 4379
    Date: 7/16/2006
    Time: 10:39:56 PM
    User: Administrator
    Computer: MAYA2
    Description:
    Windows Server 2003 Hotfix KB917537 installation failed.
    KB917537 installation did not complete.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.

    It keeps asking me to restart the server to accept the update, but it merely
    goes through an endless loop of restarting the server.

    Has anyone found a solution?
     
    Albert Frausto, Jul 18, 2006
    #84
  5. Bruce Chastain

    Dave Berry Guest

    Had the same problem with several PCs and servers. I wound up installing
    IIS, patching it and then removing it on one of the XP machines. Putting
    asp.dll in %systemroot%\system32\inetsrv did the trick and was much simpler.
    Thanks
     
    Dave Berry, Jul 18, 2006
    #85
  6. Bruce Chastain

    Ben Guest

    I'm having the same looping problem. I tried the tasklist command and it
    said no modules were found matching my criteria. I also searched the WINDOWS
    directory for asp.dll and it doesn't exist.
     
    Ben, Jul 18, 2006
    #86
  7. Bruce Chastain

    Ben Guest

    This worked for me too. Thanks!

     
    Ben, Jul 18, 2006
    #87
  8. Bruce Chastain

    Jim Guest

    I have the same loop on my systems as well. I am using SMS 2003 with ITMU and
    the problem shows up on 540 XP SP pro systems.
     
    Jim, Jul 18, 2006
    #88
  9. That is the problem. Try creating a dummy empty file at location
    C:\WINDOWS\System32\inetsrv\asp.dll
    then try the update again.
     
    Robin Walker [MVP], Jul 18, 2006
    #89
  10. Yes, it does! It hosed my WMI and I had to rebuild that from the Windoes
    w/SP2 CD. WMI works fine now, but system info was hosed untill I figured it
    out.
     
    Tim in Alaska, Jul 18, 2006
    #90
  11. Bruce Chastain

    Jim Guest

    I had 500 systems with this issue and only 56 reported as having it
    installed. The rest were reinstalling every night. I kept updating my scan
    package for ITMU and this morning it looks like the systems are reporting
    properly (57 installed 62 applicable). MS must have made a correction in the
    XML file. Anyone else go this route?
     
    Jim, Jul 19, 2006
    #91
  12. Bruce Chastain

    TomH Guest

    I think meanwhile (7/19/2006?) MS has solved the looping-problem in the
    detection-routine.
    There are new revisions of KB917537 in our WSUS and fewer systems are
    requiring this update. Thanks MS!
     
    TomH, Jul 20, 2006
    #92
  13. Bruce Chastain

    Mantra6 Guest

    I am having a similar issue on a Windows XP machine, but now the update is
    failing, where before it was looping.
     
    Mantra6, Jul 20, 2006
    #93
  14. Bruce Chastain

    Mantra6 Guest

    Mantra6, Jul 20, 2006
    #94
  15. Bruce Chastain

    Louison Guest

    As Thomas Cook I solved the
    problem by copying asp.dll from another machine to %windir%\system32\inetsrv
    Then I install the hotfix successfully & the loop never appear again.

    Many Thanks to Thomas :)
     
    Louison, Aug 1, 2006
    #95
  16. Hi,

    I have the same problem with the patch KB956744 provided by WSUS: it create
    a loop
    only on a few machines, but the patch is correctly installed. No one have
    any idea or solution?

    Regards,

    Mattia
     
    Mattia Cargiolli, Feb 19, 2010
    #96
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.