KB931768 causes IE7 failure w/ navcancl & ieframe.dll &temp soluti

Discussion in 'Internet Explorer' started by tony, May 9, 2007.

  1. tony

    tony Guest

    I have been running Internet Explorer 7.0 on Windows Vista for several
    months and it was working fine. But today I just installed the "Security
    Update for Windows Internet Explorer 7 (KB931768)" and that caused IE7 to
    stop working.

    After I installed the update and restarted Windows, IE7 will no longer
    start. Now when I double-click the icon or run iexplore.exe, the web browser
    window flashes quickly on the screen and then disappears. Then this error
    message dialog box appears.

    ----------------------------------------------------------------------
    File Download - Security Warning
    Do you want to save this file?
    Name: navcancl
    Type: Unknown File Type, 2.64KB
    From: ieframe.dll
    Save Cancel
    ----------------------------------------------------------------------

    temporarily, I have three ways to fix it:
    1. retore Vista or uninstall the patch
    2. run IE as Administrator ( which, as a matter of fact, disable the
    protection mode)
    3. in IE Options->Securities->disable Protection Mode.
     
    tony, May 9, 2007
    #1
    1. Advertisements

  2. tony

    tony Guest

    It is Windows Vista Ultimate Edition.
     
    tony, May 9, 2007
    #2
    1. Advertisements

  3. tony

    tony Guest

    I have no add-ons and toolbars installed.
    BTW. People say ,in XP & Win2003, reinstalling IE7 can fix this problem. But
    I cannot do this, 'cause I am using Vista Ultimate. There is no corresponding
    IE7 Download for Vista, supplied by MS.
     
    tony, May 9, 2007
    #3
  4. tony

    Paolol Guest

    Same problem to me, I had to remove the KB931768 , but it keep reinstalling
    it :|
    Paolol
     
    Paolol, May 9, 2007
    #4
  5. tony

    F&F Guest

    Same problem for me as well, started the update and IE 7 stoped working. Are
    there any solutions known? I tried the deinstall of the update.
    At the moment i now use Mozilla ...
     
    F&F, May 9, 2007
    #5
  6. tony

    David Guest

     
    David, May 9, 2007
    #6
  7. tony

    David Guest

    I'm having the same problem with the Update but I'm using XP pro. I can't
    use IE7 at all much less check to see if there is a new update.
     
    David, May 9, 2007
    #7
  8. tony

    PA Bear Guest

    See 'Known issues with this security update > Controls that prompt before
    they are loaded' section of http://support.microsoft.com/kb/931768

    1. Try opening IE in No Add-ons mode & see if this behavior persists. If it
    doesn't, change your IE home page to "blank" then close IE7 and reopen
    normally (i.e., with all Add-ons enabled) and see if the behavior returns.

    2. If still no joy, reopen in No Add-ons mode, reset IE settings
    (http://support.microsoft.com/kb/923737), close IE, open normally and see if
    the behavior still persists.

    This is all related to a cross-site security vulnerability addressed by
    MS07-027/KB931768: http://secunia.com/advisories/24535/

    Also try this fix, courtesy of MVP Robert Aldwinckle:

    Start > Run > Type or copy/paste the following into the box:

    iexplore.exe -nohome -extoff

    [Note the spaces in the line above!]
     
    PA Bear, May 10, 2007
    #8
  9. tony

    PA Bear Guest

    UPDATE: See if this webpage of MVP Mike Burgess' addresses the problem:
    http://mvps.org/winhelp2002/hostsfaq.htm#message
    --
    ~PA Bear

     
    PA Bear, May 10, 2007
    #9
  10. tony

    PA Bear Guest

    Follow-up: Right-click the Cancelled message > Select Properties > Write
    down exactly what's shown in Address (URL) line and post it in a reply to
    this thread.

    Also see if disabling Phishing Filter makes any difference (Tools > Internet
    Options > Advanced > Security).
    --
    ~PA Bear

     
    PA Bear, May 10, 2007
    #10
  11. tony

    tony Guest

    You know what, since I set about:blank as my default homepage, I can
    guarantee you this is nothing to do with the URL. As a matter of fact, of
    this issue there is no chance for you to perform your follow-up. The main IE7
    window is just like a quick flash, it poped up and closed at once, then left
    a popup window showing some info like the following( it's just like you are
    trying to download some unknown filetype thing):
    PS. either disabling Phishing Filter really or disable protection mode does
    help. But any way it compromises the browser's security, isn't it.







     
    tony, May 10, 2007
    #11

  12. What we'd like to know is if it's being caused by

    res://ieframe/navcancl.htm

    Normally when you use the -nohome switch and click the Stop button
    that shows up in the Address bar.

    E.g. Run... (press Win-R and enter:)

    iexplore.exe -nohome -extoff

    and click the Stop button. What happens?


    Well you could at least open the TIF Viewer using Internet Options
    (e.g. from the Control Panel) to see what is listed last in the view sorted by
    Last Accessed...

    If this is for XP with default TIF location you could also just open
    %USERPROFILE%\Local Settings\Temporary Internet Files

    Or open the History...

    Hmm... that's interesting. Navcancl doesn't show in the History viewer
    but it does show in the TIF viewer. Who knew? <eg>


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, May 10, 2007
    #12
  13. tony

    tony Guest

    Problem solved!

    I've solved this problem by restoring the temporary internet files folder
    the default folder. I changed the TIF folder for some reasons, but now I
    have to chage it back to solve this problem. The default folder in Vista
    should be like:
    C:\Users\%YOUR_USER_NAME%\AppData\Local\Microsoft\Windows\Temporary Internet
    Files
     
    tony, May 11, 2007
    #13
  14. tony

    Bradio Guest

    Solved it for me as well. I had moved the temp folder to another partition.

    When I moved it back to the default location, reapplied KB931768 (I had
    uninstalled it) and then re-booted, IE7 worked again. I am using XP SP2.
     
    Bradio, May 11, 2007
    #14
  15. tony

    PA Bear Guest

    [Posted & mailed; X-post to Windows Update newsgroup]

    Why did (any of) you change TIF's default location in the first place?

    Did (all of) you change the default to a drive other than the one on which
    Windows is installed (typically C:\Windows)?
     
    PA Bear, May 11, 2007
    #15

  16. Good news.


    So perhaps instead you could have also solved it with permissions?
    E.g. check the two folders with cacls and see what the difference is?
    ProcMon might have helped diagnose this too, e.g. by providing an
    interleaved trace of both registry and file accesses when you recreate
    the symptom.


    Interesting outcome. Thanks for sharing your solution.


    Robert
    ---
     
    Robert Aldwinckle, May 11, 2007
    #16
  17. tony

    sam Guest

    OK, so I'm not clever enough to have moved the TIF file deliberately. I am
    getting the same messages as everyone and it is fixed by turning off the
    phishing filter. Can someone put it in laymans terms what I have to check and
    do to fix this issue, because you lot have lost me! it begun causing me
    problems unexpectedly in the middle of a session with no apparent cause or
    change in the system.
    Please help, I need my tabs!

     
    sam, May 14, 2007
    #17
  18. You're on Windows XP SP2? If true, you may wanna try the following:

    #1 Close all open IE windows
    #2 Start -> Run -> cmd [Enter]
    #3 Type the following line in the "DOS prompt" window:
    rd /s /q "%userprofile%\Local Settings\Temporary Internet Files\Antiphishing"
    and hit [Enter] afterwards.

    Start IE, reenable the PhishingFilter in the Internet Options ->
    Advanced if you want to and hope, that the error(s) are gone.

    Bye,
    Freudi
     
    Ottmar Freudenberger, May 14, 2007
    #18
  19. tony

    PA Bear Guest

    I'm not clever enough to have moved the TIF file deliberately

    Where is your TIF /folder/ currently located?

    See IE Tools > Internet Options > General > Browsing history > Settings.
    --
    ~Robear Dyer (PA Bear)
    MS MVP-Windows (IE, OE, Security, Shell/User)
    AumHa VSOP & Admin; DTS-L.org


     
    PA Bear, May 14, 2007
    #19
  20. tony

    deansandrew Guest

     
    deansandrew, May 15, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.