KB948109 Update Error Code 0x733F

Discussion in 'Windows Update' started by Mike Moore, Jul 9, 2008.

  1. Mike Moore

    Cj00098 Guest

    and yes ,, when it was unticked ,,, it was a successful update,,,

    so,, thank you,,,,,, for your help,,,, Cj 00098
     
    Cj00098, Jul 10, 2008
    #41
    1. Advertisements

  2. Mike Moore

    Cj00098 Guest

    "Tornalca" gets a GOLD STAR,,,,, From Cj00098,, thank you,,,,
     
    Cj00098, Jul 10, 2008
    #42
    1. Advertisements

  3. Mike Moore

    Terry Guest

    I have tried downloading the update from

    http://www.microsoft.com/downloads/...cc-2c4c-4190-872c-84993a7623b7&DisplayLang=en

    and running it.

    I have no SQL express running on my windows SBS 2003 sp2 so that didn't make
    any difference.

    When I look at the log file I get

    Product : SQL Server Database Services 2005 (MSSQLSERVER)
    Product Version (Previous): 3054
    Product Version (Final) :
    Status : Failure
    Log File : XXXXXX\Microsoft SQL Server\90\Setup
    Bootstrap\LOG\Hotfix\SQL9_Hotfix_KB948109_sqlrun_sql.msp.log
    Error Number : 29506
    Error Description : MSP Error: 29506 SQL Server Setup failed to
    modify security permissions on file XXXXXX\Microsoft SQL
    Server\MSSQL.1\MSSQL\Data\ for user Administrator. To proceed, verify that
    the account and domain running SQL Server Setup exist, that the account
    running SQL Server Setup has administrator privileges, and that exists on
    the destination drive.

    Which indicates that the administrator is denied access to the folder
    permissions? I have tried this with SQL instances started and stopped

    Does anyone have any ideas?
     
    Terry, Jul 10, 2008
    #43
  4. Mike Moore

    Paul Guest

    Unchecking SQL express worked for me but how do I update SQL express?
     
    Paul, Jul 10, 2008
    #44
  5. Mike Moore

    Luc Guest

    Reinstalling SQL Server (and SP2) helped, the KB948109 update now installed
    as smooth as it should have all along (the automatic update, I didn't have
    to use the interactive one).

    But if each update is going to require this kind of hassle from now on,
    methinks I'm gonna have to put up a job sign for an update installer.





    BTW1: along the way I found that I had to FULLY uninstall not only SQL
    server, but also surrounding stuff (SQL Native Client, VSS writer), or I
    couldn't even get it reinstalled. Setup failed.

    BTW2: after my second uninstall (see BTW1), before I got around to
    reinstalling, something odd came up: windows update insisted that I needed
    the latest Office 2003 service pack.
    This is a clean Vista setup with Office 2007, no Office 2003 aboard.
    When I let it go along the SP setup reported success, but too fast to have
    done much. I think it didn't even create a restore point.
     
    Luc, Jul 10, 2008
    #45
  6. Mike Moore

    Keith Guest

    I acutally got this to work but here is what I had to do. Running this
    update downloaded as shown above by Tornalca, I noticed that when I ran it
    the first time it failed at an authentication point. I was logged in as the
    server admin as well. I just tried running it as the domain SQL server admin
    and it worked fine. Don't know if this will help you or not. But the local
    admin, and a domain user with local admin rights was not enough when it came
    to the database. I find that very strange. The update did complete
    successfully when I used the SQLadmin account however. Give that a shot I
    hope it helps!
     
    Keith, Jul 10, 2008
    #46
  7. Mike Moore

    Garth H Guest

    I am stuck with a similar problem, which appeared when I tried to install the
    KB948109 -- my original SQL Express 2005 SP2 installation must have been
    defective. Any way it created a service MSSQL$SQLEXPRESS which would never
    start because of not authorized for access errors regardless of what I did to
    authorize the user.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    If you have had an aborted install of SQL you may expect this problem.
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    So I uninstalled SQL Express completely and reinstalled.

    However, it still found, but would not accept, the old service
    MSSQL$SQLEXPRESS and would only proceed if I specified "Use Default"

    This reinstall then went OK and reinstalled SQL Express creating a new
    service MSSQLSERVER.

    Now I applied the downloaded KB948109 as per Tornalca and it applied it
    successfully to the new valid service MSSQLSERVER but not to the old invalid
    service MSSQL$ SQLEXPRESS.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    So, how do I purge the invalid service MSSQL$SQLEXPRESS from my machine?
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
    Garth H, Jul 10, 2008
    #47
  8. Mike Moore

    Randy Martin Guest

    Your supposition about database file location clicked for me. We had a
    similar issue on the SP2 (or SP1?) install with the mssqlsystemresource DB.

    My problem was that the distmdl.mdf and distmdl.ldf were not in the same
    folder as master, or possibly mssqlsystemresource. I copied them there, did
    the automatic update, and everything was fine.
     
    Randy Martin, Jul 10, 2008
    #48
  9. Mike Moore

    Alessandro Guest

    I had the same error code but after some unsuccesful attemps I saw that some
    Services related to SQL_SERVER were stopped and prevented the correct
    installation of the update. I fixed starting up these services and
    relaunching the update process.

    Hope this will help,
    Alessandro
     
    Alessandro, Jul 10, 2008
    #49
  10. From MS Support:

    <QP>
    Error: 733F-- Services Failed to Start

    Description: This error occurs when the installation program can’t start the
    SQL Server services. This can happen for several reasons including: expired
    account password, invalid user account, user account does not have
    permission to start the service, or there is something else wrong with the
    service.

    Resolution: To help you determine which service is failing to start, view
    the summary.txt file that is created at...

    %programfiles%\Microsoft SQL Server\90\Setup Bootstrap\Log\Hotfix

    Once you determine which service is failing, do the following:

    1. Click Start, point to Settings, and then click Control Panel.

    2. Double-click Administrative Tools, and then double-click Services.

    3. Locate the SQL Server service causing the problem and try to manually
    start the service.

    4. If the service still does not start, try resetting the password or the
    user account. After doing this, restart the service manually

    More information, see: http://support.microsoft.com/kb/282254

    If you need additional help, please post your summary.txt file located at

    %programfiles%\Microsoft SQL Server\90\Setup Bootstrap\Log\Hotfix

    to the SQL Server Setup MSDN forum at
    http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=95&SiteID=1
    </QP>
     
    PA Bear [MS MVP], Jul 11, 2008
    #50
  11. Mike Moore

    Myaushka Guest

  12. Mike Moore

    Myaushka Guest

    Myaushka, Jul 11, 2008
    #52
  13. Mike Moore

    uzr Guest

    did not work for me either. Besides, automatic update is supposed to be
    automatic.
     
    uzr, Jul 11, 2008
    #53
  14. Mike Moore

    uzr Guest

    nogo

     
    uzr, Jul 11, 2008
    #54
  15. I've searched the internet to find some hints.
    One hint was to deactivate the VIA protocol, but on the specific computer
    the VIA protocol was not activated yet.
    One hint points to an authentification problem and suggested to set the
    proper rights for the update process to modify some registry

    keys, but it was not said what keys.
    There were no compressed master database or log files.
    The event protocols proved that there were problems with the MSO
    SmallBusiness SQL server MSSQL$MSSMLBIZ, which was

    installed along with the SQL Express server MSSQL$SQLEXPRESS.

    Some error descriptions (german):
    Die Beschreibung der Ereigniskennung ( 17182 ) in ( MSSQL$MSSMLBIZ ) wurde
    nicht gefunden. Der lokale Computer verfügt nicht

    über die zum Anzeigen der Meldungen von einem Remotecomputer erforderlichen
    Registrierungsinformationen oder

    DLL-Meldungsdateien. Möglicherweise müssen Sie das Flag /AUXSOURCE= zum
    Ermitteln der Beschreibung verwenden. Weitere

    Informationen stehen in Hilfe und Support. Ereignisinformationen: 5; 1 / 51.

    Die Ereignisprotokolldatei ist beschädigt.

    Produkt: Microsoft SQL Server 2005 Express Edition -- Fehler 29503. Fehler
    beim Starten des SQL Server-Dienstes. Weitere

    Informationen finden Sie in den Themen 'Vorgehensweise: Anzeigen der SQL
    Server 2005-Setupprotokolldateien' und 'Manuelles

    Starten von SQL Server' in der SQL Server-Onlinedokumentation.
    Fehler: (5) Zugriff verweigert.

    Ereignisinformationen: FRunCM.

    Produkt: Microsoft SQL Server 2005 Express Edition - Update "GDR 3068 for
    SQL Server Database Services 2005 ENU

    (KB948109)" konnte nicht installiert werden. Fehlercode 1603. Weitere
    Informationen sind in der Protokolldatei ... enthalten.

    Die Beschreibung der Ereigniskennung ( 17053 ) in ( MSSQL$MSSMLBIZ ) wurde
    nicht gefunden. Der lokale Computer verfügt nicht

    über die zum Anzeigen der Meldungen von einem Remotecomputer erforderlichen
    Registrierungsinformationen oder

    DLL-Meldungsdateien. Möglicherweise müssen Sie das Flag /AUXSOURCE= zum
    Ermitteln der Beschreibung verwenden. Weitere

    Informationen stehen in Hilfe und Support. Ereignisinformationen:
    UpdateUptimeRegKey; 5(Zugriff verweigert).


    At last of my one-day-research I've decided to complete uninstall the MSO
    SmallBusiness SQL server MSSQL$MSSMLBIZ and leave

    the SQL Express server.
    Afterwards the MS Update process runs the July 2008 Patch without any errors.

    Now it is left to me to install the MSO SmallBusiness SQL server
    MSSQL$MSSMLBIZ again and see what will happen.

    DD.20080711.0800.CEST
     
    Detlev Dalitz, Jul 11, 2008
    #55
  16. Mike Moore

    Frank Guest

    I had the same experience. I have a computer running XP Professional Service
    Pack 3.
     
    Frank, Jul 11, 2008
    #56
  17. I had this problem too.

    I had the services' startup type listed below set to "Disabled". Changed to
    "Manual" and was able to successfully install the update.

    SQL Server Active Directory Helper
    SQL Server Browser
    SQL Server VSS Writer
     
    Grumpy Developer, Jul 12, 2008
    #57
  18. Mike Moore

    uzr Guest

    does not work

     
    uzr, Jul 12, 2008
    #58
  19. Mike Moore

    Mike Wotton Guest

     
    Mike Wotton, Jul 12, 2008
    #59
  20. Mike Moore

    Mike Wotton Guest

    Cannot find error code 0x733F anywhere. MS not being helpfull at all. Just
    going around in circles.
     
    Mike Wotton, Jul 12, 2008
    #60
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.