KB948109 Update Error Code 0x733F

Discussion in 'Windows Update' started by Mike Moore, Jul 9, 2008.

  1. Mike Moore

    Mike Wotton Guest

    I might be simple, but if MS find an error and give it an identification
    name, why when you ask what it is, they do not recognise it.
     
    Mike Wotton, Jul 12, 2008
    #61
    1. Advertisements

  2. If you're not getting that error, why are you posting a reply to this
    thread, Mike?

    Have you opened a *free* support incident yet?

    Start a free Windows Update support incident request:
    https://support.microsoft.com/oas/default.aspx?gprid=6527

    Support for Windows Update:
    http://support.microsoft.com/gp/wusupport

    For home users, no-charge support is available by calling 1-866-PCSAFETY in
    the United States and in Canada or by contacting your local Microsoft
    subsidiary. There is no-charge for support calls that are associated with
    security updates. When you call, clearly state that your problem is related
    to a Security Update and cite the update's KB number.

    For more information about how to contact your local Microsoft subsidiary
    for security update support issues, visit the International Support Web
    site: http://support.microsoft.com/common/international.aspx

    For enterprise customers, support for security updates is available through
    your usual support contacts.
     
    PA Bear [MS MVP], Jul 12, 2008
    #62
    1. Advertisements


  3. Convert to decimal and search. Then go to a more appropriate newsgroup
    or forum.

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=324158&SiteID=1

    (Live Search for
    29503 MSFT site:microsoft.com
    )


    ---
     
    Robert Aldwinckle, Jul 12, 2008
    #63
  4. Mike Moore

    seeker Guest

    I have a totally new wrinkle on this. Apparently there are a myriad of
    things that can cause this. In my case, I do not run SQL-SERVER unless I
    need it: it and its related services are set to manual. Well…… over time the
    folder’s lack of use make it a candidate for auto-compression. So the
    install couldn’t start the engine because it was compressed and needed
    uncompressing. (Found in the Event log). To uncompress select all files in
    the folder, go to the advanced button and uncheck the compress to save space
    check box. Start the server and related services then run the update. Or let
    the download run at next prompt to install.
     
    seeker, Aug 6, 2008
    #64
  5. Mike Moore

    Yalin Meric Guest

    Thanks Tornalco! You saved me from a disturbance. Although it is not nice to
    know this will leave a security hole in my local SQL server, it is not a big
    deal i guess.
     
    Yalin Meric, Aug 11, 2008
    #65
  6. Mike Moore

    Woolooloo Guest

    Ok, so I've had the same problem and none of the solutions in here worked.
    I went through the log files and made a couple changes that ended up working.

    1. Add registry key
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer\Debug - a
    REG_DWORD that I gave a value of 1.
    2. Make sure the SQL Server VSS Writer service is started. For me, the
    service was disabled. I put it in automatic mode and started it.

    After making these two changes, I reran the update and it worked. Hopefully
    this will help other people.
     
    Woolooloo, Aug 16, 2008
    #66
  7. Mike Moore

    Marco Guest

    Here is my log:

    Prerequisites Check & Status
    SQLSupport: Passed

    **********************************************************************************
    Products Detected Language Level Patch Level
    Platform Edition
    SQL Server Database Services 2005 (SQLEXPRESS) ENU SP2
    2005.090.3042.00 x86 EXPRESS
    SQL Server Tools and Workstation Components 2005 ENU RTM
    9.00.1406.00 x86 DEVELOPER

    **********************************************************************************
    Products Disqualified & Reason
    Product Reason
    SQL Server Tools and Workstation Components 2005 The product instance SQL
    Tools does not have prerequisite update 3042 installed. Update 3068 is
    dependent on prerequisite update 3042. Exit setup and refer to the Knowledge
    Base article to find the prerequisite patch. Install the prerequisite and
    rerun the installation.

    **********************************************************************************
    Processes Locking Files
    Process Name Feature Type User Name
    PID

    **********************************************************************************
    Product Installation Status
    Product : SQL Server Database Services 2005 (SQLEXPRESS)
    Product Version (Previous): 3042
    Product Version (Final) :
    Status : Failure
    Log File : C:\Program Files\Microsoft SQL Server\90\Setup
    Bootstrap\LOG\Hotfix\SQL9_Hotfix_KB948109_sqlrun_sql.msp.log
    SQL Express Features :
    Error Number : 29503
    Error Description : MSP Error: 29503 The SQL Server service failed
    to start. For more information, see the SQL Server Books Online topics, "How
    to: View SQL Server 2005 Setup Log Files" and "Starting SQL Server Manually."
    ----------------------------------------------------------------------------------
    Product : SQL Server Tools and Workstation Components 2005
    Product Version (Previous): 1406
    Product Version (Final) :
    Status : NA
    Log File :
    Error Description : The product instance SQL Tools does not have
    prerequisite update 3042 installed. Update 3068 is dependent on prerequisite
    update 3042. Exit setup and refer to the Knowledge Base article to find the
    prerequisite patch. Install the prerequisite and rerun the installation.
     
    Marco, Sep 9, 2008
    #67
  8. Mike Moore

    Walter Guest

    Mike - Your posting is dated 07.08.08, has there been any resolution since
    the time of your posting. I'm getting the same error, been hunting for a
    solution everywhere. Why is MS taking so long to fix (Rhetorical question)
    I Took the liberty of copying the entire message perhaps there's a clue...

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: hotfix.exe
    Application Version: 1.4.1548.0
    Application Timestamp: 48820815
    Fault Module Name: StackHash_e52f
    Fault Module Version: 0.0.0.0
    Fault Module Timestamp: 00000000
    Exception Code: c0000005
    Exception Offset: 002d002d
    OS Version: 6.0.6001.2.1.0.768.3
    Locale ID: 1033
    Additional Information 1: e52f
    Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
    Additional Information 3: 860f
    Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635

    Read our privacy statement:
    http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409
     
    Walter, Sep 29, 2008
    #68
  9. Mike Moore

    MOC Ewez Guest

    After trying all Buckets ideas
    "
    * Tried to get it to work using automatic updates - always failed.
    * Reboot PC - still failed.
    * Reinstalled automatic update software and try again - still failed.
    * Checked SQL server databases not compressed.
    * Checked SQL server instances running (tried all combinations of running
    and stopped).
    * Downloaded the X86 patch and installed manually - still failed.
    * Tried disabling parts of the patch (e.g. switch of SQL Express) - still
    failed.
    * Finally gave up and disabled the update!
    "

    I also tried:
    - Make sure Windows installer is okay.
    MSIExec /Unreg
    MSIExec /RegServer

    - These had help me before with WU problems
    (Only the top one was necessary then)
    regsvr32 wups2.dll
    regsvr32 wuapi.dll
    regsvr32 wuaueng.dll
    regsvr32 wuaueng1.dll
    regsvr32 wucltui.dll
    regsvr32 wups.dll
    regsvr32 wups2.dll
    regsvr32 wuweb.dll

    - Update Windows installer from 3.1 to 4.5
    http://www.microsoft.com/downloadS/...6F-60B6-4412-95B9-54D056D6F9F4&displaylang=en

    - Turned off Windows Firewall (Didn't even know that it started after uninstalling McAfee firewall)

    None of these helped me.

    What did help though was indeed changing the Service Logon to local System Account

    This has been mentioned before and I thought I had tried it before. (Actually checked it many times)
    Turns out the Service name is:
    SQL Server (Express)
    And not MSSQLServer (\....)

    A blindman's error yes, but you guys know how it is staring at a problem for so many hours....
     
    MOC Ewez, Oct 7, 2008
    #69
  10. Mike Moore

    Duke Guest

    I get the error when I download it and install manually as well.
     
    Duke, Nov 12, 2008
    #70
  11. Mike Moore

    TaurArian Guest

    Error: 733F-- Services Failed to Start

    Description: This error occurs when the installation program can't start
    the SQL Server services. This can happen for several reasons including:
    expired account password, invalid user account, user account does not have
    permission to start the service, or there is something else wrong with the
    service.

    Resolution: To help you determine which service is failing to start, view
    the summary.txt file that is created at %programfiles%\Microsoft SQL
    Server\90\Setup Bootstrap\Log\Hotfix. Once you determine which service is
    failing, do the following:



    1.
    Click Start, point to Settings, and then click Control Panel.

    2.
    Double-click Administrative Tools, and then double-click Services.

    3.

    4.
    Locate the SQL Server service causing the problem and try to manually
    start the service.

    If the service still does not start, try resetting the password or the
    user account. After doing this, restart the service manually


    More information: http://support.microsoft.com/kb/282254/en-us

    If you need additional help, please post your summary.txt file located at
    %programfiles%\Microsoft SQL Server\90\Setup Bootstrap\Log\Hotfix to the SQL
    Server Setup MSDN forum at
    http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=95&SiteID=1




    --

    TaurArian [MVP] 2005-2009 - Update Services
    http://taurarian.mvps.org
    ======================================
    How to ask a question: http://support.microsoft.com/kb/555375
    Disclaimer: The information has been posted "as is" with no warranties or
    guarantees and doesn't give any rights.
    Computer Maintenance: Acronis / Diskeeper / Paragon / Raxco
     
    TaurArian, Nov 13, 2008
    #71
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.