Keyboard layout changes

Discussion in 'Windows Vista General Discussion' started by aleangelico, Apr 6, 2008.

  1. aleangelico

    aleangelico Guest

    Hi
    I write document in english and spanish, so I have to use the US and the
    US-International keyboard layout. I have the keyboard bar active and use it
    to change layouts.
    The problem is the keyboard layout changes "by himself" constantly. I
    thought this was attached to the program I'm using, or the document, but it's
    not.
    For example, I'm writing a WinWord 2007 document using the Intl layout, and
    using accents and everything. Suddenly, I try to use another accent or
    symbol, and it doesn't work. If I check the language bar, it changed to US
    Standard layout.
    I disabled the shortcuts to change layouts, so this is not the problem (I
    mean, accidentally hitting the shortcut...)

    Any ideas?
    It's really very annoying...

    Alex
     
    aleangelico, Apr 6, 2008
    #1
    1. Advertisements

  2. aleangelico

    Earle Horton Guest

    Right click the language bar, open "Settings" and change "English" so that
    it uses "United States-International" keyboard. If you want to type " or '
    you will have to type a space or non-vowel afterwards. I have French,
    German, Spanish and English cheerfully coexisting on my computer. Another
    way to address this problem is to use US keyboard and Word keyboard
    shortcuts for international characters.

    Salu2 cordiales,

    Earle
     
    Earle Horton, Apr 7, 2008
    #2
    1. Advertisements

  3. aleangelico

    aleangelico Guest

    Ok, but I want to have both layouts and be able to change to the one I want.
    What I don't want is the layout to change by its own!
    Why this is happening?

    Alex
     
    aleangelico, Apr 7, 2008
    #3
  4. aleangelico

    Jonatan Guest

    This exact same thing happens to me too! I send emails and write documents in
    swedish, norwegian and english and change the keyboard accordingly. At first
    I thought I accidentally hit some shortcut to change back, or the changes
    were time-dependent but I have now realized they are just random. And they
    always fall back to english, never ever from for example swedish to
    norwegian. It is REALLY annoying! I cannot see how randomness would disappear
    by changing to US international?
     
    Jonatan, Apr 22, 2008
    #4
  5. aleangelico

    aleangelico Guest

    It doesn't...

    I don't know, i wasn't able to find any help about this issue. The only
    thing I did was changed the icons for the languages, so just looking the task
    bar i know wich one is active.

    I think the OS tries to remember the setting for each application, or even
    for each paragraph, so if you were writing in Word with a keyboard, if you
    change to notepad, the keyboard changes. The problem is if you come back to
    word, it could retain the former setting or change it "at will"

    This is what happens when the software developers are sure they are smarter
    than the users, they want the OS to think for you, and it does (the OS) a
    lousy job!!

    Regards
    Alex
     
    aleangelico, Apr 22, 2008
    #5
  6. aleangelico

    Earle Horton Guest

    It doesn't, but it ceases to bother. "Ã…" or any other character you care to
    type is the same in English, French, Spanish or German. When the software
    changes my input language, I just keep typing. I don't know for sure, but I
    think you can get Swedish or Norwegian characters with US International too.

    Do any of these look familiar? ð à Æ Ø Þ þ å ß ø

    Earle
     
    Earle Horton, Apr 23, 2008
    #6
  7. aleangelico

    Anorell Guest

    You can go into Control panel and start Regional and language settings:
    select the tab Languages
    press button Details
    In the dialogue that opens up you can press the button:
    Key settings
    In the new window press button Change key sequence
    uncheck the two checkboxes.

    This will prevent inadvertent change of keyboard layout

    Default is left shift + alt to change input languag
     
    Anorell, Jan 29, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.