Keyboard Layout in DOS Mode

Discussion in 'Windows Vista General Discussion' started by Fabrizio, Nov 21, 2007.

  1. Fabrizio

    Fabrizio Guest

    Hi There ,

    i'm an Itasian user of Vista.
    I have italian keyboard
    I use still a DOS program

    I have tihs strange error:
    when i open a command window the keyboard layout works fine, but when i
    enter in EDIT the layout is set in English mode. When i start my DOS program
    the layout is set in English mode.

    Now KEYB command don't work till Windows XP version.
    How can i set in config.nt or autoexec.nt the keyboard to have italian
    layout ?

    THX
    F.
     
    Fabrizio, Nov 21, 2007
    #1
    1. Advertisements

  2. The command prompt CMD.EXE is a 32-bit aplication so it uses the Win32 NLS
    setting you configure in Control Panel, Regional Settings. But when you
    start a DOS application like EDIT, the DOS app reads the NLS settings from
    thw DOS environment of the NTVDM; not the Win32 settings.

    In Vista the DOS KEYB command is replaced by KB16.

    First, test that KB16 runs okay, by entering the command:

    C:\Windows\System32\KB16 IT,850,C:\Windows\System32\KEYBOARD.SYS

    .... to enable an Italian keyboard. KB16 should return to a command prompt,
    with no messages (error, or otherwise). The Italian keyboard will remain
    active until you close the DOS prompt.

    On Windows NT (including 2000, XP and Vista) a DOS application takes its
    startup environment from the files C:\Windows\System32\Config.NT and
    C:\Windows\System32\Autoexec.NT. So to activate a code page for a DOS app,
    add the Italian code page commands to C:\Windows\System32\CONFIG.NT and
    C:\Windows\System32\AUTOEXEC.NT, the same as you would to C:\CONFIG.SYS and
    C:\AUTOEXEC.BAT on a DOS machine.

    In CONFIG.NT add to the end of the file:

    COUNTRY=039,850,C:\Windows\System32\COUNTRY.SYS

    In AUTOEXEC.NT add to the end of the file:

    C:\Windows\System32\KB16 IT,850,C:\Windows\System32\KEYBOARD.SYS

    Now to test, open a Command Prompt.
    Then run the command "command.com". This will start an instance of the
    MS-DOS Command processor.
    Run the command "edit", to start the DOS editor.
    Try typing in a few words in Edit, to see if the new Italian keyboard is in
    effect.

    Hope it helps,
     
    Andrew McLaren, Nov 22, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.