Large SATA hard drive (250 gig) - XP64

Discussion in 'Windows 64 Bit' started by Shane, Jul 22, 2005.

  1. Shane

    Shane Guest

    Hey all,

    I have a new problem - After I installed XP 32-bit and then went back to XP
    64-bit, all of a sudden my hard drive is limited to the old 130 gig thing.
    The XP-64 install only sees the 130 gig. How do I get my 250 gig hard drive
    to show up properly again?

    It is a Hitachi DeathStar SATA 250 gig drive

    Here's what I have tried:

    1) boot up with an ME floppy, run fdisk, delete the unknown partition, and
    run the XP64 setup
    no luck

    2) set in the bios from Auto to Large, on disk access
    no luck

    3) enable/disable raid support in BIOS

    4) look for the bigdrive (or whatever) registry entry, but it does not
    exits - and I think it is not supposed to in XP64, but I could be wrong.

    I could swear (but am starting to feel dillusional) that when I installed XP
    64 fresh on the drive when it was brand new, that it saw all 250 gigs. I
    just don't know anymore. any ideas?

    Oh yeah, I also updated the BIOS

    Thanks,
    Shane
     
    Shane, Jul 22, 2005
    #1
    1. Advertisements

  2. Shane

    M. Murcek Guest

    x64 Edition definitely saw all 250GB on the Hitachi SATA disks I installed.
    Have you tried booting with the x64 CD, delete any existing partitions
    there, create a new partition for the whole disk and continue the install
    from there? I sure wouldn't mess with an ME boot disk.
     
    M. Murcek, Jul 22, 2005
    #2
    1. Advertisements

  3. Shane

    Shane Guest

    At least I know I'm not out of my mind. Thanks for the info.

    So to answer your question, I did in fact try to boot up with x64, delete
    all partitions (there was only one), and try to create a new one. The
    problem is that it only shows 130 gig. x64 actually thought that 130 gog
    was all I had on that drive.

    My guess, however incorrect it may be, is that x32 put some crappy
    boundaries on the hard drive that x64 is reading. My next thought is to
    wipe it with a linux fdisk. Also, I didn't fdisk the mbr, but should I
    really have to? Any other ideas?

    Shane
     
    Shane, Jul 22, 2005
    #3
  4. Shane

    Jimmy! Guest

    FAT32 = nono for 200gb+ drives. I hope for your life that you don't use
    FAT32 or SO HELP YOU GOD!

    JimmY! :D

    --
    "The last that ever she saw him, carried away by a moonlight shadow.
    He passed on worried and warning, carried away by a moonlight shadow." -
    Groove Coverage - Moonlight Shadow

    "Hold the line...Love isn't all way on time...no woah woah woah!" - Toto -
    Hold the line.

    "And I miss you...Like the deserts miss the rain..." - Missing - Everything
    but the girl.

    "No TV and no beer make Homer something something...(Go crazy?)...DON'T MIND
    IF I DO! MUAHSAHADHDA WEE BLEAGAGS EGSAR WEE ZZZZ IZZ ZIZ Z RAH!" - Homer

    "Gabber DJ let the bass drum go liek this *untz untz untz untz*" - Hocus
    Pocus - Here's Johnny

    "I look back on my life, what do I find? I feel I'm running on empty. Even
    in the corner of my mind, I feel I'm running on empty. Even if i spead my
    wings tonight, I feel I'm running on empty. even if you run with me
    tonight, I feel the torture ending...Running ohhh wooahh wooahh running on
    empty...ohhh wooahh wooahh running on empty." - DJ Trashy - Running on
    empty.
     
    Jimmy!, Jul 22, 2005
    #4
  5. Shane

    Shane Guest

    Who said anything about FAT32? If you are referring to my use of the ME
    boot disk to fdisk the drive, I just used it to nuke the partition. That's
    it. You can be sure that I formatted it with NTFS.

    The real point, however, is that the x64 installation program did not see
    the whole drive.

    Shane
     
    Shane, Jul 22, 2005
    #5
  6. Have you run the Hitachi disk utilities to determine if the hdd has any
    problems?
     
    Colin Barnhorst, Jul 22, 2005
    #6
  7. Shane

    Shane Guest

    Not yet, but I can give it a try. I didn't get a disk with it, so I didn't
    think of downloading one. I'll try it tonight when I get home. Thanks for
    the tip :)

    Shane
     
    Shane, Jul 22, 2005
    #7
  8. yw. My concern is that static electricity did something to the controller
    during handling.
     
    Colin Barnhorst, Jul 22, 2005
    #8
  9. Shane

    LDJ Guest

    Hello Shane!

    Here is a re-use of a msg I wrote, on PlanetAMD64:

    Jun 24 2004, 05:04 PM

    Hello Anybody!
    Having spend a lot of time installing/partitioning a new 160 GB Hitachi
    ATA 100 HD, I finally found the solution, and am willing to share the
    secrets with you :)

    If you don't want to waste more time, than necessary, go read this FAQ:

    Installation and integration tips

    ยท FAQ: Why doesn't my system see the full capacity of my 137GB+ drive?
    What is the 137GB (128 GB binary) hard drive capacity limitation?

    http://www.hitachigst.com/hdd/support/hdinstall.htm

    I finally got the disk partitioned by making Primary and extended
    partition with logical drives, by making ALL of the partitions within
    the first 120 Gb
    area of the disk.

    Next thing to do was to install SP 4 on Win2000-

    I used Control Panel/Administration/Diskmanager to partition/format the
    unused space.

    Strange though (IMO) I was only given the option, partitioning the space
    as a Primary partition. But anyway, I no longer have error msg's, when
    tested with PowerQuest Partition Info. You can download a free version
    of this program from Symantec:

    http://www.symantec.com/techsupp/primus/id4256.html

    When you are there, and having read the notes, scroll to the link:

    FTP Site

    Download the file: PartInNT.ZIP

    Even though you might already have your HUGE disk
    installed and running, it can still be of interest to check the disks
    for error. IMHO

    ----------------------- end of re-used text ----------------------------

    If you wish, you can also read the text, of the posting, on PlanetAMD64:

    Topic: Huge Drives Installation and integration tips

    http://www.planetamd64.com/index.php?showtopic=1470&hl=

    Have Fun!
    LDJ
     
    LDJ, Jul 22, 2005
    #9
  10. Shane

    John Barnes Guest

    I think they gave up the trials, since this product and Ghost are items
    rarely used by most and their purchase rate was abominable. If you have
    Partition Magic, you can use by booting from the CD and see if it sees the
    whole drive, and you can partition and format there.
     
    John Barnes, Jul 22, 2005
    #10
  11. Shane

    -Dan- Guest

    Shane,

    Apparently you have some type of hardware, or BIOS, glitch, because x64 will definitely see 250 GB SATAs. I have two Maxtors set up RAID 0. System Information shows:

    Name Maxtor 7Y250M0
    Model NVIDIA STRIPE 467.52G
    Size 467.52 GB (501,997,063,680 bytes)

    You'll get it done... and you will like it.

    --
    --Dan--



    | FAT32 = nono for 200gb+ drives. I hope for your life that you don't use
    | FAT32 or SO HELP YOU GOD!
    |
    | JimmY! :D
    |
    | --
    | "The last that ever she saw him, carried away by a moonlight shadow.
    | He passed on worried and warning, carried away by a moonlight shadow." -
    | Groove Coverage - Moonlight Shadow
    |
    | "Hold the line...Love isn't all way on time...no woah woah woah!" - Toto -
    | Hold the line.
    |
    | "And I miss you...Like the deserts miss the rain..." - Missing - Everything
    | but the girl.
    |
    | "No TV and no beer make Homer something something...(Go crazy?)...DON'T MIND
    | IF I DO! MUAHSAHADHDA WEE BLEAGAGS EGSAR WEE ZZZZ IZZ ZIZ Z RAH!" - Homer
    |
    | "Gabber DJ let the bass drum go liek this *untz untz untz untz*" - Hocus
    | Pocus - Here's Johnny
    |
    | "I look back on my life, what do I find? I feel I'm running on empty. Even
    | in the corner of my mind, I feel I'm running on empty. Even if i spead my
    | wings tonight, I feel I'm running on empty. even if you run with me
    | tonight, I feel the torture ending...Running ohhh wooahh wooahh running on
    | empty...ohhh wooahh wooahh running on empty." - DJ Trashy - Running on
    | empty.
    | | > "M. Murcek" wrote
    | >> x64 Edition definitely saw all 250GB on the Hitachi SATA disks I
    | >> installed. Have you tried booting with the x64 CD, delete any existing
    | >> partitions there, create a new partition for the whole disk and continue
    | >> the install from there? I sure wouldn't mess with an ME boot disk.
    | >
    | > At least I know I'm not out of my mind. Thanks for the info.
    | >
    | > So to answer your question, I did in fact try to boot up with x64, delete
    | > all partitions (there was only one), and try to create a new one. The
    | > problem is that it only shows 130 gig. x64 actually thought that 130 gog
    | > was all I had on that drive.
    | >
    | > My guess, however incorrect it may be, is that x32 put some crappy
    | > boundaries on the hard drive that x64 is reading. My next thought is to
    | > wipe it with a linux fdisk. Also, I didn't fdisk the mbr, but should I
    | > really have to? Any other ideas?
    | >
    | > Shane
    | >
    | >
    |
    |
     
    -Dan-, Jul 23, 2005
    #11
  12. Shane

    Shane Guest

    Sorry it took me so long to post the solution, but I figured it out. I have
    to thank you all for the help, especially the point to the hitachi disk
    checking software.

    Anyway, the disk checking software from hitachi allowed me to change the
    size of the drive that would register. Pretty sweet. Not out of the woods
    yet though. When I went into the disk setup section of XP install, I would
    see the unused space, as well as the used space. Wanting them all to be in
    one clump, I did the natural thing and deleted the used partition, hoping to
    create on big new one. Once I did that, I saw only the 137 gig again.

    Solution: I had to go back into the hitachi utils again and set the thing to
    250 gig, start the install again, and then actually create a second
    partition. Then I deleted them both and was able to make one big one. i
    tried several ways and this is the only thing that worked. Thank goodness
    for that utility!

    Here's the link :)
    http://www.hitachigst.com/hdd/support/download.htm

    I hope this helps someone else!

    Shane
     
    Shane, Jul 26, 2005
    #12
  13. Glad you resolved it.

     
    Colin Barnhorst, Jul 26, 2005
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.