Legacy Parallel Scanner x Virtual PC2007

Discussion in 'Virtual PC' started by Bart, Jan 9, 2010.

  1. Bart

    Bart Guest

    Greetings,

    I'm having a lot of trouble to get my old Parallel Genius ColorPageEP
    Scanner working on a virtual W98SE machine. The thing is that this scanner
    works perfectly on REAL W98SE machines with the driver I'm using so I guess
    there's gotta be something wrong at the VM settings. The host runs Windows7
    64 and this scanner, as amazing as it sounds, used to work perfectly on Vista
    32 with Win2000 drivers.

    The resources I'm using at the HOST parallel port are:
    Parallel Port Mode (BIOS): EPP 1.9
    I/O Range: 0378-037F (the same range set on VM Settings, of course)
    IRQ: 7

    Once I'm on Virtual W98SE, all the settings above the same.

    I'm kinda confused with the "Port Settings" tab btw. The "Filter Resource
    Method" is set to "Use any interrupt assigned to the port" and the "Enable
    legacy PnP detection" was left unmarked. I tryed fooling around with these
    settings but none of them made the scanner work on W98SE.

    Before starting the VM i'm shutting down the "Printer Spooler" service as
    mentioned somewhere here so I guess this is not the real problem. It seems to
    me there's something keeping the LPT port "locked" on Win7!

    Regards.
     
    Bart, Jan 9, 2010
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.