Links don't work in Outlook Express 6.0

Discussion in 'Internet Explorer' started by Tony and his computer, Jan 26, 2007.

  1. Here's a variation on the "links don't work" problem...

    I click on a link in an email. The Task Manager shows that Internet Explorer
    starts but it never shows a window. After a few seconds, Task Manager shows
    that Internet Explorer goes away.

    If I copy and paste the link into something like Microsoft Word, it works
    fine.

    If I open Internet Explorer first, and then click on the link in the email,
    it works fine.

    I'm running Outlook Express 6.0 and Internet Explorer 7.0. Anyone got a
    solution for me? Thanks a lot
     
    Tony and his computer, Jan 26, 2007
    #1
    1. Advertisements

  2. See if this helps, Tony:
    "Hyperlinks do not work in Outlook Express after you upgrade to Internet
    Explorer 7:
    http://support.microsoft.com/kb/929867

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Jan 26, 2007
    #2
    1. Advertisements

  3. Hi Vince, Thanks for your very prompt reply!

    I had tried what you suggest below (resetting the File Type Associations by
    changing "-nohome" to "%1") but I had omitted a key step...

    When I clicked on a link in Outlook Express after following the steps in the
    suggestion, Internet Explorer told me that it was not the default browser and
    asked if I wanted to make it the default. I clicked the YES button but the
    instructions say to click the NO button.

    When I click the NO button and the "Don't ask me again" checkbox, then
    everything works fine. I can now click on links in Outlook Express and they
    work.

    BUT: What are the implications of me NOT having Internet Explorer as my
    default browser? I don't like that idea. It doesn't seem right.
     
    Tony and his computer, Jan 26, 2007
    #3
  4. "... Note If Internet Explorer 7 prompts you to make it the default browser,
    click No. If you click Yes, Internet Explorer 7 may reset the entry
    to -nohome. Then, this issue may recur..."
    Source: http://support.microsoft.com/kb/929867/en-us -> Method 2.
    Don't worry, Tony. All is OK. Test the behaviour of IE7 and of links in
    Outlook Express, now working fine.

    Have a nice day.

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Jan 27, 2007
    #4
  5. Well I just had a chance to test this issue on my other computer.

    On the other computer the associations are exactly the same as on this one.

    On the other computer Internet Explorer is set to be the default browser
    with the "tell me if not" checkbox on. On this computer Internet Explorer is
    set to NOT be the default browser and the "tell me if not" checkbox is not
    checked.

    On the other computer links in Outlook Express work fine. On this computer
    links in Outlook Express only work if I Internet Explorer is not the default
    browser.

    Why the difference on the two machines? There must be some other problem
    which is causing links to not work on this machine and the "fix" we are
    applying is not really fixing the real issue. Instead it is just a
    work-around to make it seem like it is fixed. Any thoughts?
     
    Tony and his computer, Jan 27, 2007
    #5
  6. Control Panel -> Add / Remove Programs -> Set Program Access and Defaults:
    is Windows Internet Explorer the default browser?
    http://www.microsoft.com/windows/ie/community/columns/defaultbrowser.mspx

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Jan 28, 2007
    #6
  7. On both machines, the SPAD option for "Choose a default Web browser" is "Use
    my current web browser".

    On both machines the other (non-selected) option is Internet Explorer with
    the "Enable access..." checkbox checked.

    On one machine, links work in Outlook Express all the time. On the other
    machine, links only work in Outlook Express when IE is not the default web
    browser.
     
    Tony and his computer, Jan 28, 2007
    #7
  8. Remove and reinstall IE7, Tony.

    Required reading IMHO before installing IE7:

    Sandi's Installation Tips <= FOLLOW THESE TIPS TO THE LETTER!
    http://www.ie-vista.com/known_issues.html#pre-install

    [And I strongly recommend using
    http://www.microsoft.com/windows/ie/default.mspx as the installation source,
    not Automatic/Windows Update.]

    IEBlog : IE7 Installation and Anti-Malware Applications
    http://blogs.msdn.com/ie/archive/2006/10/11/IE7-Installation-and-Anti_2D00_Malware-Applications.aspx

    What's New in Internet Explorer 7
    http://msdn.microsoft.com/workshop/essentials/whatsnew/whatsnew_70_sdk.asp?frame=true

    Release Notes
    http://msdn2.microsoft.com/ie/Aa740486

    Thanks to Robear Dyer (PA Bear)
    MS MVP-Windows (IE, OE, Security, Shell/User)

    --
    Vincenzo Di Russo
    Microsoft® MVP - Most Valuable Professional
    Windows - Internet Explorer since 2003
    My home: http://mvp.support.microsoft.com/
    My Blog: http://blogs.dotnethell.it/vincent/
     
    Vincenzo Di Russo [MVP], Jan 29, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.