Links with fragment identifiers don't always lead to proper place

Discussion in 'Internet Explorer' started by Barry, Sep 2, 2007.

  1. Barry

    Barry Guest

    The following link brings you to the content under a heading, but it should
    include the heading.

    http://www.polisource.com/consumer-protection-test_PRIVATE.shtml#cpsc

    ----------------
    This post is a suggestion for Microsoft, and Microsoft responds to the
    suggestions with the most votes. To vote for this suggestion, click the "I
    Agree" button in the message pane. If you do not see the button, follow this
    link to open the suggestion in the Microsoft Web-based Newsreader and then
    click "I Agree" in the message pane.

    http://www.microsoft.com/communitie...&dg=microsoft.public.internetexplorer.general
     
    Barry, Sep 2, 2007
    #1
    1. Advertisements

  2. Barry

    Barry Guest

    I isolated the problem at
    http://www.polisource.com/misc/fragment-identifier-link-bug.html#test (the
    page I pointed to in my original post was deleted). The bug occurs when you
    set a negative relative top position for the div id you're linking to. The
    css position apparently isn't considered for the link, so if you moved things
    up, they'll be cut off.
     
    Barry, Sep 2, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.