Linux 8.0 / Linux 9.0 Install Issues

Discussion in 'Virtual PC' started by Scott Woodford, Apr 18, 2005.

  1. I have succesfully installed Linux 8.0. Everything is working fine, except
    during boot the floppy drive continually gets accessed even though there is
    nothing in the drive. The result is a wonderful grinding sound. The only
    way to get it to stop is to insert the Linux boot disk. Although, this is a
    problem because it boots to the disk and not to the installed OS. Any ideas?

    I also installed Linux 9.0, which is doing the same thing. But this install
    is even worse, because when the system finishes booting up, the display is
    set up improperly. The screen is black, and all I can see are a few random
    icons. Any idea how to fix this? I am running both 8 and 9 at 800x600,
    using the default S3 Trio adapter. Like I said, 8 looks fine, but 9 looks so
    bad that I can't use it.

    Any help on this would be greatly appreciated. :)
     
    Scott Woodford, Apr 18, 2005
    #1
    1. Advertisements

  2. Scott Woodford

    Steve Jain Guest

    Are you referring to Red Hat 8 and 9?

    Did you start the install with a boot disk or from cd?

    For better video, use generic VESA instead of the S3, it will also
    allow you to use 8MB of VMRAM instead of 2 or 4MB that the S3 Linux
    driver limits you to.


    --
    Cheers,
    Steve Jain, Virtual Machine MVP
    Website: http://www.essjae.com
    "This posting is provided "AS IS" with
    no warranties, and confers no rights.
    You assume all risk for your use.
    I am not am employee of Microsoft."
     
    Steve Jain, Apr 19, 2005
    #2
    1. Advertisements

  3. I only have a solution for your first question (I'm not vary good at Linux).

    There is two ways to get rid of the grinding sound.

    1 (which I prefer)
    Go into the VM:s BIOS an disable Floppy boot (just like you would do to
    disable it on a real machine).

    2
    Go to the VM:s settings an disable Automatic floppy detection (this have
    the drawback you must explicitly capture the floppy when you want to use
    it in the VM.


    For your second issue: have you tried some generic VESA driver? (I don't
    know if it works, just giving a hint)

    /David
     
    David Carlsson, Apr 19, 2005
    #3
  4. Scott Woodford

    Steve Jain Guest

    Yes the generic VESA driver works and its the only way to break the
    memory limits imposed by the Linux S3 drivers.


    --
    Cheers,
    Steve Jain, Virtual Machine MVP
    Website: http://www.essjae.com
    "This posting is provided "AS IS" with
    no warranties, and confers no rights.
    You assume all risk for your use.
    I am not am employee of Microsoft."
     
    Steve Jain, Apr 20, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.