Linux=Incompetent competition = Best thing that ever happened to Microsoft

Discussion in 'Windows Vista Help' started by VistaEra, Feb 6, 2007.

  1. VistaEra

    VistaEra Guest

    Linux - The never ready OS.

    Every once and a while I get the urge to check out the Linux Operating
    system. I've never been fully happy with Microsoft Windows and never happy
    with Microsoft as a company, and I am eager to switch to an OS which
    provides good or better performance and utility than experienced with
    Microsoft windows.

    Linux gets the most hype and while MacOS and Solaris are also potential
    candidates, they always lose out because 1. MacOS comes from a flake company
    who don't really produce computers, they produce Ipods, and Solaris has even
    a smaller user base than Linux and only runs on a very limited number of
    motherboards. So, I almost always end up auditing Linux.

    I first saw Linux back in the 486 era when it was barely a year old. It was
    running on a 486 and was pleased to see how fast it managed to list it's
    directories compared to the speed of DOS on my 386. However it was clear
    even at that time, that Linux would never be a challenge to Microsoft DOS.
    This was obvious because Linux was developing into nothing more than a Unix
    clone, and Unix had been completely rejected in favour of Microsoft DOS by
    the desktop computing community.

    Typing a few commands into the Linux console, and watching the shell spit
    out cryptic and incomprehensible error messages made me laugh out loud I
    remember, I then turned off the machine and walk away in complete and utter
    disgust at the lack of vision in the Unix/Linux community. Yes they really
    had decided to produce yet another clone of the very OS that couldn't even
    compete against DOS. Retards I said to myself... Pathetic retards...

    A few years later, I abandoned the DOS command line, in favour of the vastly
    superior Windows 95 GUI - having successfully ignored all earlier versions
    of Microsoft Windows, as the earliest Windows offerings were also completely
    unusable and unstable.

    I gave Linux another shot at impressing me again that year, and once again I
    was presented with the same text command line that I had seen years earlier.
    The same cryptic commands, the same useless error messages, the same user
    hostility and the same absolute lack of vision in the Unix/Linux community.
    Yes they really had decided to produce yet another clone of the very OS that
    couldn't even compete against DOS. Retards I said to myself... Pathetic
    retards...

    When X-windows for Linux arrived, I gave the OS another shot. X11 had the
    potential of competing with Microsoft windows in terms of ease of use - if
    implemented correctly. I noted however, that after booting the X11 server
    from the command line, that what was presented was a graphical desktop from
    which multiple command line shells would be presented in a nice overlapping
    manner. It was a hollow desktop with no icon to file mapping, no desktop
    management, no device control, no computer management functions - other than
    those that were managed via command line and with each of those shells I was
    presented with the same text command line that I had seen years earlier.
    The same cryptic commands, the same useless error messages, the same user
    hostility and the same absolute lack of vision in the Unix/Linux community.
    Yes they really had decided to produce yet another clone of the very OS that
    couldn't even compete against DOS. But now the output was directed toward
    overlapping text windows. Retards I said to myself... Pathetic retards...

    It wasn't all command line though, there were a host of screen savers for
    the OS, and I decided to check out it's graphic potential by running through
    those. 20% of them either failed to run, or crashed, with several taking
    out the entire OS.

    I laughed and turned the machine off. Retards I said to myself... Pathetic
    retards...

    It's now about 5 years later and I've just given Linux yet another attempt
    to impress me, and impress upon me why I should keep it on my computer.
    I've given it a good shot, not simply seconds or minutes, or even an hour
    like the last time, but a full month or so of effort - when I have had the
    time and patients.

    The results are in. Linux - while considerably improved over it's crash
    prone past, is still a very, very long way from usability, and offers
    essentially <zero> challenge to Microosft Windows.

    The Linux Desktop is now much more than a simple means of managing multiple
    text based terminal windows. Kudo's to the various desktop developers of
    KDE and Gnome.

    In many respects the desktop I have become familiar with (KDE) is as good as
    the desktop supplied with W95. But in many ways it's also inferior, and
    suffers from a variety of problems - consistancy being one, completeness
    being another.

    Linux however, is still a command line driven environment. Try as they
    might the various providers of Linux, with all thier incompatible tinkering,
    have yet to provide a version of the OS, where you can avoid decending to
    the same incredably hostile and brain dead command line environment whose
    stench permiates ever previous version of Unix/Linux.

    What the Linux community has done is try and hide the pathetic command line
    from view. But they just can't seem to manage to get it right. They can't
    make it go away completely. For example, click on the start menu and what
    happens? Why a hidden commmand line is processed and a graphical
    application invoked. But that application is probably just a graphical
    front end which itself creates and passes along a command line to the actual
    program that is to be run. Many of the smaller Linux programs are written
    like this, although there are some full fledged applcations that are fully
    integrated.

    But ok, I said to myself, dealing with Unix command line filth has been
    minimized, so maybe I can live with that. Maybe I can adjust to an
    environment where graphical shells are slapped on top of command line
    interfaces, and where a command appropriately labeled find in the shell, is
    ultimately mapped onto some command called PinkiBoingo in some randomly
    assigned executable directory. But then again, maybe not.

    I started auditing Linux on a brand new Duel Core Athelon machine running an
    Nvidia chipset, and I was keen to see how an aledgedly efficient OS would
    fly on multiple cores. Alas, I never managed to find out, because in the
    half dozen x86 versions of Linux I installed on that machine, none managed
    to function well enough to serve as a testable platform. In fact most
    wouldn't install at all. Some couldn't find the network card, which made
    installing other applications impossible. Some didnt' recognize the Nvidia
    Video chipset, and while one version actually defaulted to VESA video it
    failed to provide a mouse pointer making pointing to anything on the screen
    somewhat difficult.

    Eventually in the case of the lost mouse pointer, I found out that I could
    edit a random text file with some random title, and alter a randomly named
    switch so that a software cursor would be used instead of the hardware
    cursor that wasn't working, but after that networking problems became
    clearer, and eventually after installing an MP3 codec, the OS just had a
    kernel panic and that Linux install was dead, quickly replaced with a
    version of Windows 2000 which installed flawlessly, runs flawlessly and
    supports the duel core Athelon quite nicely.

    I religated Linux to my older machine at this point and installed a version
    of RedHat Linux first. At this point I was looking to create a stable Linux
    environment that could be used for casual computing with some development
    tools so I could audit the OS more thoughly.

    No Joy with Redhat. Working environment was too poor.
    No Joy with Ubuntu. The inability to log on as Admin displeased me greatly.
    No Joy with Susie. It just pissed me off due to lack of any codec support
    like all the others.
    Then there was Freespire.

    I much prefer Freespire's philosophy of providing the user with some
    multimedia capability out of the box, even though the codecs and
    applications may be propriatory. And Freespire installed with Windows
    networking compatability turned on and capable of immediately connecting to
    a windows network. Joy....

    Joy yes, but joy only for so long.

    Freespire is by far the best version of Linux I have yet to audit (What do
    you do with Linux? You install it.) Networking works, XMMS is easy enough to
    install, and if you don't there is always real player. It plays many video
    file formats without any hastles, and the user interface of version 1.0 is
    actually quite good. VLC is generally available but isn't as good as the
    Windows version.

    "Maybe", I found myself thinking as I toured the OS surface, it's time to
    emmigrate from the often quirky and always inefficient state of Microsoft to
    the shiny new land of Linux and what appeared to be it's newly reformed
    Linspire ideology.

    Well, it's not quite so easy as that.

    The first thing I noticed, is that my networking card - which is a 10/100
    card is only operating at 10 Mbps. Ok Ill reconfigure that. I saw a device
    manager in here somewhere, lets get going.

    Several hours later I conclude that there is no real device manager, even in
    Freespire. In the other versions of the Linux OS, a device manager is
    supplied... Well the program calls itself a device manager, but in
    actuality there is no ability to manage any devices from these utilities.
    Oh, they may list device properties, but they provide no management
    functions. Brilliant!

    Need to change a buffer location or size, force an interrupt, turn on DMA?
    Device manager tells you where they are, what their size is, but provides no
    ability to change any parameter. Absolutely brilliant.

    Need to manually set the speed of your Network Card? Device manager might
    tell you it's current operating speed, but provides no means of actually
    altering the speed.

    Linspire differs primarily in the honesty with which it announces it's
    device reporting utility. It doesn't use the word "manager" in the title
    since the program - like all the other Linux device utilities, provide no
    management functions at all.

    Ok. So I tell myself, I'll live with a slower than necessary Network card
    for the moment. It's not a big deal, lets play some MP3's and relax. Hmmm,
    the audio level appears to be very low, lets adjust it up. No Joy. It's
    only when I reach the upper two "notches" of the volume control does the
    volume of the output sound noticabely increase. Also, when the volume is
    finally changed, the sound levels are now dramatically disproportionate
    between the left and right channel, Hmmmm. There is a problem with the
    sound mixer.

    Ok so I grab another sound mixer from the net, and off I go. Same problem.
    So I grab another... Same problem. And another. Same problem...

    Obvously there is some underlying problem with the sound driver, and not the
    mxier control applets themselves.

    So I play around with the various mixer controls, playing with the say -
    microphone control and having the left side of the master volume control cut
    in and out, and finally come across a series of settings which is
    acceptable.

    Ok I think to myself, this is a little bit of a pain, but I can live with
    it. Who knows, someone might fix it, and once I get some development tools
    installed, I might fix it myself. Time to move on.

    Soon after I notice that while trying to compose some text via a supplied
    text editor that I can not insert text. The insert button on my keyboard
    has been brilliantly removed in place of an expanded delete key. To insert
    I now must use the insert key on the numeic keyboard - prssing Shift-0
    (insert).

    Doesn't work. Pressing Shift Insert doesn't work. Hmm, no insert? I seem
    to remember it working yesterday when I tried it. Shift-0 again. "0"
    appears under my cursor.

    Hmmmmm. This worked yesterday - why not today? Must be something set
    differently. So I try toggling the numlock state. Sure enough insert
    works. But it only works when the numlock state is active. In other words
    when the insert key is <not> supposed to be mapped to the number 0. So the
    key state is inverted to that used by windows. Another Linux bug.

    Brilliant I tells ya.. brilliant.

    I can put up with this variance as well. Ok. I'm beginning to feel a bit
    soiled by the OS now, but maybe there must are better things to come I tell
    myself.

    Ok on to installing a development environment.

    After a little bit of research it appears that there are only two viable
    integrated development environments for Linux. Well only 1 really. That
    environment is RealBasic.

    Faster than I can type Shazam I'm at the RealBasic website downloading the
    latest PD version of their programming environment. It looks quit promising
    with it's visual studio style and gizmo's and such. Visual Studio for
    Windows is a truly excellent development environment for Microsoft Windows,
    and I would truly be impressed if it were duplicated in the Linux community.

    Once the program has been received and installed, I start it and am indeed
    immediately greated with a GUI interface. Most excellent. Within a few
    seconds I have a new form in the main window and from the tool bar I select
    a button to add to the form. Most excellent I think to myself, pondering
    how well the language will optimize. Clicking on the form and dragging a
    outlign box for the button to be enclosed in however immediately shows a
    very, very major problem. It takes almost a full second between releasing
    the mouse button to when the button actually appears on the form. Resizing
    is equally sluggins, taking between .5 seconds and 1 full second... This is
    on a 1.1 Ghz machine operating at just slightly more than 1 operation per
    second.

    How can you possibly burn over a billion cycles of CPU time just to draw a
    button in a window? Holy smoke. What's wrong with that picture?

    At first I thought it was some sort of post installation inefficiency
    madness, turding the application. So I shut down and restarted with exactly
    the same results.

    The delays are such that it is very difficult to actually resize any of the
    tools Clicks don't get processed and are difficult to release before they
    are considered a click and hold operations.

    Not good. Do I start to drag immediately, and drag the cursor out of the
    item selected before it's selected (sometimes) or do I wait? Horrible.

    After a little research I find that RealBasic is actually written in
    RealBasic. Which is cool enough, but exactly pinpoints the reason the UI is
    so sluggish. The RealBasic compiler isn't up to snuff - and probably
    neither is the language.

    The minimum recommended requirement for the langauge is a 1.5 Ghz pentium. I
    had an order of magnitude better performance running Microsoft Developer
    studio on a half gigabyte PC. How can anything like this be written so
    inefficiently? The mind boggles.

    With that realization RealBasic was quickly erased from existance.

    The next morning when I awoke I found that even though I had shut the Linux
    box off, the mouse attached to the machine continued to power it's laser LED
    at full brightness. Ah, another problem. Power management under Linux
    isn't working properly either.

    Moving on I note that there is a version of KDevelop that has already been
    installed with the OS. It's not an integrated environment, but it does have
    a GUI editor, so I can potentially use that.

    Now either the install of KDevelop was broken or something in the RealBasic
    installation must have boinked KDevelop because while the environment runs
    and provides a text based interface, it can't compile anything. Some error
    messages regarding missing files are printed.

    Ok I think to myself "The rate at which Linux is shitting on itself is
    increasing." Might as well try a borland package to see how it works.
    Borland has an integrated development environment called Kylix that is
    downloadable and looks promising.

    Shazam It's downloaded and installed. But during the install it asks me for
    the paths to two file sets that haven't been installed. qt something or
    other and some file set called <meaninglessname>.

    Ok, I'll install the <meaninglessname> files via apt-get and then try to run
    again. No Go, <meaninglessname> doesn't appear in a web search and it's not
    in the Debian repository. But <meaninglessname>3 is. So, I download that.

    Reinstalling I am again told that <meaninglessname> doesn't exist and I am
    requested to provide a path to it.

    But where did the apt-get put the file? Grep, grep gRep, nothing found.
    Now isn't that interesting. Can't find the file set because they don't have
    the same name as the set name, and I haven't been told where they are.

    Ok, Maybe I should just go the the Debian repository and install from there.
    No go, the file doesn't exist there. Ok, well maybe I'll uninstall it and
    try again.

    Nope, the uninstall script doesn't work, and in fact hardly appears to be a
    valid script. Looks like random hash.

    When I invoke the uninstall script, It terminates without performing any
    operation and without an error or status report. It ends abruptly as if it
    were never executed as far as I can tell. The application is still
    installed.

    The Linux ShitPile is growing quite high at this point.

    A little research leads me to the Borland site where I am instructed to use
    the GNU C compiler to compile the documentation for the application. Why in
    the world would anyone need a C compiler to compile their documentation..
    Documentation isn't an executable.

    Click - Linux is shut down for the rest of the evening. My head shaking in
    disgust. Retards I said to myself... Pathetic retards...

    And on and on it goes. This Linux application doesn't work, that
    application won't load, the other one just has no desktop shortcut
    installed, yet another executes apparently but doesn't provde even open a
    window. But it still remains running and soaking up system resources.
    Files missing in this install, that install took down the entire OS, This
    install requires to be installed as root, but the installer doesn't support
    that feature. Etc.. Etc... Etc... My head shaking in disgust. Retards I
    said to myself... Pathetic retards...

    So after a dozen or so OS installs and with each version failing critically
    at some point, or failing to provide a usable environment, I decided to
    celebrated my Linix experiment by straping a couple of M90's to my pile of
    Linux install disks and blow them all up.

    A few strays were nuked in my microwave, and they made a very pretty
    sparklie effect as they died.
    For good measure I melted a couple with a propane torch and kept a couple as
    tea cup coasters.

    So long to Linux, the Never Ready for Prime Time OS.
    15 years in development and as much a piece of shit as ever.
     
    VistaEra, Feb 6, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.