linux usb drive

Discussion in 'Windows Vista Security' started by ted medin, Sep 22, 2009.

  1. ted medin

    ted medin Guest

    I have a usb drive that is from ubuntu (Linux) & would like to access it
    from vista but i get access not permitted. So tried to change the
    properties so everyone can access the files. See the current owner is
    Unix user 501. I tried to change with administration privileges but the
    unix files will not let me. Anyone got any ideas? TIA HELP!
     
    ted medin, Sep 22, 2009
    #1
    1. Advertisements

  2. ted medin

    Malke Guest

    There should be no problem accessing a USB flash drive that is used on Linux
    or Unix in Windows. I do this all the time and the different operating
    systems don't normally honor permissions set by each other. What file format
    is the drive? To get the best interoperability between various file systems,
    use FAT32 because Linux, Unix, OS X, and Windows can all write to it.

    If is already FAT32, then you just need to take ownership of the drive.
    There is no way "the unix files will not let me" is accurate.

    To take ownership of a folder (or a drive):

    1. Right-click the folder that you want to take ownership of, and then click
    Properties.
    2. Click the Security tab, click Advanced, and then click the Owner tab.
    3. Click Edit. Administrator permission required If you are prompted for an
    administrator password or confirmation, type the password or provide
    confirmation.
    4. Click the name of the person you want to give ownership to.
    5. If you want that person to be the owner of files and subfolders in this
    folder, select the Replace owner on subcontainers and objects check box.
    6. Click OK

    Or you can run this at an elevated Command Prompt:

    For Folders or Directories (will perform action recursively):

    takeown /f drive:\ /r /d y [enter]
    (where "drive:\" is your USB thumb drive)
    icacls drive:\ /grant yourusername:F /t [enter]
    (make the correct substitution of your user account)

    Malke
     
    Malke, Sep 22, 2009
    #2
    1. Advertisements

  3. ted medin

    ted medin Guest

    Ok thanks for the info i tried the above from the cmd with admin
    privileges & got access denied.
    As to the first part i will try that & thanks. One question i am not
    talking about a flash drive but a usb2.0 external hard drive. Is that
    important? TIA
     
    ted medin, Sep 22, 2009
    #3
  4. ted medin

    Paul Adare Guest

    None of what follows in Malke's post will work, nor is it necessary. A
    FAT32 drive doesn't support file and folder level security so there is no
    concept of ownership on the FAT32 file system. Everything described in
    Malke's post applies to the NTFS file system and not to FAT32.
     
    Paul Adare, Sep 22, 2009
    #4
  5. ted medin

    Malke Guest

    What file system is the drive? FAT32? NTFS? Ext3? Something else is going on
    here. It doesn't matter that the drive in question is an external hard drive
    or a USB thumb drive. It matters that the operating system to which you are
    connecting the drive can deal with its contents. You say you used this drive
    with Ubuntu. Ubuntu normally uses Ext3 and Windows can't read/write to Ext3.

    Is this an old hard drive you put in an external enclosure? Can it still be
    read from a *nix box? I ask this because another possibility is that the
    drive is failing and the reason you can't access its contents has nothing to
    do with permissions.

    Malke
     
    Malke, Sep 22, 2009
    #5
  6. ted medin

    David B. Guest

    Just a little, again, what file system is in use on the drive?

    --
    The following is a signature, don't take it personally unless it applies to
    you.
    How to ask a question http://support.microsoft.com/kb/555375

    ------
     
    David B., Sep 23, 2009
    #6
  7. ted medin

    Justin Guest


    Oh really?
    FAT32 has file permissions? Source?
     
    Justin, Sep 26, 2009
    #7
  8. ???

    I don't see that claim being made.
     
    FromTheRafters, Sep 28, 2009
    #8
  9. ted medin

    Paul Adare Guest

    From Malke's post to which Justin replied:

    "If is already FAT32, then you just need to take ownership of the drive.
    There is no way "the unix files will not let me" is accurate.

    To take ownership of a folder (or a drive):"
     
    Paul Adare, Sep 28, 2009
    #9
  10. So, if a USB drive is formatted FAT32, it is no longer a securable
    object as far as Vista is concerned?
     
    FromTheRafters, Sep 28, 2009
    #10
  11. ted medin

    Gordon Guest

    That's correct - FAT32 doesn't have any of the security functions that NTFS
    has....
     
    Gordon, Sep 28, 2009
    #11
  12. ted medin

    Paul Adare Guest

    Correct. Ownership, just like file and folder level permissions, are only
    available on the NTFS file system and not on FAT32.
     
    Paul Adare, Sep 29, 2009
    #12
  13. Thanks Paul and Gordon for making that clear to me.
     
    FromTheRafters, Sep 29, 2009
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.