LIVE SEARCH KEEPS MAKES ITSELF DEFAULT SEARCH PROVIDER

Discussion in 'Internet Explorer' started by regfla, Apr 17, 2009.

  1. regfla

    regfla Guest

    USING XP W/SP3, MY PROBLEM IS LIVE SEARCH KEEPS MAKING ITSELF THE DEFAULT
    SEARCH PROVIDER EACH TIME I RESTART THE COMPUTER. I'M MAKING GOOGLE THE
    DEFAULT BUT LIVE CHANGES IT.
     
    regfla, Apr 17, 2009
    #1
    1. Advertisements

  2. regfla

    Karen Guest

    Hi, did you get an answer to your post? I'm having the same issue with IE8.
    Using WXP/SP3, there is not an option to make Google the default search
    provider. If you get a resolution, please share it with me! Karen
     
    Karen, Apr 19, 2009
    #2
    1. Advertisements

  3. regfla

    Merle Guest

    Hi: When you have IE open go to the search box and click on the down arrow
    to the right and click on search providers, select your search choice and
    make it default.
     
    Merle, Apr 19, 2009
    #3
  4. regfla

    regfla Guest

    Thats what I'm doing, Live keeps resetting itself default after restarts.
     
    regfla, Apr 20, 2009
    #4
  5. regfla

    regfla Guest

    Nothing yet Karen

     
    regfla, Apr 20, 2009
    #5
  6. regfla

    Karen Guest

    Thanks, I've tried the 'down arrow' by the search box, but to no avail. It
    will not change the default. Now, when I first open IE8, I get a message that
    a file has corrupted my search provider and that IE8 has changed it to Live!
    I'll keep researching this and if I hear anything I'll let you know. Please
    do the same for me.
     
    Karen, Apr 20, 2009
    #6
  7. regfla

    RalfG Guest

    You should be able to set Google or any other search engine as the default.
    Believe the error message, something is or has corrupted the Google search.

    OP can try this too; From the drop down list in the search box you can try
    removing Google (or any others) from the search providers list using Manage
    Search Providers. Google should not be set as default when you do this.
    Close and restart IE. Then go into Find more providers in the same drop down
    list and re-install Google from the web page that opens. There is an
    additional check-box option you can enable in Manage Search Providers to
    "prevent programs from suggesting changes to my default search provider.
     
    RalfG, Apr 20, 2009
    #7
  8. regfla

    Karen Guest

    Thanks RalfG, I followed your steps exactly (the 2nd part) and Google still
    cannot be set as the Default search provider. Also, that kept me from
    checking the box about preventing programs from suggesting changes...... you
    know the one.

    About your first suggestion, How can I find out if something has corrupted
    the Google search?
     
    Karen, Apr 20, 2009
    #8
  9. regfla

    RalfG Guest

    You mentioned in your original post that IE reported Google search being
    corrupted. What exactly is causing that isn't indicated but the likelihood
    is that the culprit is some other IE add-on or possibly malware. If it were
    just the Google search files themselves that were the problem then replacing
    them with good copies by uninstall-reinstall should have fixed it. Are you
    able to select any of the other Search providers besides Live as the default
    (Ask, About, Wikipedia)? That would at least indicate if the problem was
    restricted to Google or if all search providers but Live were being blocked.
    That 'prevent programs..." checkbox should be available for each of them.

    I'd start by uninstalling any toolbars that have been added to IE. If you
    have several installed, remove one at a time and check if Google is fixed
    after the uninstall. If that doesn't produce any results you can try
    running IE with no add-ons from the Accessories-System Tools folder in the
    All Programs menu. If that still doesn't allow Google search to work, run
    anti-spyware/malware scans. This discussion might be related to your issue:

    http://forums.randi.org/archive/index.php/t-10946.html
     
    RalfG, Apr 20, 2009
    #9
  10. regfla

    Karen Guest

    I cannot make any other search provider a Default. Live Search is the only
    one. I tried to remove it as a search provider, but it is 'greyed' out and
    cannot be removed. The only toolbars I have are the old usual ones, like the
    menu bar, the favorites, the status bar. I will follow up with the link you
    sent me. I ran a spyware program just recently, but it didn't find anything.
    Keep thinking about it!
     
    Karen, Apr 20, 2009
    #10
  11. You might take a look at the following blog, and comments for a possible
    fix:

    http://blog.kirb.us/2009/03/20/a-pr...earch-provider-setting-for-internet-explorer/

    Good luck,

    Donald Anadell
     
    Donald Anadell, Apr 21, 2009
    #11
  12. regfla

    Karen Guest

    Don, I tried this step. Didn't work. I edited my registry, adding the value
    that this post suggested.
     
    Karen, Apr 21, 2009
    #12

  13. Anti-spyware could be a cause. Some of it is known to "protect"
    the registry, which is fine if it would only prevent improper registry changes.
    A problem is that it can not know which registry changes are "improper"
    and hence it typically ends up blocking *all* registry changes including
    ones that you want to do too (i.e. by using a settings dialog).

    You could use RegMon to check if this is the cause, e.g. trace SetValue
    being done by IE (e.g. using filter *iexplore*SetValue*). When you do
    that and it captures trace entries of your attempts to use the UI
    you may find that such requests get Permission Denied or some such
    indication that they didn't work. Another possibility which RegMon could
    also expose would be that a similarly misguided security program could
    have saved all registry values and instead of taking steps to prevent
    changes, it would simply monitor changes being made and replace
    them later with the "correct" value. Etc.


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Apr 24, 2009
    #13
  14. regfla

    kg52 Guest

    My two cents here for what it is worth. I am experiencing the same problem
    except Ask remains the unwanted default. since installing IE8. First I would
    get the message telling me something about default search corruption and then
    I would have to click ok and it would open Manage search Providers (this
    happened every time I opened Internet Explorer). First I deleted Windows Live
    search from search choices. My default search was Ask which I do not remember
    ever setting (I only had Google and Ask prev. to IE 8 Installation and Google
    has always been my default). So I want to set Google as default again in this
    Manage Search Providers window. When I would click on set as default though,
    nothing happens. I would delete Ask but you can't delete one unless you set
    another as default. Meanwhile this corruption notice would still display when
    opening. I removed ASK search from Add remove programs and now the corruption
    error no longer pops up but Ask is still set as default and I still cannot
    change that. The prevent changes to default search tab that you can check in
    Mangage Search Providers did not do any good either. I am not a high tech
    computer person and trusted MS IE to just keep my computer updated not add a
    bunch of often useless to me and corrupting add ons in the process that I do
    not have the knowledge or time to figure out how to safely remove. Needless
    to say I'm a bit frustrated but at least I got rid of the annoying corrupt
    error pop up, for now anyway.
     
    kg52, Apr 26, 2009
    #14
  15. regfla

    Kinesic Guest

    I stupidly downloaded IE8 today and have the same stupid message, the same
    frozen search engine, the same add-on that I don't want and can't make them
    go away! Helloooooo Microsoft! Many are having this problem, when do you
    plan to FIX it?
     
    Kinesic, Apr 29, 2009
    #15
  16. regfla

    Gordon Guest


    No problem here. Uninstall it.....
     
    Gordon, Apr 29, 2009
    #16
  17. regfla

    CarlWit Guest

    I have the same problem. I tried Start, Control Panel, Add or Remove
    Programs, Windows Internet Explorer 8, Remove. This bought me back to IE7,
    which works fine. I reinstalled IE8. Same problem. I now use Mozilla Firefox.
     
    CarlWit, May 2, 2009
    #17
  18. regfla

    regfla Guest

    Karen, try this if you have Webshots installed.

    I had the same problem. I've already complained to the company, now
    American Greetings, however, for now you can download an older, non-
    hijacking version of webshots from download.com
    http://www.download.com/Webshots-Desktop/3000-2196_4-11768.html?tag=mncol

    Good luck
     
    regfla, May 4, 2009
    #18
  19. regfla

    regfla Guest

    try this, it worked for me and my google problem.
    I had the same problem. I've already complained to the company, now
    American Greetings, however, for now you can download an older, non-
    hijacking version of webshots from download.com
    http://www.download.com/Webshots-Desktop/3000-2196_4-11768.html?tag=mncol

    Good luck
     
    regfla, May 4, 2009
    #19
  20. Niagara Mouse, Jun 17, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.