logging out directly after logging in

Discussion in 'Windows Server' started by Molensky, Nov 23, 2004.

  1. Molensky

    Molensky Guest

    Hello,

    Today we made an disk-to-disk Ghost image of a 2003 standard server. When we
    place the new imaged-disk in the system, windows boots normal, but after
    logging in, the server automagically and immediatly ends the login by loggin
    off. Same symptom happens directly at the sytem/keyboard or using RDC.

    I've queried Google for help and similar problems (with hopefully a
    solution). I've found some users describing the same symptoms, but all using
    XP. What makes it all more strange is, with the original disk, logging in has
    no problems.

    Little history: We have a system with a Western Digital 160GB disk
    (WD1600JB). S.M.A.R.T. warned us about a possible crash of the disk. Due to
    the price of this disk etc, we decided to purchase a similar or same disk.
    Make a Ghost image and we should be up and running within 2-3 hours. And
    worry about warranty and long RMA-procedures etc later. We bought the same
    disk.

    - We tried to enter recovery using the win2003-setup and using 'fixmbr';
    - someone suggested a grouppolicy which prevents logging-in when a hardware
    change has been made. I've started and looked on the original disk, but can't
    seem to find it. But I would suspect a local admin should always be able to
    login?
    - I've used an other system, used 'manage' to connect to the faulty system
    and view any eventlogs. The credentials are authenticated, but when I want to
    see the eventlog or services etc, it says 'access denied'.
    - Tried using save mode, VGA mode and last known good configuration.

    If I enter any wrong creditials during any of my attempts, it correctly
    alerts to tell the user/pass is incorrect.

    Any help is much apreciated, even pointers to other sources where I can
    continue my search.

    Tnx, Paul
     
    Molensky, Nov 23, 2004
    #1
    1. Advertisements

  2. I suspect that the physical location of userinit.exe is not in agreement
    with what the registry says (HKLM/Software/Microsoft/Windows NT/
    Current Version/Winlogon/Userinit). The usual trick is to copy this
    file to \winnt\system32 on every drive of the machine, using network
    access, before setting the registry entry to its correct value.

    I also suspect that you have an underlying problem: That your
    system drive is no longer C:. Use psexec.exe (www.sysinternals.com)
    to verify this, and post again if you need help in fixing this problem.
     
    Pegasus \(MVP\), Nov 23, 2004
    #2
    1. Advertisements

  3. Molensky

    Molensky Guest

    I've used psinfo, and your correct about your last assumption. The drive
    isn't C: but E: (see little dump of PSInfo below)

    Kernel version: Microsoft Windows Server 2003, Uniprocessor Free
    Product type: Edition
    Product version: 5.2
    Service pack: 0
    Kernel build number: 3790
    System root: E:\windows
    Video driver: Matrox Graphics MGA-G200 AGP
    Volume Type Format Label Size
    A: Removable
    D: CD-ROM
    E: Fixed NTFS new 149.0 GB

    Any suggestions how to correct this and make the disk become C: again?

    Tnx again, Paul
     
    Molensky, Nov 24, 2004
    #3
  4. Molensky

    Molensky Guest

    Hi Pegasus,

    thanx for your pointer. A little search in Microsoft Knowledgebases led me
    to Q249321 (problem) & Q223188 (solution).

    I will be testing this setup today, but for now I can login and the disk is
    C: again, so I suspect/hope this is the correct solution.

    Paul
     
    Molensky, Nov 24, 2004
    #4
  5. Well done! This is pretty much what I would have told you in
    my next post.
     
    Pegasus \(MVP\), Nov 24, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.