Lost USB devices after last night's Vista OS updates

Discussion in 'Windows Vista Hardware' started by Lee Stone, Nov 27, 2008.

  1. Lee Stone

    Lee Stone Guest

    Hello

    I hope someone can help me. I cannot see any other posts on this issue.

    Last night about three updates were installed using Windows Update on a
    fully working Dell XPS1330 laptop. This morning I booted up to find that the
    fingerprint sensor could not be found. Then my USB mouse and keyboard were
    not operational. In fact no USB device is seen including my USB memory
    stick.

    Any clues how to progress? Do I need to go back to the last restore point?
    Apologies if this information is already 'out there' - the most recent that
    I could find was from April of this year.

    Many thanks

    L
     
    Lee Stone, Nov 27, 2008
    #1
    1. Advertisements

  2. Lee Stone

    Rick Rogers Guest

    Hi,

    Control Panel/Programs and Features/View installed updates, remove the most
    recent ones one at a time, rebooting inbetween until your devices return.

    A system restore would accomplish the same thing similarly, but it would
    remove all the updates not just one. It may be that only one is a problem,
    and this you might want to mark to hide.
     
    Rick Rogers, Nov 27, 2008
    #2
    1. Advertisements

  3. Lee Stone

    Lee Stone Guest

    Rick, Max

    Many thanks

    L
     
    Lee Stone, Nov 27, 2008
    #3
  4. Lee Stone

    D Lirious Guest

    This has been a common issue with some Microsoft updates, particularly
    Service Packs in XP and presumably Vista.
    The standard advice from Microsoft under these circumstances, which for once
    actually works, is to open Device Manager and uninstall all the USB devices,
    or whatever the malfunction is, you see, then reboot- in this case with the
    USB peripherals not connected.
    When you reboot fresh USB drivers will be installed. Then reinstall your
    peripherals one by one.
    This should work better than tracing backward through the updates.
     
    D Lirious, Nov 27, 2008
    #4
  5. Lee Stone

    Lee Stone Guest

    Thanks for the tip. I tried this. Unfortunately, the fingerprint reader is
    built in - albeit connected internally via USB. The machine now boots into a
    load or error messages and app warnings layered on top of each other.

    I will now try and find the last restore point and work from there....

    L
     
    Lee Stone, Nov 28, 2008
    #5
  6. Lee Stone

    GWL Guest

    I too have had a similar problem. But I was not upgrading anything when it
    happened. Yesterday, my computer suddenly issued a series of USB port
    unplugging
    sounds. Investigation has revealed that none of the USB ports on my machine
    are functioning. No USB printer, keyboard or mouse (without PS/2). There were
    five windows displayed with the following message: "One of the USB devices
    attached to this computer has malfunctioned and Windows does not recognize
    it." Occasionally when I try to plug in a device, while no plugging sound is
    issued, the malfunction message will be displayed. I also have one USB port
    in a multi-card reader on my machine and it has a Ready Boost device plugged
    in. This device works when plugged in at Boot, but is unrecognized if plugged
    in after boot.

    I have gone to the earliest restore point and that did not work. I have
    installed all USB drivers in Device Manager and after Windows re-installed
    them the Devices still do not work. Only return the malfunction message when
    plugged in. In Problem reports there is a notation that Human Interface
    Device could not load driver software. Then goes on the report that Windows
    was able to install driver software, but encountered a problem when it tried
    to run.

    HELP, I have no clue as to what happened here.
     
    GWL, Nov 28, 2008
    #6
  7. Lee Stone

    Lee Stone Guest

    Hello

    I only just found your note. I tried all the above and more.

    Eventually, after a few abortive boots, all my USB devices just sprang back
    into life. All are now working well, including my fingerprint reader
    (internal USB connection). The most recent Windows Updates are all listed as
    present, too. Very odd.

    I hope yours is now working also?

    L
     
    Lee Stone, Dec 2, 2008
    #7
  8. Lee Stone

    GWL Guest

    Thanks for the reply Lee. I fought this all weekend. Yesterday I gave up and
    completely disconnected the computer from everything, then unplugged it
    getting ready to take it to a shop. Shop found nothing wrong. So I am left to
    assume that either the complete unplugging of the machine did something or
    the vibration of moving the machine did something that restarted the USB
    ports. I am leaning in the direction of the power off and unplugging as the
    fix as I ran into another user who's IT men could not fix her company
    computer that had suddenly lost all USB ports last Friday. She left it
    unplugged over the weekend and it worked fine on Monday morning.
     
    GWL, Dec 2, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.