Low levels of free disk space email?

Discussion in 'Windows Small Business Server' started by Jim G, Apr 18, 2007.

  1. Jim G

    Jim G Guest

    I've received several of these emails from the server. The drives, volumes,
    partitions look fine in Windows Explorer. What's the deal?

    Jim G

    The following disk is low on free disk space. Low levels of free disk space
    can cause performance problems and prevent users from saving files on the
    Drive Letter: HarddiskVolume4
    Free Disk Space: 0.000000. MB
    % Free Disk Space: 0.000000.%
    You can disable this alert or change its threshold by using the Change Alert
    Notifications task in the Server Management Monitoring and Reporting
    Jim G, Apr 18, 2007
    1. Advertisements

  2. You may see similar alerts from time to time if you have an external USB
    hard drive (or some other USB device) attached to the server and the USB
    cable is suddenly unplugged by a user or the device is turned off - in
    either case without clicking on the Safely Remove Hardware icon in the
    System Tray. The alerts can be ignored as they will eventually go away
    Merv Porter [SBS-MVP], Apr 18, 2007
    1. Advertisements

  3. Jim G

    Jim G Guest

    Thanks Merv,

    I have external USB drives that I rotate for backup purposes. I'm still
    having difficulty gracefully swapping the drives. The drive is not fazed by
    the Safely Remove Hardware icon, nor the devcon script. I've resorted to
    yanking the current drive and rebooting when I attach the new drive.

    I use drive mapping so I can take a peek at the USB drive from a workstation
    without having to RDP to the server. Is drive mapping my issue?

    Jim G

    Jim G, Apr 18, 2007
  4. Hi Jim,

    I can't speak to the mapped drive as being part of the problem, but whenever
    a USB drive cable is "yanked" (with or without a reboot), this kind of alert
    may be issued. My normal procedure is to turn off the power to the USB
    drive, pull out the USB, then replace the drive, reconnect the USB cable and
    turn the power back on. I don't believe I've every seen an alert when I use
    this procedure. I do, however, see a corresponding Ftdisk event in the
    System Event Logs.

    If you don't have a power switch on the USB drive, you might try connecting
    it to a surge protector, then turn off that surge protector before
    disconnecting the USB cable.

    Merv Porter [SBS-MVP]

    Merv Porter [SBS-MVP], Apr 18, 2007
  5. Jim G

    Steve Guest

    A lot of the newer small size drives have no external power at all-just from
    the USB port itself. Devcon so far has worked well for my client installs.

    Steve, Apr 18, 2007
  6. Jim G

    Jim G Guest

    Mine have a separate power cable and a power switch. I've been following
    Merv's procedures for disconnecting the drive.
    1. Turn off power to USB drive.
    2. Unplug power and USB cables from drive.
    3. Connect cables to different USB drive.
    4. Power-up USB drive.

    Steve, what devcon script are you using? I followed the devcon help and
    other resources to come up with the ones I attempted.

    Jim G

    Jim G, Apr 18, 2007
  7. Jim G

    Steve Guest

    Pretty simply:

    In a batch file that is run by a scheduled task after the backup
    devcon disable USBSTOR\DISK*

    In a batch file that is run by a scheduled task before the backup
    devcon enable USBSTOR\DISK*

    As I recall your USB device might have a different "name" than this but
    there are additional devcon commands that will tell you what the correct
    name is for your device.

    Steve, Apr 18, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.