mailto from Protected Mode: Off to Protected Mode: On

Discussion in 'Internet Explorer' started by Eric, Apr 16, 2007.

  1. Eric

    Eric Guest

    We've been testing our web apps to make sure our clients will be able to use
    IE 7 and Vista. Our sites are part of an extranet and to ensure that all
    applications function correctly without exposing the users, we have them add
    our domains to their list of Trusted Sites; been this way for years. The
    problem now is that when a user clicks a mailto link, Vista considers a
    mailto as part of the Internet Zone, opens it in a new brower with Protected
    Mode on, dumps an error that Internet Explorer couldn't display the page, and
    then opens the new email as appropriate. The problem here is the second
    browser that is opened just because a mailto link was clicked from where
    Protected Mode is off. How can I keep the second browser from opening or at
    least keep it from displaying the error? If a mailto is clicked from within
    a Trusted Site, shouldn't it too be considered trusted?

    One thing that I discovered is that if the mailto link is hosted within a
    framed page, the problem doesn't happen! If Microsoft really considers a
    mailto link to be a threat when clicked when Protected Mode is off, a frame
    should have no impact. Bug?
     
    Eric, Apr 16, 2007
    #1
    1. Advertisements

  2. Eric

    Eric Guest

    More...

    Though turning on Protected Mode for Trusted Sites would work around this
    issue, it would also put all other trusted sites under the control of
    Protected Mode.


    So the scenario is:
    1) Page, with a mailto link, exists in the Trusted Sites.
    2) mailto link is clicked.
    3) IE7/Vista considers a "mailto" to be part of the Internet Zone and opens
    a new brower.
    4) With the mailto address in the URL bar of the new browser, IE cancels the
    navigation and reports that the page cannot be displayed.
    5) The new email opens as though everything is fine.
    6) Many confused users then call our hotline to report the error.


    Scenario if hosted page is framed is (makes no sense at all):
    1) Framed page, with a mailto link, exists in the Trusted Sites.
    2) mailto link is clicked.
    3) The new email opens without a problem.
    4) Users are happy.


    Questions:
    1) How do I keep IE from treating a "mailto" as being part of a zone other
    than trusted?
    2) Why is the behavior different when the page is framed?


    Thanks!
     
    Eric, Apr 17, 2007
    #2
    1. Advertisements


  3. Why is it associated with your browser? I would expect that it would be
    associated with Windows Mail instead. Oh, I see you are already cross-posting
    to an Outlook NG, so you have changed the association already?

    Open a cmd window and enter:

    ftype | find /i "mail"

    to see what the association and open action really is.

    Also what happens if you just Run... mailto: (e.g. start it from explorer.exe)?

    I think you would find more informed assistance on a Vista newsgroup
    than IE General. I suspect the symptom has more to do with the OS
    than with the browser.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Apr 17, 2007
    #3
  4. Eric

    Eric Guest

    An association does exist otherwise I'd be getting the problem where 50
    windows open and the mail client never comes up.

    Opening mailto: from Run is fine and opening mailto: when on a site with
    Protected Mode: On is fine. The problem is that Trusted Sites have Protected
    Mode: Off and Vista is treating mailto: as being part of the Internet Zone
    which has Protected Mode: On. So when you click on a mailto that exists on a
    site in your Trusted Sites list, a new browser opens with Protected Mode: On
    and mailto: as the address. Navigation cancels with an
    error and then your default email client loads.

    If I turn ON Protected Mode for Trusted Sites, then there is no problem but,
    that impacts all sites a user may have in their list. The only time this is
    seen is when opening a mailto from a zone that has Protected Mode: Off but
    Protected Mode is On for the Internet Zone.


    You got Vista and IE7? Go ahead and try it. Find a page with a mailto
    link, add that page to your Trusted Sites, reload the page as a trusted site
    so that Protected Mode turns Off, and then click on the mailto link.
     
    Eric, Apr 17, 2007
    #4

  5. This doesn't answer my question. ; ]


    That's what doesn't make any sense to me and why I suggested you find
    out what the mailto Filetype open action is set to.

    FWIW here it is for XP:

    <cmd_output>
    E:\>ftype | find /i "mail"
    mailto="%ProgramFiles%\Outlook Express\msimn.exe" /mailurl:%1
    Microsoft Internet Mail Message="%ProgramFiles%\Outlook Express\msimn.exe" /eml:%1
    </cmd_output>


    Hence there would be no reason for "a new browser" to open at all...


    No I don't. I was going to cross-post to Vista Mail last time
    until, as I remarked, I noticed that you were already cross-posting
    to Outlook.

    What happens if you replace your (assumed) association
    with Outlook for the default association with Windows Mail?
    Perhaps your Outlook(?) association is the cause of your symptom?


    ; }

    Robert
    ---
     
    Robert Aldwinckle, Apr 18, 2007
    #5
  6. (cross-post added to Vista Mail)

    Oops. Sorry. I had no idea it would return all that.
    Perhaps we should just be looking at a find for "mailto" then? ; )

    BTW what would be the significance of the 8.3 path name?

    Good. Cross-post added to Vista Mail to see if your symptom
    is understood by anybody else who is seeing it.


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Apr 18, 2007
    #6
  7. Eric

    Eric Guest

    BTW what would be the significance of the 8.3 path name?
    Probably just something stupid with Vista.

    I switched the association to Windows Mail and experienced the same problem.

    It's gotta be a bug in the Protected Mode feature.
     
    Eric, Apr 23, 2007
    #7
  8. Eric

    Eric Guest

    Eric, Apr 24, 2007
    #8
  9. Eric

    Stefan Guest

    Hi Eric

    I have the same problem with the IE7 and Vista.

    Do you have already a solution for this problem?


    Thanks
     
    Stefan, Sep 13, 2007
    #9
  10. Eric

    Eric Guest

    I never was able to find a workaround for this problem.
     
    Eric, Sep 18, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.