Mandatory User Profiles and Group Policy...delete locally cached c

Discussion in 'Active Directory' started by dterborg, Jun 16, 2006.

  1. dterborg

    dterborg Guest

    Hi all,

    I'm making a change to a network I'm working on so that one group of users
    has a mandatory profile assigned to it. I've created the profile and copied
    it to a share on the Server 2003 primary domain controller. I've set up a
    test user that maps to this profile.

    My problem is this: One of the primary reasons I created mandatory profiles
    was so that we don't have users consuming disk space to the point of "disk
    full" errors, since there are many different users on a single workstation.
    While the mandatory profile seems to work, a copy is saved for every user
    that logs on to the workstation. This doesn't fix my problem, as the local
    hard disk will end up filling up eventually anyway.

    I've tried using Group Policy and set the option for the user group to
    "Delete cached copies of roaming profiles" (located in Computer
    Configuration-->Administrative Templates-->System-->User Profiles in the GPO
    I've created) to enabled, but this does not seem to fix my problem. I've
    also tried using REGEDIT on the local machine and adding the following DWORD
    value set to 1:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

    "DeleteRoamingCache"=DWORD:00000001

    This has not solved the issue either. I'd like to make sure that at the
    point a user logs off, their local copy of the profile is blown away, thereby
    keeping the disk from filling, and forcing their system to retrieve the
    profile over the network anew the next time they log in.

    If anyone has any suggestions, I'd appreciate it.
     
    dterborg, Jun 16, 2006
    #1
    1. Advertisements

  2. dterborg

    dterborg Guest

    P.S. After thinking about it, I've decided I really don't want this done as
    a local registry edit, so I've reversed this change (I'd like to use this
    software image for more than just the user group I need the change for).
     
    dterborg, Jun 16, 2006
    #2
    1. Advertisements

  3. dterborg

    Jorge Silva Guest

    Hi

    If you want to limit Profile space - use GPO to control the maximm size of
    the user profile.
    You can also use GPO to implement Quotas in their hdd.

    --
    I hope that the information above helps you

    Good Luck
    Jorge Silva
    MCSA
    Systems Administrator
     
    Jorge Silva, Jun 16, 2006
    #3
  4. dterborg

    dterborg Guest

    Hi,

    My problem is, this is in an educational environment. Even if I limit the
    size of each user profile to 5MB, 5MB x 200 students = 1GB of local hard disk
    space. These systems are a bit older, so their hard disks are small, and
    they're more prone to fragmentation as well. I'd like to not have their user
    profile saved to the local hard disk at all. From what I have read, the
    change I made to the GPO should solve this, but it isn't --am I doing
    something wrong, or is this just not how it works?

    Douglas

     
    dterborg, Jun 16, 2006
    #4
  5. dterborg

    Jorge Silva Guest

    1. Edit the GPO that you want to modify.
    2. Locate the following section: Computer Configuration \
    Administrative Templates \ System \ User Profiles.
    3. Double-click Delete cached copies of roaming profiles (the Group
    Policy setting).
    4. Click Enabled.


    To check if the policy is being applied used RSoP.msc in logging mode

    --
    I hope that the information above helps you

    Good Luck
    Jorge Silva
    MCSA
    Systems Administrator

     
    Jorge Silva, Jun 16, 2006
    #5
  6. dterborg

    dterborg Guest

    Hi Jorge,

    I have done this, and the locally cached copies still aren't deleted. I
    tried using RsOP to determine what is going on, but entire sub-folders of the
    policy don't show up in the report that is generated for my test user; that
    is, when I go to view the report, I can find Computer
    Configuration->Administrative Templates, but only one sub-folder exists
    within it, Windows Components, the System sub-folder isn't there.

    I ran RsOP from my own machine (XP box with the 2003 admin pack installed)
    set to gather RsOP data from a machine that I had logged into previously as
    the user profile I'm testing with. I hope I'm giving enough detail; if you
    need more information, please let me know.

    Thanks for all the great help you've provided so far,

    Douglas Terborg
     
    dterborg, Jun 19, 2006
    #6
  7. dterborg

    Jorge Silva Guest

    If I understand you correctly, when you run rsop.msc in logging mode the
    policy "delete cached users profile" doesn't show up, is this right?
    If yes then generally is because isn't being applied at that user. Check if
    the policy is being applied to the user and/or correct OU.

    --
    I hope that the information above helps you

    Good Luck
    Jorge Silva
    MCSA
    Systems Administrator
     
    Jorge Silva, Jun 19, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.