Map network drive via logon script and launchapp.wsf error in scri

Discussion in 'Windows Vista Networking' started by Ziv, Jul 9, 2007.

  1. Ziv

    Ziv Guest

    Hello,
    I have a problem with logon script in vista to map networks drive. I have
    followed Microsoft suggestion in article for using launchapp.wsf.

    http://technet2.microsoft.com/Windo...878e-48db-a3c1-4be6ac7cf7631033.mspx?mfr=true

    There I found exactly the problem I was having and the solution.
    Unfortunately the script is faulty. I copied and paste it in notepad. and
    saved it as launchapp.wsf. But every time it runs I get an error message:
    ---------------------------
    Windows Script Host
    ---------------------------
    Script: \\dc1\staff$\ZShadar\launchapp.wsf
    Line: 114
    Char: 2
    Error: Syntax error
    Code: 800A03EA
    Source: Microsoft VBScript compilation error

    ---------------------------
    OK
    ---------------------------

    I get the same result if I run it from the GPO or manually.

    I will appreciate any help.

    Regards

    Ziv Shadar
     
    Ziv, Jul 9, 2007
    #1
    1. Advertisements

  2. Ziv

    jo.eads Guest

    If line 113-115 of code looks like the following: Delete line 114

    call rootFolder.RegisterTaskDefinition( _
    ****(Delete this line of code)***
    strTaskName, taskDefinition, FlagTaskCreate, _

    Should look like this:

    call rootFolder.RegisterTaskDefinition( _
    strTaskName, taskDefinition, FlagTaskCreate, _
     
    jo.eads, Aug 31, 2007
    #2
    1. Advertisements

  3. Ziv

    mrdaytrade Guest

    Here is a real simple fix for Vista and Windows 7. Just add this
    registry item. Copy and past the lines below into a text file and name
    it networkdrivefix.reg or whatever you want. Then double click the file
    to add it to your registry.


    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    "EnableLinkedConnections"=dword:00000001
     
    mrdaytrade, May 6, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.