Mapping Network Drives

Discussion in 'Windows Vista Networking' started by damnlimey, Oct 30, 2007.

  1. damnlimey

    damnlimey Guest

    I have a NAS drive on my home network. Under XP I could map different drive
    letters to different folders on the drive. Under Vista I was initially able
    to set up the storage the same way, but now something has changed and I
    cannot log on to the private folders, even though I provide the correct user
    name and password.

    This is not a NAS or Network problem as i still have the XP machine
    available and can access the private folders with no problem.

    Any thoughts?
     
    damnlimey, Oct 30, 2007
    #1
    1. Advertisements

  2. damnlimey

    Malke Guest

    It actually may be a NAS problem in that most NAS's use some form of
    embedded Linux and will probably need updating to work with Vista since
    authentication is different on Vista (see below). If you have the
    ability to configure the Samba running on the NAS, you may make changes
    there yourself although it is unlikely that you will have access to the
    smb.conf file. You can try the fix for Vista below, but probably the
    best solution is to contact the NAS mftr.'s tech support to see what
    they say.

    From Michael Bishop (MS) - Basically, the issue with Samba and Vista is
    that Vista no longer permits LM or NTLM authentication by default; only
    NTLMv2. Samba versions 1.x and 2.x only support LM and NTLM, so there's
    an issue there.

    Recommended solution: upgrade to Samba 3.x and enable NTLMv2 by adding
    "client ntlmv2 auth = yes" to your smb.conf file. Because of another
    issues with previous versions, I strongly recommend upgrading to 3.0.22
    or later regardless of your choice for this particular instance.

    Alternate solution: change Vista's security settings to permit
    lower-security authentications. (as below)

    To enable Windows Vista to connect to Mac OS X with Windows File Sharing
    enabled, you will need to change the following policy in Windows Vista:

    Start>Run>secpol.msc [enter]

    Click on "Local Policies" --> "Security Options"

    Navigate to the policy "Network Security: LAN Manager authentication
    level" and double-click it to get its Properties. By default Windows
    Vista sets the policy to "NTVLM2 responses only". Use the drop-down
    arrow to change this to "LM and NTLM – use NTLMV2 session security if
    negotiated".

    In Vista Home Premium, you won't have this tool so per Steve Winograd, do:

    1. Run the registry editor and open this key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    1. If it doesn't already exist, create a DWORD value named
    LmCompatibilityLevel

    3. Set the value to 1

    4. Reboot


    Malke
     
    Malke, Oct 30, 2007
    #2
    1. Advertisements

  3. damnlimey

    damnlimey Guest

    Thanks for the hint. I went to the Seagate website (since this is a Maxstor
    NAS which is now part of Seagate) and they said the same thing. I did the
    registry edit this AM before leaving for work. Now I have a different error
    message that says "Multiple connections to a server or shared resource by the
    same user, using more than one user name, are not allowed."

    I was not able to try disconnecting the public drive on the share but does
    this mean that I can only map ONCE to the share?

     
    damnlimey, Oct 31, 2007
    #3
  4. damnlimey

    Malke Guest

    I wouldn't think so. I've got a Maxtor NAS at a client's - lots of XP
    machines, no Vista ones - with many shares but I don't map any drives.
    Check with the Maxtor's tech support. Or maybe someone else reading this
    newsgroup knows.


    Malke
     
    Malke, Oct 31, 2007
    #4
  5. damnlimey

    H S Guest

    Hi

    I have the same problem:

    I have a Lacie NAS 2 and everytime I logged in to Windows I had to key in my user name and password for MyShare (which is the password protected one).

    So I thought perhaps I did not tick the button to remember password and that I will disconnect and reconnect. However, now I cannot reconnect and I get the following message: Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

    Please help! Thanks in advance.

    PS I run Windows Vista
    PPS I tried creating a user with the same user name and password as the drive in Windows and with that I can connect and disconnect multiple times.
     
    H S, Dec 30, 2010
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.