Might have screwed up the C:\ProgramData folder...

Discussion in 'Windows Vista Help' started by DanielEKFA, Apr 26, 2008.

  1. DanielEKFA

    DanielEKFA Guest

    Hey there :)

    I've been using xxcopy for a while to mirror my important data, which are
    all on my D: drive to an external USB drive.

    The other day I thought, "but wait, there's also the icons (if nothing else)
    in the shared start menu folder, which is on the C: drive, maybe I should
    include that." These icons were inside the C:\ProgramData folder, so I
    thought that maybe there were some other important things in there I wasn't
    aware of, so I decided to just back up the entire ProgramData folder.

    Blech! Xxcopy kinda went into an infinite recursion, copying stuff from
    C:\ProgramData\Application Data\Application Data\Application
    Data\Application Data\... etc. I found out that this "Application Data"
    folder was actually a junction, or symlink if you like, to the ProgramData
    folder itself, hence the recursion.

    Weird part was, "Application Data" didn't show up in Explorer or in a
    command prompt, which junctions usually do (I use them myself alot, so I was
    puzzled that I couldn't find it). I thought something "bad" was up with this
    folder, and not really hesitating to think it properly through, I removed
    the "junction" with a 'junction /d "application data"', which did indeed
    succeed. No more recursion, no more woes. Except...

    I now find that Windows Search is no longer able to start. Looking on the
    Internet, other people've had the same woes, but for different reasons, and
    while they fixed it by clearing out some temp folders, this does not work
    for me. I tried creating a new "application data" junction, but this does
    not result in the same. I realized too late that this is a virtual folder
    type of thingie, so lots of stuff is probably going on behind the scenes
    that I have no clue about. A reboot did nothing, by the way.

    I should say that I also recently installed SP1, which COULD be the cause
    for Windows Search no longer working, but I'm pretty much positive that I've
    used the search index in the meantime (I used it extensively), so I'm more
    or less ruling that out. I'm pretty sure it's my wrongdoings with the
    "junction /d" command that put me in this situation.

    I'm just not sure what to do, so I'm turning to you guys. Any ideas?

    Thank you,
    Daniel, Denmark :)
     
    DanielEKFA, Apr 26, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.