Most DVD games won't install

Discussion in 'Windows Vista Games' started by McBain, Nov 29, 2007.

  1. McBain

    McBain Guest

    I think AnyDVD caused the problem. AnyDVD is uninstalled now but the problem
    won't go away. Everything is up-to-date including the BIOS. I've tried
    reinstalling the DVD ROMS. The problem persists even in safe mode.

    Quake Wars: ignores disk, no autoplay. right click for 'install' gets no
    action. disk content not visible even disk icon comes up.

    Bioshock; Lauching already istalled game results in BSOD. Unintalled game,
    then tried reinstalling. Autoplay menu comes up but 'install' gets no action.

    Crysis: Thank heavens it installed okay; plays well.

    Lost planet; Steam registers the install, installs from dvdrom okay, plays
    well. Disk not needed as it is now registered with steam.

    Battlefield2142: BSOD happens right after you select language to install.

    Timeshift: BSOD right at install.

    Company of Heroes; BSOD right at install.

    Call of Duty, Pacific Duty; BSOD at install.

    The system is otherwise stable. Either AnyDVD or SecuRom or StarForce threw
    a monkey wrench in the system and I should sue. Vista shouldn't be this
    frail.
     
    McBain, Nov 29, 2007
    #1
    1. Advertisements

  2. McBain

    dzomlija Guest

    It more than likely SecuROM or StarForce. They usually need to be able
    to run in the same memory space as the system kernel, which Vista does
    not allow. Have you tried running the installers in XP Compatibility
    mode?


    --
    dzomlija

    ____________________________________
    Peter Alexander Dzomlija
    Do you hear, huh? The Alpha and The Omega? Death and Rebirth? -And as
    you die, so shall I be Reborn-...

    - ASUS A8N32-SLI-Deluxe
    - AMD Atlon 64 Dual-Core 4800+
    - 4GB DDR400
    - 128MB ASUS nVidia 6600 PCI-Express
    - Thermaltake Tai-Chi Watercooled Chassis
    - 1207GB Total Formatted Storage
    - Vista Ultimate x64
    - CodeGear Delphi 2007'http://dzomlija.spaces.live.com/' (http://dzomlija.spaces.live.com/)
     
    dzomlija, Nov 29, 2007
    #2
    1. Advertisements

  3.  
    wildwestcoaster, Jan 6, 2008
    #3
  4. First attempt to contribute heremate. My Bioshock has been languishing since
    November waiting for a reply from the arrogant swines at 2K to bother to
    reply to multiple e-mails . securom fails to operate after the game installs
    normally. As they are owned by Sony, I dont think they can plead poverty
    with any credence! When are they going to take seriously issues other than
    how to maximise profit?

    I am Scottish, but this goes beyond any regional stereotype I'm sure you'd
    agree!

    Happy New Year!
     
    wildwestcoaster, Jan 6, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.