My .exe files are being opened in notepad...

Discussion in 'Windows Vista General Discussion' started by shinryuu, Nov 1, 2007.

  1. shinryuu

    shinryuu Guest

    somehow they are now set to open in notepad, and i can't find out how to
    change the .exe files to open as executables. help would be greatly
    appreciated...
     
    shinryuu, Nov 1, 2007
    #1
    1. Advertisements

  2. shinryuu

    shinryuu Guest

    i have managed to run the programs again by setting them to open with
    runxx... but now icons have disappeared... not as bad, but still annoying...
    aby ideas on how to solve this?
     
    shinryuu, Nov 1, 2007
    #2
    1. Advertisements

  3. shinryuu

    Rick Rogers Guest

    Hi,

    Have you tried system restore yet? This is precisely why it exists, to
    resolve issues and changes not easily undone.
     
    Rick Rogers, Nov 1, 2007
    #3
  4. shinryuu

    mayayana Guest

    You might try comparing the Registry setting with
    someone else's. It's likely that there should be
    something like:

    HKEY_CLASSES_ROOT\exefile\DefaultIcon

    with a default value of: %1

    ( If you look under HKEY_CLASSES_ROOT you'll
    see keys for all registered file extensions. Under
    the .exe key will be a default value that points
    to another HKEY_CLASSES_ROOT subkey that's
    named for the name being used for that file type.
    So, for instance, HKEY_CLASSES_ROOT\.txt probably
    leadss to HKEY_CLASSES_ROOT\txtfile, under which
    will be keys telling Explorer how to handle that
    particular file type. The default program is under
    HKEY_CLASSES_ROOT\txtfile\Shell\Open\Command.
    There's often a DefaultIcon key. Etc. )

    I would hope that Vista is not so bad that a
    messed up EXE association requires a System Restore.
     
    mayayana, Nov 1, 2007
    #4
  5. shinryuu

    bomb#20 Guest


    Create a new blank text document.
    Copy and paste the following into it :


    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\exefile\shell\open\command]
    @="\"%1\" %*"
    "IsolatedCommand"="\"%1\" %*"


    Save the text document and change extension from .TXT to .REG
    Right-click new REG document and select ' Merge '.

    Good luck!
    ..
     
    bomb#20, Nov 1, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.