Natural Keyboard Hot Keys While Minimized

Discussion in 'Windows Media Player' started by John V. Barone, Jul 29, 2004.

  1. I just purchased a Microsoft Natural Pro keyboard, and have noticed the
    following in regards to the keyboard's media navigation keys (play/pause,
    back, forward, stop, etc.).

    1. Everything is fine if Windows Media Player is not minimized. It does
    not matter if the player is in the background or foreground, or if it is
    maximized or not maximized.
    2. If the player is minimized, then the media-related hot keys do not work.
    Does not matter if minimized to the toolbar mini player or to the
    "traditional" way. All non-media related keys (including volume, believe it
    or not) continue to function normally.

    Any suggestions?? Or is this a bug??

    Running Windows XP, SP 1 & WMP 9.

    TIA,
    John Barone
     
    John V. Barone, Jul 29, 2004
    #1
    1. Advertisements

  2. John V. Barone

    Josh Mitts Guest

    I think (not positive here) that the hot keys are sent to the active
    application, with the exception of system-related keys (such as volume,
    etc.). If Windows Media Player is not the active application, then it likely
    is not receiving the message that the keys are being pressed.

    So this would be by design...take an example where you have two applications
    that both are playing music simultaneously (e.g. Winamp and WMP), maybe
    broadcasting to a radio station or writing to a file, etc.....which
    application should these keys control? Rather than try to figure it out, I
    think Windows let's you make the choice by requiring you to switch to the
    app you want to control. This doesn't apply to system-related stuff (such as
    volume), since that is shared between all applications.

    (There may be cases where the computer manufacturer has set up a certain
    application to "catch" these media keys and forward them to a default media
    player program, but if so, that would vary widely by manufacturer).
     
    Josh Mitts, Jul 29, 2004
    #2
    1. Advertisements

  3. I see your points, but...
    1. Why then would the keys work if WMP is not minimized, but is not the
    active application (i.e., maximized or normal window, but behind another
    program which I am actively working on)? This is the case with me.

    2. Having such a situation (must somehow activate WMP to use the keys) is
    of **very limited** utility.... The phone rings, and instead of just
    hitting the key (which is the point of it after all) to pause the player,
    you have to hunt around for WMP, then bring it up front, then hit the key on
    the keyboad. When at that point you might as well use the mouse... :-(

    Right now, I'm experimenting w/having WMP open in the background and using
    the keyboard, which seems to work ok. But I would much rather have WMP
    minimized down to the toolbar miniplayer. That way I can either use the
    mouse or the keyboard to control things, depending on my mood...

    John Barone
     
    John V. Barone, Jul 29, 2004
    #3
  4. John V. Barone

    Josh Mitts Guest

    Ah yes I see what you're saying. That's true. If it does get those keys when
    it is open but not active, it could be a bug. I don't have a hotkey-enabled
    keyboard to try it out with...anyone else have any ideas?
     
    Josh Mitts, Jul 29, 2004
    #4
  5. John V. Barone

    WineGuy Guest

    I have the same problem on 2 different computers both running WXP SP2 and WMP
    10. The problem did NOT occur when running WXP SP1 & WMP 9. I'd call it a
    bug.
     
    WineGuy, Sep 28, 2004
    #5
  6. John V. Barone

    Seth Guest

    Well all this does seem amusing to me as microsoft created the media keyboard
    for their program and with media player 9, it worked perfectly when
    minimised. i think al this could be put down to a design falt and i am
    hopwimg microsoft can give us some advice or a patch to fix this issue. Also,
    it must be with WMP10 as i am currently on SP1 and using WMP10 and still the
    hotkeys do not work.
     
    Seth, Nov 16, 2004
    #6
  7. John V. Barone

    WineGuy Guest

    Think I found the solution and it's simple. I had plugged in the USB
    connector AND the keyboard connector. Removing the keyboard (purple)
    connector solved the problem. It also solved a problem when I held a SHIFT,
    CTRL or ALT key for more than one keystroke. Previously the second keystroke
    did not have the effect of the key combo. Now all is fine. Must have been a
    conflict with the keyboard.
     
    WineGuy, Nov 16, 2004
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.