Network Congestion with MCE on xbox360 using gigabit switch

Discussion in 'Windows Media Center' started by REN, Apr 28, 2006.

  1. REN

    REN Guest

    The short story is that I can get it working flawlessly by forcing the server
    to 100Mb rather than 1Gb, BUT I want the extra bandwith because all the other
    computers on the network are 1Gb capable and file transfers are much faster
    that way!

    I have an Asus p5wd2 motherboard 3Ghz dual core, 1GB ram, with marvel yukon
    gigabit ethernet adapter on board. This is connected to a netgear GS116
    gigabit ethernet switch. For completeness, the network is pretty standard
    with the cable modem going to the wgt624 wired/wireless 10/100 firewall
    router, and the router than providing internet and DHCP services to
    everything else on the network. All of the wired devices go to the 16 port
    gigabit switch which has one connection to the router. The MCEPC connects to
    the switch at 1Gb, as do the other computers with Gb adapters. The 360 and
    two of the older computers connect to the GS116 at 100Mb. The runs are
    originate from a structured media panel in the basement to their
    destinations. The longest runs are probably 50 Feet. Cabling is all CAT5.
    I planned CAT5e but that's another story.

    Are there know problems with gigabit adapters and the 360? The older
    computers aren't intimidated by the faster Gb server. They stream files
    fearlessly and flawlessly. Network monitor says I'm using like 4% available
    bandwidth at 1Gb, yet the 360 chokes unless I slow the server down to 100Mb.

    Hopefully this is a known issue. Please let me know.
     
    REN, Apr 28, 2006
    #1
    1. Advertisements

  2. Have you updated to the latest drivers for your Ethernet NIC? If that
    doesn't do the trick, do have a second Gbit switch you could try for
    comparison? FWIW, I've previously used my Xbox 360 against a PC with the
    same Gbit NIC and didn't have any issues.
     
    Todd Bowra [MSFT], Apr 28, 2006
    #2
    1. Advertisements

  3. REN

    REN Guest

    Yes, I believe I downloaded the latest drivers. SOP for putting a new PC
    together.
    No, I don't have another Gbit switch. I can try moving the xbox and pc
    close and using short runs with 5e cable. the network tuner in MCEPC goes
    full on, off, full on.. forever.
    I'll try the short runs when I get back from soccer. I'll look for new
    driver again, just to be sure.
     
    REN, Apr 28, 2006
    #3
  4. the network tuner in MCEPC goes full on, off, full on.. forever.

    Are you saying it oscillates between all green bars and no bars whatsoever?
    If so, open Task Manager while the Network Performance Tuner is running and
    look at the Network tab; does it show steady traffic (if so, how much?) or
    does it spike up and down?
     
    Todd Bowra [MSFT], Apr 29, 2006
    #4
  5. REN

    REN Guest

    Yes, it goes between all green and 1~2, although sometimes it stops at SDTV
    and goes back up to HDTV(all green)

    I rebooted between each of the following tests:
    I checked the pc to switch and xbox to switch and still got a problem even
    with short cables and nothing else connected to the gigabit switch.
    I then hooked it back up with the MCEPC and 360 on the 100Mb router with
    that hooked to the switch and it worked.
    I then moved the MCEPC to the switch and left the xbox on the router. That
    worked also. I then moved the 360 back to the switch along with the MCEPC
    and the problem occurred.

    Here are the numbers:
    100Mb a task called ehrecvr is taking 17% cpu with no test running. Run the
    test and the network goes to 32% and the cpu goes to about 32%.
    the 100Mb and 1Gb split configuration, same cpu loads, network taking a
    steady 3% during the test.
    With both hooked to the !gb switch, the NW usage is all over from 1% to 4%.
    CPU is using less and ehrecvr was using very little.as I recall..

    I have used ethereal before but it is not exactly easy. Is there an easy
    characterization tool with more info than task manager or do you already have
    an idea as to what could be wrong. I might be able to borrow a different Gb
    switch also... altough i really don't want it to be the switch :-(.
     
    REN, Apr 29, 2006
    #5
  6. REN

    REN Guest

    In addition to the response below, I tested some more, updated the bios,
    updated the nic driver(although it was fine) and played with most of the
    settings. It ONLY fails when both the 360 and the MCEPC are connected
    directly to the Gb switch. I really don't understand this as having the pc
    connected to the switch and then connecting the switch to a spare 100Mb
    router I have and the 360 to that router works, but it would seem you have
    the same speed mismatch and the same traffic.. ? maybe the router has more
    buffer space to play with and smoothes things out? I am very very tempted to
    get a different Gb switch.

    Thoughts?
     
    REN, Apr 29, 2006
    #6
  7. REN

    REN Guest

    A d-link switch works fine, so therefore, it must be the netgear GS116.
    Thanks for the hints.
    I'm still curious though, has anyone had success with a GS116.. ie is mine
    broken or just an incompatable product??... not exactly sure how a switch
    would be incompatable, but I suppose anything could happen.

    That may interest everyone else if the GS116 is not compatable.
    Thanks again
     
    REN, Apr 29, 2006
    #7
  8. try to get netgear to replace it as defective with another GS116. if
    you have the same problem, then there's definitely something wrong.

    --

    Barb Bowman
    MS Windows-MVP
    Expert Zone Columnist
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
     
    Barb Bowman MVP-Windows, Apr 30, 2006
    #8
  9. REN

    REN Guest

    I had submitted a tech request when I found it was firmly tied to the switch.
    It has been slow, but I will post any progress or resolution. Thanks.
     
    REN, May 3, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.