network controller and wireless card driver not found and wont ins

Discussion in 'Windows Vista Hardware' started by azreal, Jul 12, 2007.

  1. azreal

    azreal Guest

    Hi i recently had a automatic vista home basic update and after it installed
    i have not been able to access my wireless internet. i get a message saying
    that the drivers cannot be found. i went to the device manager and it says
    the same and also that my network controller drivers are missing. so i try to
    automatcaly reinstall drivers but they are not found and i have tryed the
    disk that came with the laptop and the belkin wireless g notebook wireless
    card but none of these help. i can connect using a wire but yesterday all was
    fine the only change i have had is this update. i tryed to do a system
    restore but now that fails aswell i am a little distresed please help.
     
    azreal, Jul 12, 2007
    #1
    1. Advertisements

  2. azreal

    freddy Guest

    azreal,

    If your wireless is a USB device, then some folks have had good luck
    resolving USB device recognition issues like you have by deleting the
    INFCACHE.1 file, which can get corrupted with bad data and cause issues like
    you have. The file is located at C:\Windows\inf. There, scroll down to the
    INFCACHE.1 file and right click it and select delete. To do this, you will
    likely have to give yourself permission to delete it, because of Windows
    built-in Security. Just right click the file, select Properties and then
    click on the security tab. Let us know whether this procedure does anything.
    Sometimes it does and sometimes not. Post back on the results.
     
    freddy, Jul 12, 2007
    #2
    1. Advertisements

  3. azreal

    dean-dean Guest

    Have you tried downloading the Vista driver for your Belkin card? Starting
    here:

    http://www.belkin.com/support/browse/?lid=en

    Start by choosing Networking Products > Wireless > etc. Make sure you chose
    a Vista compatible driver, after finding your model, and, under Software &
    Updates, clicking on Driver...
     
    dean-dean, Jul 12, 2007
    #3
  4. azreal

    azreal Guest

    ok tried that but to no avail seems to be the internal network controller
    rather than the wireless card. cheers for responding any way.
     
    azreal, Jul 12, 2007
    #4
  5. azreal

    azreal Guest

    cheers i have done that but still no joy it seems to be the network
    controller rather than the plug in wireless card. thanks for you response any
    way.
     
    azreal, Jul 12, 2007
    #5
  6. azreal

    freddy Guest

    azreal,

    Can you post the name of the item in Device Manager where the driver is
    missing? That is , if you can connect with a wire, then the network
    controller must be working. More specifics may (or may not) be helpful.
     
    freddy, Jul 12, 2007
    #6
  7. azreal

    dean-dean Guest

    Do you mean your CardBus Controller under PMCIA adapters? In Device Manager
    double-click on the problem device, and on the Driver tab, choose Roll Back
    Driver. If that's grayed out, try Update Driver. Click on "Browse my
    computer for driver software," then "Let me pick from a list of device
    drivers on my computer". Choose something other than what you currently
    have.

    You could also try going to your computer manufacture's web site and
    download the Controller for your notebook model.
     
    dean-dean, Jul 12, 2007
    #7
  8. azreal

    azreal Guest

    Yer thats what I thought but it is under other devices as network controller
    with the device tower icon that vista has with a yellow triangle and a
    exclamation mark with it.it is pci bus 3. my belkin card also is in this
    other devices subsection as unknown device i know that it is my card because
    i had it recognised a few times when i am wired in but this is intermittent
    and not recognised now when i remove the wire i get the yellow triangle over
    the network icon and no matter what i try it wont connect. i had a similar
    problem recently with my dvd drive and it involved deleting some regestry
    files to sort it from what i remember. i have tried every possible way to
    update the drivers but no joy. i also note that all system restores up untill
    today have gone. which i find a bit odd.
     
    azreal, Jul 12, 2007
    #8
  9. azreal

    azreal Guest

    no i have another in there that is working ok. this shows in other devices as
    network controller with a exclamation triangle on the device icon. i have
    tryed updating from the toshiba website but once again no joy. i had a
    similar thing happen to my dvd drive recently but i from what i remember it
    involved deleting two files from the regestry then all was ok. i also note
    that all my system retore files excluding today are gone...
     
    azreal, Jul 12, 2007
    #9
  10. azreal

    freddy Guest

    azreal,

    From a distance, I'm having problems seeing this in my mind's eye, so to
    speak. I would try simply uninstalling those unknown devices in Device
    Manager under the Properties of each unknown device. Leave everything
    connected and uninstall them. Then reboot to see what happens. Sometimes
    Windows fixes these problems when it reboots. That's the idea at least.
    Post back on results.
     
    freddy, Jul 12, 2007
    #10
  11. azreal

    azreal Guest

    the fix for my dvd was to delete these files.
    -- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325
    -11CE-BFC1-08002BE10318} - "Upperfilters" and "Lowerfilters".
    dont suppose any easy fix like that
    thanks
     
    azreal, Jul 12, 2007
    #11
  12. azreal

    dean-dean Guest

    In Control Panel (Classic View) > Windows Update, when you click on "View
    Update History", can you identify what device driver was recently updated
    (ignoring all the KBxxxxxx updates)? Sort the view by "Installed On".

    Navigate back to the main page. Can the device be uninstalled when you
    click on Installed Updates (on the left-hand side of the Windows Update
    window, down in the corner)?

     
    dean-dean, Jul 12, 2007
    #12
  13. azreal

    freddy Guest

    azreal,

    I've not heard of that type of fix for the problem you have.
     
    freddy, Jul 12, 2007
    #13
  14. azreal

    azreal Guest

    yer i gave up i went out and bought a usb wifi stick works no problems.
    thanks for your time
     
    azreal, Jul 13, 2007
    #14
  15. azreal

    azreal Guest

    i have given up and bought a usb wifi stick all working ok.
    thanks for your time
     
    azreal, Jul 13, 2007
    #15
  16. azreal

    freddy Guest

    azreal,

    Thanks for posting the resolution. The solution for some of these issues
    are often clouded in a shroud of mystery. At least you're good to go, and it
    didn't cost that much.
     
    freddy, Jul 13, 2007
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.