New Maxtor drive - partition / drive letter issues

Discussion in 'Windows 64 Bit' started by - Bobb -, Dec 19, 2005.

  1. - Bobb -

    - Bobb - Guest

    I've ghosted lots of drives , used OEM Drive CDs to install a disk, but this
    is the first time that I had to use Windows to get a drive installed, so ...

    Background: I had built Xp64 on my C drive and XP on my D partition (along
    with the other stuff I had there : my backup / library) last week. I was
    debating ghosting to another drive and creating a third partition to better
    organize and - bingo - today CompUSA had Maxtor 250Gb SATA drives for $59
    after rebate , so I bought one - to replace the primary IDE drive. Rather
    than ghosting, I've now got a bigger SATA drive and can just move the data
    and at the same time create a new partition.

    I ran the Maxtor utility CD to create 3 partitions on the SATA drive and
    formatted them. Now comes the tricky part. I had to assign a letter to each
    drive in order for windows to see it / to move " the stuff that I didn't
    want in the XP partition" to this new 3rd partition.

    so I started with C + E on IDE drive. I added the SATA drive - 3
    partitions - drive letters = J,K,L .
    #1 = Drive J = XP64
    #2 = Drive K= xp Pro
    #3 = Drive L = Library
    I moved the data from the old partitions to the new ones using the Maxtor
    app - which had to be installed in Windows. I then shutdown and
    disconnected IDE drive and booted XP and Xp64 on the SATA drive. Looks
    good, EXCEPT that I would like drives to be C = XP64 , D = XPPro , E=
    Library , rather than J,K and L.
    I changed drive L to E - fine. I can't change letters of the other 2
    partitions as the first = " Healthy System" and the second = "Healthy Boot".
    SO, I put IDE back in and boot it. Then I could change K drive to be D ,
    good.
    BUT how to get that J drive to be C ?? If I boot from either disk , it
    senses that the first partiton is " Healthy Active " ( when not-booted) or
    "Healthy Boot" when I DO boot from it. Either way I can't mess with the
    first partition to change the letter.
    This Maxtor utility CD got the data moved, but no help assigning drive
    letters.
    My past few drives were Seagates and I ran their app under windows, pulled
    out the old drive and booted the new one - no problem. I think that adding
    the partition is what's messing me up here.
    Do I need to delete the J drive and ghost C to partititon #1 on SATA
    standalone ?

    While I'm at it : I have this set as "Basic Disk". With only one drive, do I
    care to make it a "Dynamic Disk" ?
    I've never had a need to play with dynamic disks - is it worth doing so ?


    Bobb
     
    - Bobb -, Dec 19, 2005
    #1
    1. Advertisements

  2. - Bobb -

    - Bobb - Guest

    I DID find this online - has anyone ever done this ?
    http://support.microsoft.com/default.aspx?scid=kb;en-us;223188

    9. Locate the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
    10. Find the drive letter you want to change to (new). Look for
    "\DosDevices\C:".
    11. Right-click \DosDevices\C:, and then click Rename.

    Note You must use Regedit instead of Regedt32 to rename this registry
    key.
    12. Rename it to an unused drive letter "\DosDevices\Z:".

    This frees up drive letter C.
    13. Find the drive letter you want changed. Look for "\DosDevices\D:".
    14. Right-click \DosDevices\D:, and then click Rename.
    15. Rename it to the appropriate (new) drive letter "\DosDevices\C:".
    16. Click the value for \DosDevices\Z:, click Rename, and then name it
    back to "\DosDevices\D:".
    Quit Regedit, and then start Regedt32

    ========
     
    - Bobb -, Dec 19, 2005
    #2
    1. Advertisements

  3. - Bobb -

    - Bobb - Guest

    I did as recommmened in KB223188 and now my drive letters are as I would
    like them.
    I don't know if this is new or may have been this way since imaging:
    If I boot XP64 ( drive C) and check my System Restore tab on My computer -
    properties, it had Restore points disabled. I turned it off / on for each
    drive - looks OK. BUT,
    If I boot XP Pro ( D Drive ) and check System Restore tab , I get hang /
    then program failure " Run dll as an app" - don't know why. May have been
    that way since install - not sure as this is the first time I tried to use
    it.
    I have to do a few "end tasks" to close the windows. Even Drwatson fails and
    I have to close that window too.

    I didn't find anything matching my problem in Knowledge Base.
    Can anyone tell me how to " init" the "Restore Point" area of XP Pro for my
    D partition ?

    Thanks.
    Bobb
    ==========================
     
    - Bobb -, Dec 19, 2005
    #3
  4. - Bobb -

    - Bobb - Guest

    How to have XP Pro init Restore Point as if first time run ?
    I'm building a new box and had a few issues after migrating data to new
    drive. Now if I boot XP64 from partition #1 - system restore tab is OK, but
    if I boot XP from partition #2 the system restore tab generates errors:
    "cannot find the specified path".
    Thanks


    Details below if it matters.

    Event log shows that all was Ok yesterday . Last thing in log was boot at
    11 pm last night and drive letter reassignment due to dup names after
    booting with both drives in there (as I started this thread earlier today).
    System was Ok and I shutdown at 12:30 am. Today when I started at 8am, I got
    a System Restore Service failure.

    The SR start failure shows as :
    "Error 3 : the system cannot find the specified path", which shows as '
    E:\WINDOWS\System32\svchost.exe -k netsvcs '. Well the file IS there and
    since the RPC service starts with ' E:\WINDOWS\system32\svchost -k rpcss ' ,
    and it is running - what's the difference ? what doesn't XP like about the
    '-k netsvcs' command that it reports " cannot find the path " ?? The path to
    WHAT ! What changed while I slept last night !
    I checked :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sr - seems OK.

    If I go to command prompt and manually enter the command, I do NOT get a
    path error, it "looks like it worked" - I get a command prompt back , but
    when I check the service it is not running, so typing it in didn' t make it
    work. I've checked SR reg info at
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sr etc - all the Hex
    data is greek to me but I suspect one of those values is wrong. I'd just
    like to have it re - init System restore area to get both OS'es to work . OR
    is that the isssue - can only have one ? I disabled in XP64 and
    booted/retried XP pro - still same error.
    Bobb
    ======
     
    - Bobb -, Dec 19, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.