"News" menu item in Outlook calls Windows mail, not Windows Live Mail

Discussion in 'Windows Live Mail' started by Gordon, Apr 11, 2008.

  1. Gordon

    Gordon Guest

    Vista Home Premium.
    I've installed Windows Live Mail, and set it as the default news reader.
    However, when I do Go-News in Outlook, it calls Windows Mail and NOT Windows
    Live Mail.

    How (if at all), do I fix this?
     
    Gordon, Apr 11, 2008
    #1
    1. Advertisements

  2. Gordon

    Highspar Guest

    what version of outlook are you using?

    Also, from a run line can you type this in to make sure that wlm loads a
    message? (it'll be the message from Luky with the subject of "sending
    emails" (pay no attention to it opening as an email, it's a known issue.)

    news://msnews.microsoft.com/
     
    Highspar, Apr 11, 2008
    #2
    1. Advertisements

  3. Gordon

    Gordon Guest

    What do you mean by a "run" line?
     
    Gordon, Apr 11, 2008
    #3
  4. Gordon

    Gordon Guest

    Ignore the last post re "what is a "run" line"!

    When I enter the above, it retrieves the message in Windows Mail, although
    there is a dialog that comes up that says "Windows Mail is NOT your default
    news handler"!!!! So WHY does WM get called, if it's not the default?
    Grrrrrr!
     
    Gordon, Apr 11, 2008
    #4
  5. Gordon

    Dave Guest

    As a test, I tried Go - News in Outlook 2003. It opened Windows Mail, even
    though I subscribe to no newsgroups in it, and I have Agent set as the
    default NEWS & NNTP handler.
    And I'm posting from WLM.
     
    Dave, Apr 11, 2008
    #5
  6. Gordon

    Highspar Guest

    well, now there's the interesting question. and I think you found a bug, but
    I'll need more info on how you got yourself into that state, but I'd wager
    you installed wlm and office a while ago. if not I'd like to follow up with
    you through email to see if I can find out what happened. send me a mail at
    .

    how to fix your problem though, should be fairly easy.
    1. start->Default programs->set your default programs
    2. you should now see a list of programs. look for Windows Live Mail
    (News). provided you want wlm to be "the" default news client, click "set
    this program as default". I'd wager that currently wlm is only the default
    handler for the .nws client.
    3. now retry that link below wlm should now open. if it does advance to step
    4.
    4. try to use your outlook link now.
     
    Highspar, Apr 11, 2008
    #6
  7. Gordon

    Highspar Guest

    could you throw any more variables at me? :)

    you should be able to follow the steps I just sent one post up to set it
    yourself.
     
    Highspar, Apr 11, 2008
    #7
  8. Gordon

    Gordon Guest

    Office 2007 was installed on the purchase of the machine - about 4 weeks ago
    now.
    Windows Live Mail was downloaded and installed today - prior to that I've
    been using Windows Mail as my news reader.

    I did that as soon as I'd installed WLM
    I have just done that again so see below:
    It did and it didn't! After having clicked on the "set as default" link for
    the third or fourth time, when I run the link below, I do get a splash
    screen saying "Windows Live Mail", I then get a dialog bo saying "WLM is
    trying to retrieve the message". That then times out because I have an
    on-going problem with my ISP and access to msnews.microsoft.com! (Don't
    ask - it's VERY frustrating. Suffice to say that for a large proportion of
    the day I can only access news groups through drooper.mixmin.net on port
    563......)

    Nada - still calls Windows Mail....
     
    Gordon, Apr 11, 2008
    #8
  9. Gordon

    Dave Guest

    Sorry... :)
    Just testing...

    After giving WLM all the news defaults, clicking on the link below opens the
    post in WLM.

    However, in Outlook 2003, clicking on Go - News still opens Windows Mail.
    The window title says.. "Microsoft Communities - Microsoft Outlook
    Newsreader"
    and I get a popup saying
    "Outlook News is not currently your default news client.
    Would you like to make it your default news client?..."

    There appear to be several places in the Registry that still point to
    WinMail.exe....

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Mail\Outlook
    NewsReader\Protocols\news\shell\open\command

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Mail\Outlook
    NewsReader\Protocols\nntp\shell\open\command

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Mail\Outlook
    NewsReader\Protocols\snews\shell\open\command

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Mail\Outlook
    NewsReader\shell\open\command

    "%ProgramFiles%\Windows Mail\WinMail.exe" /outnews /newsurl:"%1"
     
    Dave, Apr 11, 2008
    #9

  10. Try reinstalling the latest updates for Outlook? <eg>
    (Many users complain that Outlook then overrides
    their non-Outlook default.)

    However, FWIW (I have never used Outlook) my guess
    is that you could be seeing the same problem I found between
    OE and WLMail. OE only checks HKLM while WLMail
    overrides that using HKCU.

    I posted about that a while ago...

    Subject: Re: Mail to links no longer working
    2/29/2008 5:39 PM PST
    http://www.microsoft.com/communitie...b1bb94-8a1c-4325-b4f6-bc5f01eb8a75&sloc=en-us

    If that doesn't help execute the following command pipeline
    (in a cmd window):

    ftype | find /i "mail"

    and post the results.


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Apr 20, 2008
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.