No Audio Device after Computer Resumes from Sleep State

Discussion in 'Windows Vista Hardware' started by George, Feb 3, 2007.

  1. George

    George Guest

    When my computer resumes from its sleep state (STR), the Sound Device is
    gone. I have to reboot the computer to get it back. I have a Gigabyte
    965P-DS3 (rev 2) mother board with a Realtek ALC888 HD codec chip. I used
    the latest Realtek HD software which is version 1.56. This is a newly built
    computer with a clean install of Vista Home Premium.

    I reverted back to the drivers Vista originally installed with are dated
    6/21/2006. They help some. I don't usually lose the Sound Device when the
    computer wakes. However, this morning after being off all night (Vista's
    sleep mode off), the Sound Device was gone when the computer started. I
    haven't been able to duplicated this when I tried briefly sleeping and
    resuming the computer several times.

    As a further test, I installed XP Professional on a separted HD. My
    computer appears to have no problems with the sound device when I sleep and
    resume it under XP. I have done much testing with XP though.

    George
     
    George, Feb 3, 2007
    #1
    1. Advertisements

  2. George

    George Guest

    I forgot to ask my questions.

    Has anybody else had this problem?

    Deos anyone have any suggestions or comments?

    George
     
    George, Feb 3, 2007
    #2
    1. Advertisements

  3. sounds like broken ACPI problem from the Bios.

    The descriped scenario does happen on certain Linux versions if the ACPI
    does not completely support S3 and higher state or if the graphics-driver is
    running in Kernel-mode ( especially nvidia ).

    Tech Background :

    If OS suspends / hibernates it tries to unload network and sounddrivers, if
    awakening again it will load these drivers back.

    Some graphics-driver also do prevent correct re-loading of drivers.

    Vista does handle all these power-savings very different than XP, so thats
    not an indicator.

    Look if you can find Bios-Upgrade for your PC or a newer
    graphics/sound -driver.

    SJ / germany
     
    Sascha Benjamin Jazbec, Feb 3, 2007
    #3
  4. George

    George Guest

    I'm already have the latest BIOS (F10) and the Realtek 1.56 driver is
    the latest. That aside, I did some more research on BIOS versions.
    Some people have had problems with the F10 Bios and reverted back to
    old versions. Others think F10 is great. No one reported any problem
    like mine yet. I submited it to Gigabyte, so maybe they will fix it
    with a new BIOS version>

    George
     
    George, Feb 4, 2007
    #4
  5. George

    Paul Spencer Guest

    I have been having the same problem and ran across a fix in a forum last
    night:

    My system:
    Vista Ultimate
    Gigabyte GA-965P-DS3 with Realtek ALC888 8 Channel Audio Codec (HD)

    I have been installing the latest Realtek drivers and bios updates as they
    come out with no success.

    SOLUTION:
    In Device Manager uninstall the audio driver.
    Put the computer in sleep mode.
    Wake up the computer from sleep and it will detect the uninstalled audio
    hardware and automatically install the driver.
    I have restarted my computer several times and toggled in and out of sleep a
    bunch of times and this fix is still working!
    I have read that Vista has a problem with unsigned drivers when resuming
    from sleep and this method seems to allow Vista to permanently accept the
    audio driver.

    Paul
     
    Paul Spencer, Mar 12, 2007
    #5
  6. George

    Paul Spencer Guest

    Just now it failed again. I did cycle in and out of sleep and also let it go
    to sleep on it's own off and on for a day and it appeared to be fixed but
    it's not. I guess I'll just have to go back to waiting on MS to patch it.
    Sorry!

    Paul
     
    Paul Spencer, Mar 12, 2007
    #6
  7. George

    Paul Spencer Guest

    I tested it many times successfully but now it doesn't work again. I was
    premature in my celebration.
     
    Paul Spencer, Mar 12, 2007
    #7
  8. George

    emccann594 Guest

    Had the same problem with Vista...(no audio device installed)
    Try this it works.........first go to microsoft and install the
    upgrade
    (KB929685).....then go to the control panel>system>device
    manager.....highlight the sound controller.......uninstall the High
    Defination Sound Device and uninstall the driver (check
    box)........restart
    the computer and the system will reinstall both and the upgrade
    prevents it
    from happening again.
     
    emccann594, Mar 18, 2007
    #8
  9. George

    wchp Guest

    KB929685 was installed auto-magically by Microsoft Update.
    Realtek released another driver yesterday on their site. (Gigabyte
    doesn't have it yet)
    So taking this post, the KB929685 was already installed on my PC
    Downloaded Realtek HD Audio driver Vista_R164 from here:
    http://www.realtek.com.tw/downloads...=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
    Ran the Realtek setup utility.
    Rebooted the machine.
    Went to device manager and uninstalled the HD Audio Device AND selected
    the remove drivers option box.
    Restarted machine.
    Machine found hardware and installed drivers.
    Now the Driver shows up as:
    Driver Signed as:
    Provider - Realtek
    Driver Date - 3/26/07
    Driver Version - 6.0.1.5391

    Testing:
    Put machine to sleep 3 times. Wakes up with Audio still there.
    Allowed machine to put itself to sleep 3 times. Wakes up and Audio is
    still there.

    Seems like emccann594's post/solution does resolve the issue. Realteks'
    updated driver may help as well.
    Took me a while to find this post, but glad I did and thanks all for
    your contributions.
    This was the last bug I needed to work out with my new Vista box.
     
    wchp, Mar 31, 2007
    #9
  10. George

    George Guest

    Are you sure it's fixed? Three successful resumes is not enough to
    prove its fixed. I determined I had KB929685 and did the uninstall
    reinstall thing with the latest Realtek drivers. I went over a day
    with over six sleeps and resumes before I had a failure. It's very
    random and seems to go in streaks of successfule reumes and failure.

    George
     
    George, Apr 3, 2007
    #10
  11. George

    wchp Guest

    Well...
    I don't know, because every time I install the latest realtek driver is
    breaks Outlook (which I discovered after I posted)
    I am currently in the middle of cleaning up all drivers, software,
    installs and rebooting after each one to confirm no new issues in the
    logs.
    Nero 7 is the next to go in, then the 1.64 Realtek driver and then
    Outlook 07.
    Keeping my fingers crossed.
    I did note with the previous driver the same "random" behavior. I don't
    really believe anything a PC does is truly random... but your comment
    makes me think I should keep track of what apps I have open/operative
    at the point it goes to sleep and then see if there is a correlation !
    ? Make take several days, but Ill bet there is something correlative.
     
    wchp, Apr 3, 2007
    #11
  12. George

    George Guest

    BTW, I'm using Outlook 07 and Realtek 1.64 without any problems. I
    don't have Nero though.

    George
     
    George, Apr 4, 2007
    #12
  13. George

    wchp Guest

    Well it is all back in. Nero put up a big fight. Kept wanting to
    install its indexing app which from other posts is not known for
    playing well with others.
    After I got it all in with no errors in the log from start, sleep and
    boot sequences I tried to install Office 2007 and... no good.
    It actually invoked it own install-begin restore point.
    Made a second attempt after disabling AV, Spysweeper, etc.
    The only things I did leave running was the HP printer services, Google
    Desktop, Nero and the Realtek drivers/control panel.
    It went in that time.
    Cleared all logs again and did a sleep, wake, shutdown, restart and
    finally have clear logs other than the iTunes complaint... which is
    what it is.

    I am going to turn back on Sleep mode and leave outlook running
    tonight, and keep adding running open apps to the mix over the next
    couple of days and see if it breaks, and if it does, if there is some
    application or interaction that is the catalyst for the audio
    driver/sleep mode issue.
     
    wchp, Apr 4, 2007
    #13
  14. George

    George Guest

    I just noticed another hardware device that my system sometimes looses
    when it resumes from sleep. I have a Gigabyte 965P-DS3 (rev 2) mother
    board that uses the Intel P965 chipset. Since that chipset doesn't
    support IDE drives, Gigabyte added an IDE controller chip. Anyway,
    the IDE controller and the HD and DVD connected to it can fail when my
    system resumes from sleep. I hadn't noticed it before because I don't
    access The IDE drives very often. My SATA HD has most my stuff on it.

    George
     
    George, Apr 5, 2007
    #14
  15. George

    wchp Guest

    So I am day three with the sleep issue apparently behind me.
    I had what seemed to be three or four combative services so I stripped
    them all out and started over and experimented with sequences until I
    could get a good boot with nothing in the Event Viewer Application log
    other than the event 0s (which are not of consequence)
    Removed Google Desktop, NVidia 7X drivers, HD audio drivers, HD device
    (under system), Nero 7 and Office 2007 (don't ask)

    Turned off SpySweeper
    Turned off McAfee AV, Firewall, Reg protector and any thing else that
    might investigate or try to mediate the install.

    Installed the latest NVidia Driver
    Rebooted
    Installed the Realtek 1.64 driver
    Rebooted
    Installed Nero 7
    Rebooted
    Chased down the NMIndex service (Nero Media Index) in files and
    registry and killed it off (problem child in the first place, never
    mind on Vista)
    Installed Google Desktop 4.5 (Don't install ver 5 yet they are still
    working on issues)
    Installed Office 2007
    Set the PC to Sleep after 30 minutes and...
    It has gone to sleep 15-20 times a day for the last two days with all
    kinds of apps open or in various states and the machine now wakes up
    and everything works.... I have to type slowly with one hand while I
    knock on my wood desk with the other while I type this.

    I spent a lot of time resolving each error in the application log and
    hardware log. Researching each issue and eliminating it before
    installing the next app or driver.
    I have come to the conclusion Vista is a house the apps and drivers are
    like children. Any one of the kids on its own plays pretty well and does
    just fine. Put siblings in a group and you never know what you are going
    to get.
    I will check back in, in a week and post how things are going.
     
    wchp, Apr 6, 2007
    #15
  16. George

    George Guest

    You got me to look at my event logs and I found something really
    bizarre. It's another missing divece upon resume error. This time
    it's for the parallel port. The funny thing is that I've disabled the
    parallel port in the BIOS. When I boot my computer, the parallel port
    is correctly not showing up in the Device Manager. Weird!

    wchp, I take it you uninstalled your programs and drivers. Then you
    installed them one at a time closely monitoring the logs. What
    motherboard and chipset do you have. Did you uninstand the drvers for
    your MB also?

    I might give your technique a go when I feel like diving into it. For
    now, once my computer is up and running, it is stable and works fine.
    The resume from sleep problem is a low-priority issue.

    George
     
    George, Apr 6, 2007
    #16
  17. George

    wchp Guest

    George,
    I am running a Gigabyte GA-965P-DS3 MB.
    As this is based on a Intel 965P chipset I let Vista plug in its ow
    drivers.
    The only driver I used on install beside that was the Gigabyte Sat
    Raid1 driver.
    My initial problem was that when the machine went to sleep I couldn'
    get it to wake up without a power cycle.
    USB errors kept coming up in the logs. Installation of the Intel ICH
    drivers for the USB bus resolved this issue.
    Once I had that in, things were working OK except on resume from slee
    I loose sound. I installed the updated driver and it broke outlook.
    would repair outlook and Google Desktop would stop indexing
    Repair/reinstall that and sound would stop working again.
    I had lost the restore point from where I had originally started havin
    issues so I decided to uninstall all three that had given me issue. Ner
    7 had a partial failed load when I had tried initially to install th
    non-Vista compatible version. The order in which I installed was jus
    my way of applying to OSI model to what the drivers and apps wer
    doing.
    Hardware first, Utilities with hooks next and then the apps on top.
    I have no clue why this worked, but I have had success with it in th
    past with other problem installs and for whatever reason it worke
    again.
    Chasing the issues that turned up in the log was just a matter of m
    trying to see where the conflicts were.
    There are still quite a few services that start and don't have or hav
    an invalid event ID. This results in Vista assigning a default value o
    0 which results in the misleading message of:
    " The description for Event ID 0 from source gusvc cannot be found
    Either the component that raises this event is not installed on you
    local computer or the installation is corrupted. You can install o
    repair the component on the local computer.

    If the event originated on another computer, the display informatio
    had to be saved with the event.

    The following information was included with the event:

    Service started"

    The only one that actually means anything is the "service started" th
    rest of it is just the vendors not having all there event IDs in orde
    for Vista.

    Now... to make you sick... I took my Mac G5, installed the lates
    version of boot camp, and had Vista Ultimate up and running with n
    errors and no conflicts in just over an hour. This is with DirectX
    and full USB support.

    Now if Vista installs this easily on a Mac then why are we having s
    many problems. The real scary thing is this is my first exposure to Ma
    hardware or OS. I must say, I am blown away by Mac Hardware buil
    quality. TAT at 100%load only resulted in a Tjunction temp of 63C wit
    and ambient temp of 22C.

    I am going to try living in the Mac OS for the next two weeks and se
    how many of the things I do on my PC I am able to accomplish on th
    Mac.
    The funny part was that one of the Mac Techs working with me on th
    project went out an bought a copy of Vista Ultimate after seeing it ru
    on the G5
     
    wchp, Apr 7, 2007
    #17
  18. George

    George Guest

    I have the same board. My is revision 2.0. What's your revision? I
    believe there are also 1.0 and 3.3 revisions.
    That's what I did.
    I don't use Raid, so I didn't do this. My single Sata drive is on an
    Intel Sata port. Vista is on this drive.
    I seem to recall this having once or twice. Then the problem went
    away by itself.
    I installed these also just to have the latest drivers. I didn't look
    at the log back then so I can't report any USB errors.
    (snipped the rest)

    I don't use Google Desktop. The different Realtek driver version
    didn't seem to make and difference in loosing the sound upon resume.
    BTW when testing with XP, I had no resume problems.

    Other drivers I installed are the latest Marvell network and Nvidia
    graphics (7600 GT) drivers. I've installed drivers in various orders
    as I find updates.

    I have questions about your hard drive configurations.

    Do you use the Intel Sata ports? If so, have you switched them to use
    AHCI in the BIOS? I tried using AHCI. I switched both (at the same
    time) the Intel and Gigabyte ports to use AHCI. Afterwards, my
    computer would lock up when I tried resuming it from sleep. I backed
    out the changes and things return to normal. I need to try only
    configuring the Intel Sata port fot AHCI.

    I take it you use the Gigabyte Sata ports for a Raid. How does it
    work for you? I've heard (http://www.anandtech.com/mb/showdoc.aspx?
    i=2914) that there has been issues with the JMicron JMB363 chip used
    for this. (Note: I've read that the Gigabyte Sata2 chip is a relabel
    JMicron JMB363 chip) I've only have an IDE HD and DVD connect to this
    and they work fine.

    George
     
    George, Apr 7, 2007
    #18
  19. George

    wchp Guest

     
    wchp, Apr 7, 2007
    #19
  20. George

    wchp Guest

    Unfortunately you have to call and reference KB Article Number(s): 934237 to
    have them send you an email with a link to the zip file. In the email they
    will include the password to unzip the hotpatch.

    This resolved the issue completely on my machines.
     
    wchp, May 5, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.