No audio in WMP11 & AC3Filter IS installed

Discussion in 'Windows Media Player' started by thumper629, Dec 4, 2007.

  1. thumper629

    thumper629 Guest

    WMP11 recently stopped playing audio for no apparent reason; it was installed
    shortly after it was released, so it worked ok for a long time (in the PC
    universe). Trying to open MP3, WAV, or WMA files yields this message:
    "Windows Media Player cannot play the file because there is a problem with
    your sound device. There might not be a sound device installed on your
    computer, it might be in use by another program, or it might not be
    functioning properly." It will open & play a DVD or an AVI file with video
    but no audio.

    The system sounds work fine. Media Player Classic & other apps that I tried
    play audio ok. The problem only exists in WMP. GSpot reports that codecs
    are installed for the files that will not play (and it also plays the audio).
    Returning to a restore point before the problem happened didn't help. After
    researching multiple forums & help sites, including "Guide To Error's
    C00D11BA, 80040256, and 00040258 In Windows Media Player", I tried
    re-installing the sound card drivers and installing the AC3 filter
    recommended here. I ran the DirectX troubleshooting tool. I re-installed
    DIVX. I ran Codec Sniper and Sherlock. WMP will not roll back to WMP10;
    re-installing WMP11 didn't help. I even tried changing codec merit values.
    I am sure that I have tried other things that I can't remember right now;
    none of them found problems. If it were possible I would uninstall WMP.
    Besides needing suggestions on what to try next, I would like to know what is
    different about WMP (from all other apps, apparently) that makes it so prone
    to audio problems?
     
    thumper629, Dec 4, 2007
    #1
    1. Advertisements

  2. thumper629

    thumper629 Guest

    Update: I tried logging in as a different user and WMP11 plays audio for
    that user ID. I can probably create a new user for myself and delete the
    old, but I am not sure what additional ramifications there are for that.
     
    thumper629, Dec 6, 2007
    #2
    1. Advertisements

  3. thumper629

    thumper629 Guest

    Problem solved. I searched the registry for differences betweeen my WMP
    settings and other users. My settings had the following string:
    HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences\DefaultAudioDevice,
    set to: {BD6DD71A-3DEB-11D1-B171-00C04FC20000}. I searched for that string
    and it was not found, so I deleted DefaultAudioDevice. WMP is working now.
     
    thumper629, Dec 7, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.