Notepad starts with "[.ShellClassInfo] computer starts in Vista

Discussion in 'Windows Vista General Discussion' started by otho69, Mar 6, 2007.

  1. otho69

    otho69 Guest

    I have set up a dual boot system with Vista and XP on separate partitions of
    a single hard drive, with a second physical drive for shared folders. After
    sucessfully installing some legacy programs under XP I rebooted into Vista.
    When the computer booted Notepad opened up a text document displaying the
    following:

    [.ShellClassInfo]LocalizedResourceName=@%systemRoot%\System32\Shell32.dll,-21787".

    I have found a KB article that addresses this in XP (KB/330132), instructing
    me to remove the desktop.ini file that was causing this. I did check my XP
    installation and found such files and removed them (oddly i did not
    experience the problem in XP), but this did not solve the problem in Vista.

    My question - will this solution work for Vista as well? Is this being
    caused by an incorrect desktop.ini in the Vista partition?

    Thanks very much!

    otho69
     
    otho69, Mar 6, 2007
    #1
    1. Advertisements

  2. otho69

    Guest Guest

    It happens becaise the file should be hidden and someone (like you) removed
    the hidden attribute. The fix is to make it hidden not delete (although
    delete doesn't hurt much on ENGLISH LANGUAGE versions of window). This and
    the All User's desktop.ini are the only 2 desktop.ini that must be hidden or
    wierd thing happen..
     
    Guest, Mar 6, 2007
    #2
    1. Advertisements

  3. otho69

    otho69 Guest

    Me?! I would never do such a thing - perish the thought!

    While I do not know how I managed to change the desktop.ini file's hidden
    attribute, it sounds as though it is an easy enough problem to fix. I'll
    have a bash at it and let you know how I fare.

    Thanks!

    otho69
     
    otho69, Mar 6, 2007
    #3
  4. otho69

    Guest Guest

    What that file in that location does (as others have other non language
    related functions) is give the folder it name. In English the directory name
    and display name is the same. With the file there you see the name coming
    from the language resource. In German Windows it says something like Hande
    Hoch (or some babble). So if you delete it in english all looks the same but
    you see the real folder name not the language translation.
     
    Guest, Mar 6, 2007
    #4
  5. otho69

    otho69 Guest

    I would love to give this a try but I have yet to be able to access my
    "Documents and Settings" folder to look for the necessary desktop.ini to
    correct its attributes. I am logged in as an administrator, but Vista denies
    me access to the folder. I have looked at the permissions but cannot figure
    out how to grant myself access.

    I am quite new to Vista (obviously). I understand why the new security
    protocols are in place, but I do not understand how to work with them as yet.
    Can you explain to me how I can get permission to access the system folders
    and fix the desktop.ini files? Any help is greatlty appreciated!

    otho69
     
    otho69, Mar 7, 2007
    #5
  6. otho69

    Guest Guest

    Replace Users for Documents and Settings. D&S isn't a real folder but a
    redirect signs for install programs looking for the old names. Or just right
    click the folder on Start and choose Open.
     
    Guest, Mar 7, 2007
    #6
  7. otho69

    Dean-Dean Guest

    In the following two folders (the paths may be hidden)

    C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Windows\Start
    Menu\Programs\Startup

    and

    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

    confirm that in each of the above two folders, that there is a desktop.ini
    file with the following contents (nothing more, nothing less), as seen in
    Notepad:

    ----------------------------------(below this
    line)-------------------------------

    [.ShellClassInfo]
    LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21787

    ----------------------------------(above this
    line)-------------------------------


    Now, in Windows Explorer (which should be "Run as Administrator"), go to:

    C:\Users\(YOUR NAME)\AppData\Roaming\Microsoft\Windows\Start
    Menu\Programs

    Select the Startup folder. While holding down the Shift key, right click on
    the Startup folder, and choose "Open Command Window Here". In the Command
    Window, at the prompt, type (or copy and paste):

    attrib +H +S -R desktop.ini

    Press Enter on your keyboard.

    Now go to:

    C:\ProgramData\Microsoft\Windows\Start Menu\Programs

    Select the Startup folder. While holding down the Shift key, right click on
    the Startup folder, and choose "Open Command Window Here". In the Command
    Window, at the prompt, type (or copy and paste):

    attrib +H +S -R desktop.ini

    Press Enter on your keyboard.

    These are the only two desktop.ini's that could be causing your problem.
    (Any other desktop.ini's in other folders should be left alone.)

    Hope this helps,
    Dean
     
    Dean-Dean, Mar 7, 2007
    #7
  8. otho69

    otho69 Guest

    Fellows,

    Thanks very much for your responses - they were extremely helpful and had
    allowed me to resolve the problem. The problem did re-arise after a day or
    so, after I had booted into Windows XP a few times, so I suspect there is
    something amiss with my dual boot arrangement that is causing this problem.
    Also, Vista will no longer allow me to change the "read only" attribute on
    the C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup folder,
    which prevents me from reapplying the solution you had outlined.

    It is a little frustrating, but progress is being made at least in that I am
    starting to feel more comfortable working in Vista and am finding my way
    around!

    Your help has been greatly appreciated!

    otho69

     
    otho69, Mar 10, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.