Now Vista won't play Sims 2 + ep?

Discussion in 'Windows Vista Games' started by Cassira, May 9, 2007.

  1. Cassira

    Cassira Guest

    I bought a new Dell XPS 210 about 6 weeks ago and after a month the HD was
    found to be defective. I got the new one and got help installing it. Before
    the new hard drive I could play Sims 2 and all the expansion just fine. Now,
    when I go to install, each expansion starts to install, asks for the second
    disk if there is one, and then when it asks for disk 1 to be put back in to
    finish up, it can't read that the disk in in the drive. It does this with
    each and every expansion. I've been installing the patches from the Sims 2
    website and I set each one up to run in XP SP2 and as administrator....but no
    luck. I've been on the phone many times with Dell and corresponding with EA
    Games as well...they can't seem to help me. I reinstalled Vista again, last
    night and am still having this issue. I've even tried putting a copy on my
    computer and installing that way...but it still can't find the disk 1 at the
    end of the installation. :(

    If anyone has any suggestions, I would really be grateful. Thank you!
     
    Cassira, May 9, 2007
    #1
    1. Advertisements

  2. It sounds more than just a faulty HDD, I would contact Dell and ask for a
    full replacement
     
    VRG Scotty©, May 9, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.