Nslookup succeeds, but ping fails to resolve hostname

Discussion in 'Server Networking' started by Curt McNamee, Nov 7, 2006.

  1. Curt McNamee

    Curt McNamee Guest

    Hi everyone, I have an odd one that I just can't figure out. I have an AD
    environment of about 20 w2k3 R2 servers and 100 XP workstations with 2 DCs
    that act the DNS servers for the network. Every once and a while I run
    accross a workstation or server that has the works time contacting our DCs.
    Upon further invistation it just can't resolve the hostname (sort of).

    For example: I have an AD domain called domainname.AD and a
    workstation/server called Steve. If you run an nslookup on steve, you can
    resolve domainname.AD just fine. If you then try to ping domainname.AD it
    fails with the message it cannot resolve the hostname.

    I have tried all maner of flushing the DNS cache and bouncing the system and
    sometimes it works and sometimes it does not. Usually after enough time has
    passed (a couple days) the problem goes away by itself. I was wondering if
    anyone else has run into this and has a clue how to correct the situation.

    Thank you for your help,
    Curt
     
    Curt McNamee, Nov 7, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.