NT4 to 2003 server upgrade including Exchange 5.5 to Exchange 2003

Discussion in 'Server Migration' started by Nex-Tech Support Staff, Dec 19, 2005.

  1. The issue I have is this. I am in the middle of a NT4 to 2003 server upgrade
    including Exchange 5.5 to 2003 and NT4 Directory to Active Directory.

    The network started out as follows, three different domains, A, B, and C for
    this document. Domain A includes the Exchange 5.5 server which B and C also
    access via trusts between all the domains. All domains are single DC domains
    and none contain BDC’s. The Domain A PDC is the same box that Exchange
    resides on as well.

    The customer wants to upgrade Domain A and then B and C at a later date when
    the money and time is available.

    They have two new servers, one that will be the new DC for Domain A and one
    that will host Exchange 2003.

    I brought in a temporary server and installed NT4 on it as a BDC in Domain A
    and then promoted it to PDC for the upgrade. I then did an upgrade on the
    server to 2003 server and also the AD upgrade for the domain. All of this
    went super smooth and I also joined and promoted the new DC server to the
    domain and transferred the FSMO roles to it so that the temp DC is now not
    really needed but is still there.

    Everything is running smooth at this point and I was ready to start on the
    Exchange upgrade. According to the docs on the upgrade I need to clone the
    accounts from domain B and C to domain A so that when I install the ADC it
    will be able to match the mailboxes owned by users in those domains to a user
    in Domain A. It would then use the SID history attribute to match accounts
    from the other domains and allow them to authenticate and get to their
    mailboxes.

    I was going to use the ADMT to do this but failed to realize that the target
    domain has to be in native mode to make this happen. Currently Domain A is in
    interim mode due to the fact that the old PDC is still running as a BDC in
    the domain.

    I can’t just get rid of this box because Exchange is on it. So I am stuck. I
    can’t migrate to 2003 without those accounts, I can’t get rid of the server
    because Exchange is on it.

    So what is the best way to get around this issue? I have done some looking
    but can’t really find anything simple.

    The only things I’ve been able to see is a utility called Upromote
    http://utools.com/UPromote.asp which would allow me supposedly to remove the
    server as a BDC and bring it back as a member server which would allow me to
    go to native mode or I was also thinking that maybe I could bring up the temp
    server after demoting it with NT4 on it and put Exchange 5.5 on there and
    move everything to that server for the upgrade.

    Any other ideas or any info on these strategies would be appreciated.

    Thanks,

    Ashley Heaton
    [email protected](nospam)nex-tech.com
     
    Nex-Tech Support Staff, Dec 19, 2005
    #1
    1. Advertisements

  2. Hi Ashley,

    After reading your post, my understanding of your current issue is totally
    related to Exchange 5.5 upgrade to Exchange 2000. Therefore, I think
    following newsgroup would be more approprate for your issue:

    microsoft.public.exchange.setup

    Thanks for understanding.

    Best regards,

    Vincent Xu
    Microsoft Online Partner Support

    Get Secure! - www.microsoft.com/security

    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.

    This posting is provided "AS IS" with no warranties, and confers no rights.


    --------------------
     
    Vincent Xu [MSFT], Dec 20, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.