ntbackup failure: Error returned while creating the volume shadow

Discussion in 'Windows Server' started by criptonite, Feb 14, 2008.

  1. criptonite

    criptonite Guest

    On our Windows 2003 Server (32-bit, SP2), we have recently had failures with
    ntbackup. This scheduled job backs up Exchange 2003 (SP2) Information stores
    and SystemState only. A couple of weeks ago we received the following errors:

    ntbackup log:

    Backup Status
    Operation: Backup
    Active backup destination: File
    Media name: "AntHoDaily.bkf created 13/02/2008 at 18:30"

    Volume shadow copy creation: Attempt 1.
    Timeout before function completed

    Error returned while creating the volume shadow copy:0xffffffff.

    Error returned while creating the volume shadow copy:ffffffff
    Aborting Backup.

    ----------------------

    The operation did not successfully complete.

    ----------------------

    Event viewer:

    Source: NTBackup
    Event ID: 8019
    Description: End Operation: Warnings or errors were encountered.
    Consult the backup report for more details.

    Source: VSS
    Event ID: 6013
    Description: Sqllib error: OLEDB Error encountered calling
    IDBInitialize::Initialize. hr = 0x80004005. SQLSTATE: 08001, Native Error: 18
    Error state: 1, Severity: 16
    Source: Microsoft OLE DB Provider for SQL Server
    Error message: [DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL
    Security error.

    Do you need any further information?

    Cheers

    Crip
     
    criptonite, Feb 14, 2008
    #1
    1. Advertisements

  2. criptonite

    criptonite Guest

    As an addendum, I ran a test last night just backing up Exchange Information
    stores and NOT the SystemState and this ran successfully. Ran a test this
    morning just backing up SystemState, and this Failed!!!

    Any ideas?

    Crip
     
    criptonite, Feb 15, 2008
    #2
    1. Advertisements

  3. Here is a copy of a report on this subject. I picked it up from
    this newsgroup some time ago but I do not know it it works
    or not or how safe it is to run the commands shown below.
    *************
    Ran:- vssadmin list writers and could see all the writes but when tried to
    take system state backup, it failed with an error.

    Followed an internal article and ran this from system32 in a Command Prompt:
    Net stop vss
    Net stop swprv
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    Vssvc /Register
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll
    regsvr32 es.dll
    regsvr32 stdprov.dll
    regsvr32 vssui.dll
    regsvr32 msxml.dll
    regsvr32 msxml3.dll
    regsvr32 msxml4.dll
    Reinstalled COM+
    1. Backup and then delete HKLM\Software\Microsoft\COM3
    2. Boot to Recovery console and rename clbcatq.dll to ~clbcatq.dll.
    3. Boot to normal mode and in Control Panel, open the Add or Remove Programs
    tool,
    and then open the Add/Remove Windows Components tool.
    Checked DCOMCNFG and red down arrow on Computer
    2. Distributed Transaction coordinator is running and started.
    3. Followed Q315296 How to clean up a damaged COM+ catalog
    4. Errored again with: "sub-component Com+ raised an exception" 0x8007041b
    5. Stopped the System event Notification serivce and attempted to reinstall
    Com+ again
    6. This time it was successful
    7. Created a Shadow Copy on C:\ and that was successful
    8. Attempted the System State backup of the server to C:\ Successful
    **********
     
    Pegasus \(MVP\), Feb 15, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.