NTLDR, NTDETECT.COM fixmbr fixboot

Discussion in 'Windows 64 Bit' started by TheIneffableBob, Aug 16, 2005.

  1. So, It would appear that the NTLDR and NTDETECT.COM files are nonexistent in
    XP64. or rather, they exist in the root directory but are so hidden, that
    even the administrator account does not have acces.

    more to the point, the fixmbr and fixboot commands have been removed from
    the recovery console, which is entirely distressing.

    my problem is described in greater detail in my other recent post, "x64
    instal error 'Hardware halted'" but in overview, I have a thoroughly
    corrupted boot sector as a result of a dual-boot attempt in linux. basically
    GRUB edited my boot sector, but did so onto a disk which was NTFS formated,
    and has some seirous problems.

    I have since tried to go into the recovery console to fix it, nly to find
    that fixboot and fixmbr are no longer valid commands. HOW CAN THIS BE?!?!

    have I simply missed somehting obivous? did µsoft forsake me and leave me
    stranded without a boot sector? I would greatly love any inpus one can offer.
    TheIneffableBob, Aug 16, 2005
    1. Advertisements

  2. No, I do not think it is quite so alarming. However, something obviously has
    gone wrong. The fact that you have put Linux and Grub into the equation,
    shouldn't matter, either. Not on it's own, anyhow. Let's hear - these HD's
    and the controller - do you have Winx64 compatible drivers ready for the
    installation to 'F6' at the very beginning? Go visit the manufacturers sites
    to see if anything has been updated, applies to Controller and/or Chip;
    Motherboard and possibly BIOS.
    Just because you've seen all this working in earlier installations, does not
    imply that it will automatically work under Winx64. Anything remotely
    driver-like must be expected to have compatible drivers, and older drivers
    that used to work under beta-versions do not work with the release version,
    since MS has since imposed new demands on the - so called, 'decoration' of
    the drivers - which is done in the .INF file.
    Problem is, if I understand correct, that your other windows installation
    was already corrupt? This may not be an enviable situation in which to
    install 64bit Windows. Perhaps I would prefer to just install something
    'ordinary', next door, and launch a salvage operation from there. When
    everything is under controll you will have full access to the i-net and all
    the resources you migh need. Rule one: Identify all your Hardware and make
    sure that compatible drivers exist, and get them lined up on floppy's at
    your desk before attempting to install Winx64.

    As for the recovery console: no, to the best of my knowledge, these commands
    do exist, not sure of the syntax at the moment, but typing HELP in some form
    or other. Perhaps "fixmbr /? " But, then - if the installation doesn't
    understand your HD subsystem, neither will RC.

    My recommendation is to insert that other windows installation and try RC
    from there, that might tell you something?

    Tony. . .
    Tony Sperling, Aug 16, 2005
    1. Advertisements

  3. TheIneffableBob

    John Barnes Guest

    Since fixboot and fixmbr both work fine, it is obviously a driver issue that
    the drives are not being seen.
    John Barnes, Aug 16, 2005
  4. Actually, this is the thing. All of my devices have worked with winXP64
    before. I failed to mention that the older windows version is also XP64.
    this new copy is the exact same verison from the same install disk. Also,
    the drivers are native to this installation, as evidenced by their loading up
    when my system boots form the CD (displays the deviced and all the drives
    briefly while loading up all the requisite drivers)

    re:"As for the recovery console: no, to the best of my knowledge, these
    do exist, not sure of the syntax at the moment, but typing HELP in some form
    or other. Perhaps "fixmbr /? ""
    Actually, Ive tried this. in the recovery console, when i list the available
    commands with HELP fixmbr and fixboot are not actually in the list. typing
    "fixmbr /?" gives the error "command not recognized" I have also tried
    copying the requisite ntldr files from the disk, knowing that they are there
    in the drives root directory, though hidden. after the command "copy
    G:i386/ntldr F:/" it gives access denied, which i found rather peculiar as I
    am logged into the admin account (which you have to be to even load the
    recovery console in the first place)

    basically, Ive done everything i know of to try to repair this boot sector.
    Of course, it doesnt help at all that my version of windowsXP64 is actually
    the beta of a 365day liscence. yes, i do plan to buy it, but I would rather
    make sure it is going to keep working first. Ill take your advice and try to
    install a 32bit version of XP to at the very least reconstruct a boot sector.
    (it shouldnt be vastly different, should it?)
    TheIneffableBob, Aug 16, 2005
  5. TheIneffableBob

    John Barnes Guest

    You cannot use the drivers from the beta now. You must have the latest
    decorated drivers as Tony mentioned.
    John Barnes, Aug 16, 2005
  6. TheIneffableBob

    John Barnes Guest

    What system options does it give you to sign in when you start recovery
    console. What drives and types are shown when you do a map in recovery
    console. Maybe you are using the wrong drive letters for the current setup.
    I'm not sure, but I would guess you should sign on as administrator for the
    drive (system) that you are copying the file into.
    John Barnes, Aug 16, 2005
  7. And! Do not forget your Tux alternative. If you are already familiar with
    that, it actually might give you more partitioning options, as Windows seems
    unwilling to make other than extended partitions from any primary partition
    you may already have. I don't want to make up your mind for you, just a
    note - if you plan to dual-boot,(or even triple?) you might actually like to
    have a couple primary partitions to start from.

    And no, again, the boot sector or MBR are no different in any of those
    instances, the systems have different ways of understanding the stuff - if
    that makes any sense?

    Tony. . .
    Tony Sperling, Aug 16, 2005
  8. re: "What drives and types are shown when you do a map in recovery
    my windows system is on drive letter F, so that's why my command referred to
    F. I know that this is not conventional, but then neither is my system. In
    general, I am able to recognize all of the drives. the SCSI contorller is
    working perfectly, and I can access all of my drives as needed. I have
    logged into admin for that system drive, and can do so without trouble. I can
    also navigate the disk without difficulty. I cannot, however, access the
    ntldr and ntdetect files in the root directory of that file, even while
    logged into the administrator account. having tried to copy the file from
    the i386 folder on the boot cd, it siply states that access is denied.

    re: "You cannot use the drivers from the beta now. "

    I have only ever had the Beta installed on this computer, and it has always
    worked fine. I actualy plan to buy the public release soon, but I hesitate
    to do so, if this does not first come to resolution. currently, I do not
    believe it is a problem with the dirvers, but i shall attempt another clean
    install with minimal hardware attatched. ideally, it will work with only the
    VGA, and scsi controller attatched (and human interface, of course). If it
    is, in fact a driver issue, that would explain why the system fails at the
    "loading devices" stage after the first major reboot (which follows creation
    of boot sector, etc) howveer, what irks me is the fact that not but two days
    ago all of these drivers worked perfectly. in fact, installing Debian didn't
    actually affect windows. when I booted into windows, it still worked. it was
    oly after i installed Grub into the boot sector for the purpose of dual
    booting that I had problems. these problems only escalated when i had ot
    repair the boot sector through windows.

    re:"And! Do not forget your Tux alternative. If you are already familiar with
    Unfortunately, I am not completely familiar with Linux. This was a first
    introduction. although well-read, I am certainly not an expert, and there is
    much i have yet to learn. I have considdered toasting windows altogether and
    going pure linux, but i need to accompish certain levels of stability first,
    for productivity reasons. for this reaosn, I cannot be rid of windows
    altogether. not until I have learned more about linux, and have acquired the
    toolsets to be as productive.

    Actually, If you are well-versed in the world of Linux (specifically Debian,
    "Sarge" and use of GRUB) then I would very much Like to ask some specifics.
    This all started for me when Grub rote itself into my boot sector, but then
    failed to recognize windows. veyr frustrating. I ultimately had the
    following: default and safemode boot options for Debian, following a clean
    install of linux of drive1 (for furute ref, drive0 = SCSI id 0 = the windows
    disk. drive1 = SCSI id 1 = the linux disk, though im currently trying to put
    windows on it to rescue disk0's boot sector.) I then manually added another
    boot option for windows, and directed it to the correct partition, /dev/hda1
    (sd0,0) when doing this through the linux boot manager, I continually
    experienced errors in recognizing the drive, which i assume is because that
    partition is NTFS formatted, which i know causes no end of trouble for
    linux/unix. so, i created the new boot option and had it refer to the linux
    boot sector. this more or less cloned the linux boot option. Then, in grub
    (upon the next boot) I redirected it to the correct partition. the results
    were this: I could load grub without trouble and boot into debian as much as
    i wanted. i can also boot into windows, once. all is well and good, but then
    if i ever reboot from there, the boot secotr seems to be completely buggered.
    I never see Grub, nor linux, nor windows, but instead, the system goes into
    what ive called the "recursive POST loop" wherein it posts, loads the bios,
    loads the scsi contorller, loads/recognizes the disks, and then at the point
    where it would normally load the boot manager, it simply restartes the boot
    process from the post screen. it will do this infinitely until i either kill
    the computer, load a boot CD (debian or windows, both work) or enter the BIOS
    and tell it to boot form a different location. if i tell it to boot from a
    different disk, it tries, but then posts a GRUB error 17. from another
    online forum, this means that Grub cannot mount the targetted partition. I
    have since attempted to install grub and Lilo both, butwith no success. (more
    errors, no notes just now)

    any suggestions? I knwo that this is not a Linux forum, so if you would
    rather deal with this issue elsewhere, please feel free to email me at
    b-tsang [at] northwestern [dot] edu
    TheIneffableBob, Aug 16, 2005
  9. TheIneffableBob

    John Barnes Guest

    The place you need your ntldr and ntdetect.com and boot.ini is on your
    system drive. I don't know SCSI but other setups (SATA IDE) the first hard
    drive in your boot sequence is the drive your system is on and it is on the
    active partition. That partition is where you need to have the 3 files.

    John Barnes, Aug 16, 2005
  10. TheIneffableBob

    John Barnes Guest

    While you are in Recovery console, what does your boot.ini if any show.
    bootcfg /rebuild will build a replacement file bootcfg /scan will list
    the windows installations available to add

    John Barnes, Aug 16, 2005
  11. OK, ill try the boot.ini bit.
    also, for your own knowledge, SCSI also requires the boot sector to be on
    the system disc. however, unlike IDE and SATA, there is no master/slave. all
    devices (harddisks, tape drives, anything) on the SCSI channel are
    equivalent, until given a heirarchy by the contorller (which is itself just
    another device on the chain, though traditionally it is always given id7)
    for me, this is a simple matter of telling my BIOS which drive to look at,
    and it will then search for a boot directory in the active parititonin that
    drive. perhaps my problem lies within the "active" status of my partitions.
    when i get back form work I will invesitgate further. Thanks for your help.
    TheIneffableBob, Aug 16, 2005
  12. Right now I am in the middle of dinner, I havn't read all this yet, but I
    think you are right - generally Grub/Linux has no 'issues' as such with NTFS
    partitions, not that I know of - except you shouldn't let it write to them.
    You can quite easily manipulate Grub to deal with Windows boot, but you have
    to follow it's own view of how the universe is looking - I cannot recount
    the matter off the top of my head, I need to check my references (if I can
    find them?)

    Also, this is not a good Linux forum, you're welcom to mail me at
    and we can deal with this matter, 'behind the
    scenes', as they say .

    That is, in the event that this was - at least in part - directed at me. (I
    think you managed to concatenate two posters, there).

    Tony. . .

    Tony Sperling, Aug 16, 2005
  13. All is well!

    I have now decided to use the windows boot sector, at leats for now.
    Currently, I do not have linux back on the machine, because I haven't had
    time, but the boot.ini file was in fact corrupt, and upon a parallel
    reinstallation of windows, it was all fixed.

    you were both right (thanks Tony Sperling as well) there was some unforseen
    driver issue mucking up the installation, but after removing all but he most
    necesary pci cards, the installaiton continued. now it all works fine once
    again. I shall be thoroughly exploring l;inux later while running off a
    floppy boot disk, until such time as i am comfy with the dual boot.

    Thanks to you both.
    TheIneffableBob, Aug 17, 2005
  14. Thanks! all is well (see above post reply to john barnes for details)
    TheIneffableBob, Aug 17, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.