NTLM Passwords Linux NAS passwords

Discussion in 'Windows Vista Networking' started by SteveK, Jan 31, 2007.

  1. SteveK

    SteveK Guest

    in RC2 this forum gave me the following solution to a problem accessing linux
    devices - i.e. password format was not accepted due NTLM.

    - Click Start
    - Click Control Panel
    - Click System and Maintenance
    - Click Administrative Tools
    - Double-Click Local Security Policy
    - In the left pane, click the triangle next to Local Policy
    - In the left pane, click Security Options
    - In the right pane near the bottom, double-click "Network security: LAN
    manager authentication level"
    - Click the drop-down box, and click "Send LM & NTLM - use NTLMv2 session
    security if negotiated"
    - Click OK

    The solution worked perfectly - BUT now I have a the final version (Vista
    Home - bought in a shop) I have the same problem except that when I try to
    follow the procedure above there is no 'Local Security Policy' option in the
    Administrative Tools section of the control panel.

    Can anyone tell me where I can access the 'Local Security Policy' settings??

    Thanks, SteveK
     
    SteveK, Jan 31, 2007
    #1
    1. Advertisements

  2. SteveK

    SteveK Guest

    The implications are it seems that if you have any Linux based NAS devices
    (which probably accounts for the majority) they will not work (passwords)
    with Vista Home Edition. There are going to be a lot of very unhappy people
    out there! You'll have to pay another £144 to upgrade to Ultimate!

    Any comments, input, work arounds or donations towards a copy of Ultimate
    greatly appreciated.
     
    SteveK, Jan 31, 2007
    #2
    1. Advertisements

  3. SteveK

    Dave R. Guest

    Two thoughts: One, perhaps there is a way to upgrade the NAS devices to
    support NTLMv2 authentication. Two, perhaps there are registry settings
    that can achieve the same effect as using the Local Security Policy
    settings.

    In XP Pro, changing from "Send LM & NTLM responses" to "Send LM & NTLM -
    use NTLMv2 session security if negotiated" changes
    "lmcompatibilitylevel" in
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa from
    dword:00000000 to dword:00000001

    If someone with a Business or Ultimate version had time and inclination,
    they could run a registry compare before & after changing the
    authentication level and see what surfaces. Unfortunately I don't yet
    have access to a copy of Business or Ultimate or I'd do it - I'll
    eventually have to anyway so I can automate a couple of deployment
    scenarios.

    Hope this helps.

    Regards,

    Dave
     
    Dave R., Jan 31, 2007
    #3
  4. SteveK

    Jimmy Brush Guest

    This is the correct registry key and value to change.


    --
    - JB
    Microsoft MVP - Windows Shell/User

    Windows Vista Support Faq
    http://www.jimmah.com/vista/
     
    Jimmy Brush, Feb 1, 2007
    #4
  5. SteveK

    Dave R. Guest

    Thanks for the confirmation.

    Best Regards,

    Dave
     
    Dave R., Feb 1, 2007
    #5
  6. SteveK

    SteveK Guest

    Worked a treat - thanks
    BTW, the existing value in my registry was 00000003 and not 00000000. But I
    set it to 00000001 and it works a treat.
     
    SteveK, Feb 2, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.