O&O Defrag versus Microsoft Defrag in Vista

Discussion in 'Windows Vista Performance' started by MB@MI, USA, Sep 22, 2006.

  1. MB@MI, USA

    MB@MI, USA Guest

    Out of curiosity I wanted to do a side-by-side test of Microsoft Defrag
    versus O&O Defrag, and was shocked...

    Microsoft Defrag announced at its completion all drives defragmented. When I
    loaded O&O Defrag next, it reported that the hard drive was 78% fragmented!!

    Whats going on with Microsoft Defrag? Why would it tell me defrag done at
    78% fragmentation? (with O&O Defrag you can actualy look at each cluster and
    see listings of what sections of what files occupy that cluster and sure
    enough there was very wide fragmentation everywhere)

    Does Microsoft Defrag work? Or does it have a level of "acceptable
    fragmentation" (although I cant imagine why it would think 78% fragmentation
    is acceptable)
     
    MB@MI, USA, Sep 22, 2006
    #1
    1. Advertisements

  2. MB@MI, USA

    Robert Moir Guest

    Well it might be that you've found a bug, after all Vista is still beta
    software.

    More importantly, different defrag programs have very different ideas about
    how to defrag a drive, what constitutes a defragged drive, what difference a
    particular pattern of files will make to performance, etc.
     
    Robert Moir, Sep 23, 2006
    #2
    1. Advertisements

  3. MB@MI, USA

    Jeff Guest

    Whoever dumbed down defrag in Vista; ouuta be fired-IMHO
    Jeff
     
    Jeff, Sep 23, 2006
    #3
  4. MB@MI, USA

    Robert Moir Guest

    I'm disappointed too, as it happens. What they've done makes perfect sense
    at the machine level but shows absolutely no idea of how people interact
    with their computer.
     
    Robert Moir, Sep 23, 2006
    #4
  5. MB@MI, USA

    Jeff Guest

    Ah,
    Robert,
    We agree-lol
    :)
    Jeff
    P.S. As you well know; command line defrag works fine;but I miss all the
    colors.
    LOL
     
    Jeff, Sep 23, 2006
    #5
  6. MB@MI, USA

    JJ Guest

    With all of the ooo and ahhh of vista, I miss the colors as well.

    Please give me a "more information" button, so I know how long I have to
    wait...
    --
    John

    PC: (XPS Gen 1) laptop
    Mem 1 gb
    processor P4 3.4
    Video ATI 9800 256 MB
    Vista RC1 build 5600/5728 dual boot
    Base score 4.3
     
    JJ, Sep 24, 2006
    #6
  7. Yeah. People can talk all day about how much the pictures were worth but not
    having any kind of estimate of time left, percentage complete or whatever is
    just inexplicable.

    Actually, long story short, I've got so annoyed with Vista on my main
    machine that I've put XP back on. I'm still running RC1 in a dual boot
    config on my Apple MacBook though, for testing, but I'm stunned that such a
    ropey piece of software is considered near enough to release to call it a
    release candidate.
     
    news.microsoft.com, Sep 25, 2006
    #7
  8. MB@MI, USA

    JJ Guest

    Not ready to ditch yet, though dealing with the UAC system just to allow the
    defrag -v -c command (yes I need the information, but still no time estimate)
    was a bit frustrating to the standard user.

    It seems that there are two levels of information - very "dumbed-down" user
    information and the IT Pro information (with whole web sites of "exciting"
    information!)

    Hey, I hope I can speak for some Vista users out there (at least for home
    use) - include the "more detail" option for every application. Let the users
    decide the level of information that they want. One would believe that this
    is the true test of a RC ready piece of software.

    --
    John

    PC: (XPS Gen 1) laptop
    Mem 1 gb
    processor P4 3.4
    Video ATI 9800 256 MB
    Vista RC1 build 5600
    Base score 4.3
     
    JJ, Sep 26, 2006
    #8
  9. MB@MI, USA

    Telstar Guest

    Which build of O&O are you running?
    I remember that I tried one version that I couldnt install.

    I'm gonna try diskeeper 10 beta for build 5600 now... so I can
    uninstall the crappy auslogic disk defrag (which is very quick btw).
     
    Telstar, Sep 27, 2006
    #9
  10. MB@MI, USA

    astro999 Guest

    Telstar,
    I have Diskeeper 10 and loaded Vista RC 1 and Diskeeper 10 works.Now I did a
    manually defrag and it did good.Was some files that it coulndn't open to
    defrag but that was a small amount.And I have to research to find out how to
    get these open so Diskeeper can do its job.
     
    astro999, Oct 4, 2006
    #10
  11. MB@MI, USA

    astro999 Guest

    Telstar,

    I might be wrong on this.It may work but it doesn't work defraging all the
    time like it was meant to do.So I just downloaded the Raxco's Perfect Disk 8
    for Vista RC 1 and will use that for now until Diskeeper comes out with
    another version to work on Vista.Sorry about this.But i really like Diskeeper.
     
    astro999, Oct 4, 2006
    #11
  12. MB@MI, USA

    Telstar Guest

    It seems I'm cursed with defrag in Vista.
    After installing Diskeeper 10 and rebooting, ALL the storage is
    diappeared from Computer Management and now I cant resize or move any
    partition.

    Here goes another uninstall hoping I can fix MMC... :(
     
    Telstar, Oct 5, 2006
    #12
  13. MB@MI, USA

    Telstar Guest

    Hopefully uninstalling fixed the MMC, I'm waiting for an answer from
    Diskeeper for this huge bug.
     
    Telstar, Oct 6, 2006
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.