Old usb devices work fine,new usb devices would not install

Discussion in 'Windows Vista Hardware' started by Christopher Hume, Aug 11, 2008.

  1. Like the subject title, says old usb devices are working fine, but new
    ones will not install under Vista. Vista would suggest the update
    (Windows6.0-KB940199-x86) but when trying it, I'd get the message that
    it does not apply to my machine. I've tried copying the pnf and inf
    files, tried moving the usbstore, tried deleting the INFcache.1, all to
    no avail (as recommended by many web site). I am currently attempting to
    install a Brother DCP-7020 monochrome multi-function laser printer under
    Vista via its USB connection (it also has a parallel port but using that
    connection, its scanning functions will not work according to Brother's
    web site so have to USB to get the scanning ability -- tried an MFC-8040
    with the same results and error messages)). I thought of upgrading to
    Vista SP1 to see if that would fix things but it's not offered to me
    under Windows Update and I know I could install it manually (via the
    stand-alone download from Microsoft's site), but am afraid it may mess
    up something with my system since Windows Update doesn't offer it to me.
    When installing the latest drivers downloaded directly from Brother's
    site, after I plug the printer in and turn it according to the
    installation's instructions, Vista see it's a DCP-7020,tells me that
    it's ready to use, that the USB composite device is ready to use and
    that an unknown device failed to install. I even tried the navigating to
    C:\Windows\winsx at the appropriate prompt and still nothing. I've even
    tried some things with System Restore but System Restore is no longer
    successful at any restores for me for some reason, although it doesn't
    do me any harm either (it leaves things the way they were before the
    System Restore attempt). I have tried the kb941600 download at
    http://support.microsoft.com/kb/941600/ which somehow managed to get the
    printer side of the dcp-7020 to work but no scanner. In frustration, I
    uninstalled that package. I have also thought of re-installing Vista,
    but that would be a last resort option as re-installing any OS is no fun
    (back up stuff, re-install OS, re-install drivers, re-install programs,
    etc.) In case needed, my system's specs are:

    Dell Dimension 9200/XPS 410 (same machine but it's known as the 9200 in
    Canada and the XPS 410 in the U.S.)
    2.4Ghz Quad core
    4GB RAM
    32-bit Vista Home Premium
    Logitech Quickcam Messenger (usb device) -- installed, but not hooked up
    - works fine when connected
    Seagate FreeAgent Drive 500GB (usb device) -- hooked up and working fine
    Brother MFC-665CW (usb device) -- hooked up and works fine
    Epson Perfection 1250 (usb device) -- installed, but not hooked up -
    works fine when connected
    Logitech Meida Keyboard (usb device) -- hooked up and works fine
    Logitech LX7 mouse (usb device) -- hooked up and works fine
    Sansa E270 mp3 player (usb device) -- hooked up and works fine
    LG Lightscribe drive (usb device) -- hooked up and works fine
    2 Kingston Data Traveller usb drive -- installed, but not hooked up -
    both work fine when connected
    IOGear 6 port USB hub with card reader -- hooked up and works fine
    DCP-7020 -- trying to install, but so far no go, due to the reasons
    stated above.
    MFC-8040 -- trying to install, but so far no go, due to the reasons
    stated above.

    It's getting to the point I am afraid to buy *any* new (to my system)
    USB devices as none have worked thus far all of a sudden.

    Any help in this matter is greatly appreciated. Thanks.
    Chris
     
    Christopher Hume, Aug 11, 2008
    #1
    1. Advertisements

  2. Christopher Hume

    mikeyhsd Guest

    are you sure the instructions do not say,
    install software and drivers.
    then plug in and turn on the printer when requested.








    Like the subject title, says old usb devices are working fine, but new
    ones will not install under Vista. Vista would suggest the update
    (Windows6.0-KB940199-x86) but when trying it, I'd get the message that
    it does not apply to my machine. I've tried copying the pnf and inf
    files, tried moving the usbstore, tried deleting the INFcache.1, all to
    no avail (as recommended by many web site). I am currently attempting to
    install a Brother DCP-7020 monochrome multi-function laser printer under
    Vista via its USB connection (it also has a parallel port but using that
    connection, its scanning functions will not work according to Brother's
    web site so have to USB to get the scanning ability -- tried an MFC-8040
    with the same results and error messages)). I thought of upgrading to
    Vista SP1 to see if that would fix things but it's not offered to me
    under Windows Update and I know I could install it manually (via the
    stand-alone download from Microsoft's site), but am afraid it may mess
    up something with my system since Windows Update doesn't offer it to me.
    When installing the latest drivers downloaded directly from Brother's
    site, after I plug the printer in and turn it according to the
    installation's instructions, Vista see it's a DCP-7020,tells me that
    it's ready to use, that the USB composite device is ready to use and
    that an unknown device failed to install. I even tried the navigating to
    C:\Windows\winsx at the appropriate prompt and still nothing. I've even
    tried some things with System Restore but System Restore is no longer
    successful at any restores for me for some reason, although it doesn't
    do me any harm either (it leaves things the way they were before the
    System Restore attempt). I have tried the kb941600 download at
    http://support.microsoft.com/kb/941600/ which somehow managed to get the
    printer side of the dcp-7020 to work but no scanner. In frustration, I
    uninstalled that package. I have also thought of re-installing Vista,
    but that would be a last resort option as re-installing any OS is no fun
    (back up stuff, re-install OS, re-install drivers, re-install programs,
    etc.) In case needed, my system's specs are:

    Dell Dimension 9200/XPS 410 (same machine but it's known as the 9200 in
    Canada and the XPS 410 in the U.S.)
    2.4Ghz Quad core
    4GB RAM
    32-bit Vista Home Premium
    Logitech Quickcam Messenger (usb device) -- installed, but not hooked up
    - works fine when connected
    Seagate FreeAgent Drive 500GB (usb device) -- hooked up and working fine
    Brother MFC-665CW (usb device) -- hooked up and works fine
    Epson Perfection 1250 (usb device) -- installed, but not hooked up -
    works fine when connected
    Logitech Meida Keyboard (usb device) -- hooked up and works fine
    Logitech LX7 mouse (usb device) -- hooked up and works fine
    Sansa E270 mp3 player (usb device) -- hooked up and works fine
    LG Lightscribe drive (usb device) -- hooked up and works fine
    2 Kingston Data Traveller usb drive -- installed, but not hooked up -
    both work fine when connected
    IOGear 6 port USB hub with card reader -- hooked up and works fine
    DCP-7020 -- trying to install, but so far no go, due to the reasons
    stated above.
    MFC-8040 -- trying to install, but so far no go, due to the reasons
    stated above.

    It's getting to the point I am afraid to buy *any* new (to my system)
    USB devices as none have worked thus far all of a sudden.

    Any help in this matter is greatly appreciated. Thanks.
    Chris
     
    mikeyhsd, Aug 11, 2008
    #2
    1. Advertisements

  3. That's the first thing I tried, actually and got nothing but error
    messages. As stated, below, "When installing the latest drivers
    downloaded directly from Brother's site, after I plug the printer in and
    turn it according to the installation's instructions, Vista see it's a
    DCP-7020,tells me that it's ready to use, that the USB composite device
    is ready to use and that an unknown device failed to install." Whether
    from the CD that came with the printer or via Brother's web site, I
    don't plug in or turn on the printer until requested. I then get the
    usual Vista trying to find the appropriate driver routines but Vista
    can't find them on the CD or even via the downloaded driver's
    installation routine for some reason and will not proceed further. I am
    having the same issue as the folks at
    http://forums.microsoft.com/msdn/sh...d=1&mode=1&sb=0&d=1&at=7&ft=11&tf=0&pageid=13

    and so far those suggestions haven't worked :(.
     
    Christopher Hume, Aug 12, 2008
    #3
  4. Christopher Hume

    oscar Guest

    Hi Christopher,

    Could you post some of those error messages such as Error Code and Error text?
     
    oscar, Aug 12, 2008
    #4
  5. Whoops, I see I accidentally cross-posted to a Win2k group. Fixed now.
    To answer, I get no error code, but I do get an error message to the
    effect that Vista asks me where to locate the drivers (one would think
    the downloaded drivers or CD would know where to look for them). I can't
    remember the exact wording but it along the lines of "installing device
    driver SW" followed by option window "Found New Hardware".Under "Found
    New Hardware" window, I get the choices of automatically find driver
    (Recommended), Browse manually to drivers or "Ask Me again later". If I
    choose the automatic route, it finds everything but the scanner and says
    the installation of unknown device (scanner) failed and the installation
    routine refuses to go any further and just sits there. If I cancel out,
    Vista sometimes informs me to download the kb941600 at
    http://support.microsoft.com/kb/941600/ but when I do that, it tells me
    it doesn't apply to my system. For some reason, I don't get the message
    to do that download anymore, but all the other symptoms remain the same.
     
    Christopher Hume, Aug 12, 2008
    #5
  6. Christopher Hume

    mikeyhsd Guest

    if this is a multi function printer.
    for mine I have to install the scanner first then the printer.
    not plugging in or turning on till after the printer and told to do so.

    sounds like part of the function failed to install.










    That's the first thing I tried, actually and got nothing but error
    messages. As stated, below, "When installing the latest drivers
    downloaded directly from Brother's site, after I plug the printer in and
    turn it according to the installation's instructions, Vista see it's a
    DCP-7020,tells me that it's ready to use, that the USB composite device
    is ready to use and that an unknown device failed to install." Whether
    from the CD that came with the printer or via Brother's web site, I
    don't plug in or turn on the printer until requested. I then get the
    usual Vista trying to find the appropriate driver routines but Vista
    can't find them on the CD or even via the downloaded driver's
    installation routine for some reason and will not proceed further. I am
    having the same issue as the folks at
    http://forums.microsoft.com/msdn/sh...d=1&mode=1&sb=0&d=1&at=7&ft=11&tf=0&pageid=13

    and so far those suggestions haven't worked :(.
     
    mikeyhsd, Aug 12, 2008
    #6
  7. It is a multi-function printer and does indeed include a scanner. The
    scanner portion refuses to install as Vista sees it as an unknown device
    and I don't both to turn on the printer or plug it in until specifically
    told by the installation routine per the instruction manual. During the
    usual Vista has detected a new device, looking for drivers, installing
    drivers, etc., it does not seem able to find the scanner portion of the
    printer and after Vista gives up, the installation program does not
    proceed further as it only gives me the option to cancel. The strange
    part is the printer works fine on another PC with Vista SP1 (I'd install
    SP1 on the PC giving me issues and no guarantee it'd fix my issues
    anyway, but it's not available via Windows Update and as an aside, I'm
    not sure what's causing it to be blocked from there -- thought it was my
    Sigmatel drivers, but tried uninstalling those & rebooting, but SP1
    still isn't offered by Windows Update).
     
    Christopher Hume, Aug 12, 2008
    #7
  8. Christopher Hume

    oscar Guest

    So far it looks like you’re doing all the right things.

    (You did try loading drivers manually using Device Manager, yes? Sorry, I
    have to ask but I can’t remember if that was one of the mentioned methods
    that you tried in the forum that you referred to.)

    If it works on another Vista machine with SP1 but not yours then the problem
    may indeed be with your OS. Some corrupted files?

    1) You may want to look into getting the problem of SP1 installed.

    Here’s a start in case you haven’t seen these:

    http://windowsvistablog.com/blogs/w...ows-vista-sp1-released-to-windows-update.aspx

    http://windowsvistablog.com/blogs/w...sp1-rc-now-available-for-public-download.aspx

    2) Try Startup Repair to fix possible damaged OS files

    3) See if you can load the drivers in a different user account.

    Yes, reinstalling Vista is the last resort. But if I read it correctly, the
    mention that your System Restore doesn’t appear to change any settings is a
    concern.

    Best of luck…
     
    oscar, Aug 12, 2008
    #8
  9. No problem asking (good not to assume anything). I've tried installing
    the drivers manually, but the scanner portion isn't recognized no matter
    what I do. It is possible I may have some corrupt system files as my PC
    had a huge hang the other day (had to forcibly restart the system and at
    the time, System Restore barely worked, but enough to get my PC usable
    again -- I suspect with any Windows or any OS for that matter
    crash/hang, it's always possible some files get corrupted or even when
    Windows is shut down due to a power outage) and I still had to reinstall
    a couple of corrupted programs. Also, an external hard drive around that
    time died on me :( (it was about 5 yrs old). And yes, you did recall
    reading correctly about System Restore being problematic for me. The
    reason I didn't mention the HD dying/huge hang, is everything else on my
    PC is working fine at the moment except new usb devices for some reason.

    Thanks for your help :).
     
    Christopher Hume, Aug 12, 2008
    #9
  10. Christopher Hume

    oscar Guest

    Christopher,

    I'm sure you'll get it fixed.

    With my XP computers I have reinstalled the OS once a year.

    With my Vista Home Premium Sp1 machine (one year anniversary coming up), I
    haven't seen any need to do so... so far. Knock wood.

    Right now, I'm using two user accounts. One administrator account that I
    only use for global maintenance work and a standard user account which I use
    everyday. I think that using the standard user account with elevated
    priveleges when needed helps keep the minimize damage to the OS in case some
    "bad" software does its number.

    Cheers...
     
    oscar, Aug 12, 2008
    #10
  11. I'm sure I'll get it fixed eventually, one way or the other :). I had
    thought of running as a standard user for one account and an
    administrator (for global maintenance work) as another, but had tried
    that under XP and didn't work too well (most programs at the time
    required administrator privileges). I hear it's very different under
    Vista (i.e., much easier) but haven't tried it for fear of way too many
    programs insisting on administrator privileges --- although I could try
    it as it'd give me a chance to see if there's something wrong with my
    current profiles and as you said, if any "bad" software or even "good"
    software malfunctions, the damage to the OS will be minimal.
     
    Christopher Hume, Aug 13, 2008
    #11
  12. Christopher Hume

    Wandering Guest

    Some multifunction machines have a separate driver to install for the
    scanner. They also come with scanner software, that sometimes includes the
    driver. It is not unusual to find a Vista driver for the printer, but no
    software for the scanner. Visit the mfg site, and don't download "the latest
    driver" download the Vista Compatible drivers. Good luck.
     
    Wandering, Aug 13, 2008
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.