Old WSUS server parameters reappearing on workstation.. rsop error

Discussion in 'Update Services' started by markm75, Mar 12, 2008.

  1. markm75

    markm75 Guest

    I cant figure this one out so far..

    I have a vista x64 machine which seems to be getting an old WSUS server
    address (which at one point was in our GPO, but isnt now)...

    IE: if i go into the LM computer section of the registry and remove the
    entries.. then run gpupdate /force .. it pops the two entries back in place,
    not the new server name and port (other machines are fine)..

    Also.. if i do an rsop.msc from this machine.. i can see that the GPO policy
    for auto updates is being applied.. however, there is an error.. on the error
    information tab i have under component name: Registry and status failed..
    error is "registry failed due to error listed below. Unspecified error"

    I do have an exclaimation mark through the "computer configuration" portion
    of rsop

    I also have errors under the source of "GroupPolicy" and eventid 1125 in the
    system log: "The processing of Group Policy failed because of an internal
    system error. Please see the Group Policy operational log for the specific
    error message. An attempt will be made to process Group Policy again at the
    next refresh cycle."


    I'm not sure what else to check or do here..

    Any thoughts?
     
    markm75, Mar 12, 2008
    #1
    1. Advertisements

  2. This appears to be a group policy issue, rather than a WSUS issue per se, so you
    might get better advice in a newsgroup relating to group policy.

    To clarify: you're removing the entries in this key:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate

    and when group policy recreates them, it is setting the wrong value for
    WUServer? (And WUStatusServer?)

    Did you doublecheck that the entries really were removed, e.g., by exiting and
    restarting registry editor? Have you tried deleting the entire WindowsUpdate key?

    Harry.
     
    Harry Johnston [MVP], Mar 12, 2008
    #2
    1. Advertisements

  3. markm75

    markm75 Guest

    Yep.. these are the entries i manually delete.. i see them go away upon
    deleting.. i close the registry.. run gpupdate /force and the windows update
    parameters for an old server go back in place.

    I havent tried deleting the windows update key.. I'm suspicious of that
    error i'm getting in the system event viewer though...
     
    markm75, Mar 13, 2008
    #3
  4. markm75

    markm75 Guest

    Well I found a solution.. albeit ugly...

    It appears something in the local vista policy was hosing this machine,
    causing it to get old values..

    I'm not sure what.. as once i disabled the computer portion of the local
    policy.. i got the correct values in the registry.

    I checked the computer section of the local policy, but it was all set to
    "not configured".. so i'm not sure why it kept reverting..
     
    markm75, Mar 14, 2008
    #4
  5. markm75

    markm75 Guest

    Well I found a solution.. albeit ugly...

    It appears something in the local vista policy was hosing this machine,
    causing it to get old values..

    I'm not sure what.. as once i disabled the computer portion of the local
    policy.. i got the correct values in the registry.

    I checked the computer section of the local policy, but it was all set to
    "not configured".. so i'm not sure why it kept reverting..
     
    markm75, Mar 14, 2008
    #5
  6. markm75

    DaveMills Guest

    Off topic I know but how do you disable local policy. It this a Vista feature, I
    cannot find a way in XP and this may solve a problem I have.
     
    DaveMills, Mar 15, 2008
    #6
  7. Dave, you disable the "Computer Configuration" or "User Configuration"
    portion of a local policy the same way in which you would for a group
    policy. In fact, disabling one or the other is considered a "best practice"
    since
    [a] Computer and User configuration options should not be combined in
    the same policy, and
    the policy will load a bunch faster if it doesn't have to parse
    through a bunch of pointless policy settings.

    From the Local Policy Editor (gpedit.msc), right click on the "Local
    Computer Policy" note, select Properties, under the disable section, check
    the box to "Disable Computer Configuration settings".

    --
    Lawrence Garvin, M.S., MCBMSP, MCTS(x4), MCP
    Senior Data Architect, APQC, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2008)

    MS WSUS Website: http://www.microsoft.com/wsus
    My Websites: http://www.onsitechsolutions.com;
    http://wsusinfo.onsitechsolutions.com
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
     
    Lawrence Garvin [MVP], Mar 15, 2008
    #7
  8. markm75

    DaveMills Guest

    Gee thanks Lawrence. It probably one of the few places in group policy I have
    not tried. Combining this with the /gpcomputer: switch this will help a lot.


     
    DaveMills, Mar 16, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.