Opening IE 7 on a Vista OS just gets a File Download Security Warn

Discussion in 'Internet Explorer' started by paledin, May 13, 2007.

  1. paledin

    paledin Guest

    When I attempt to open IE 7(default site is on a Vista OS it opens
    the window and then immediately closes. I just get a File Download Security
    Warning. It looks something like this:


    Do you want to save this file?

    Name: navcancl

    Type: Unknown File Type, 2.64KB

    From: ieframe.dll


    The file you are downloading cannot be opened by the default
    program. It is either corrupted or it has an incorrect file type. As a
    security precaution, it is recommended that you cancel the
    download. How can I decide what software to open?

    This started when I updated IE7 from the Microsoft site.

    I can use Mozilla Firefox as a browser. When I make Mozilla the default
    browser, The message shown above changes as follows:

    Name: google.htm

    Type: Firefox Document


    I have emptied temporary files, history, cookies, saved passwords, and web
    form information. I have deleted any ActiveX add-ons and disabled the rest.
    None of this helps.

    How do I get IE7 back?
    paledin, May 13, 2007
    1. Advertisements

  2. paledin

    Don Varnau Guest

    Has your Temporary Internet Files been moved?
    - - -
    Posted by Tony on May 11
    If you use Vista and have a similar kinda issue of latest KB931768, which
    cause IE7 stopped working with a popping up window, indicating some navcancl
    & ieframe.dll related issue, you may follow my instruction to fix that. IMO,
    this issue is caused by a non-default temporary internet files' folder.

    0. Check my previous thread to see if you have the same issue as I had.

    1.Maybe you need to change the folder options in control panel -> folder
    options and turn off those hiding system & hidden files related settings.

    2. Access control panel -> internet options -> general->history section->
    settings, to see if your Temporary Internet Files folder is in its default
    folder. The default folder should be like :
    C:\Users\%USER_NAME%\AppData\Local\Microsoft\Windows\Temporary Internet
    Files (default folder may vary in WindowsXP)

    3. If it is not in a default folder format, change it to
    C:\Users\%YOUR_USER_NAME%\AppData\Local\Microsoft\Windows\. IE7 will
    automatically copy the temp files to
    C:\Users\%YOUR_USER_NAME%\AppData\Local\Microsoft\Windows\Temporary Internet
    Files by restarting windows.

    4. Reapply the KB931768 patch ,if you have uninstalled it and turn on your
    phishing filer. Restart IE7 to see if it works.
    - - -

    Hope this helps,
    [MS MVP- IE]
    Don Varnau, May 13, 2007
    1. Advertisements

  3. paledin

    John Taylor Guest

    You will need to do a restore to before the up date was installed. I had the
    same thing happen to me. MS has a problem with the update !
    John Taylor, May 13, 2007
  4. paledin

    PA Bear Guest

    From a related thread in Windows Update newsgroup:

    The problem has been solved by me. Simply restore the temporary internet
    files folder to the default folder and everything is working just fine!

    For detail See:

    The default location in WinXP is typically C:\Documents and
    Settings\[Username]\Local Settings\Temporary Internet Files.
    PA Bear, May 13, 2007
  5. paledin

    paledin Guest

    Thanks, it worked.

    paledin, May 14, 2007
  6. paledin

    paledin Guest

    Thanks, I followed this and it worked.

    paledin, May 14, 2007
  7. paledin

    Don Varnau Guest

    You're welcome. Thanks for the update.


    Don Varnau, May 14, 2007
  8. paledin

    PA Bear Guest

    PA Bear, May 14, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.