Optical USB Mouse not working

Discussion in 'Windows Vista Hardware' started by Dmitriy, Feb 26, 2007.

  1. Dmitriy

    Dmitriy Guest

    My Vista Business recognized my Dynex Optical USB mouse. However, when it
    tried to install the driver, it said that there was an error - section of the
    INF file is missing. I tried this about 5 times. I also tried installing the
    driver via Windows Update, got an error as well.

    Any suggestions?

    P.S. Dynex doesn't have any drivers for my mouse, or Vista on their website.
     
    Dmitriy, Feb 26, 2007
    #1
    1. Advertisements

  2. Dmitriy

    simrick405 Guest

    I have the same problem using Vista Home Premium. The system recognizes
    the thing when I plug in the adapter and tries to install drivers. Then
    I get an error message that the install has failed and it says "The
    driver installation file for this device is missing a necessary entry.
    This may be because the INF was written for Win 95 or later."

    Dynex are no help at all. They say that because it's PnP it should
    work. There are no special drivers available for this mouse. It was
    packaged in their "Notebook Kit".

    Someone please help?
     
    simrick405, Mar 21, 2008
    #2
    1. Advertisements

  3. Consider upgrading now to SP1. It cleans up a number of issues with
    devices.
     
    Colin Barnhorst, Mar 21, 2008
    #3
  4. Dmitriy

    simrick405 Guest

    Thanks. I may try that. However, I have more problems now which I have
    to deal with. After giving up trying to install this mouse, I rebooted
    and found that I could no longer connect to the internet or my home
    network via the notebook's integral wireless-G adapter. I rebooted
    several times. I even went and restored the system to an earlier time
    today (prior to trying to install this mouse). Still, I can not connect.
    Very frustrating.
     
    simrick405, Mar 21, 2008
    #4
  5. Dmitriy

    John Guest


    Also, when having trouble with USB, try taking it off a hub, if that's what
    you're using.
     
    John, Mar 28, 2008
    #5
  6. Dmitriy

    simrick405 Guest

    No, I am not using a hub (although I will remember your suggestion fo
    the future). I will try SP1 as Dynex are no help at all
     
    simrick405, Mar 29, 2008
    #6
  7. Dmitriy

    Stickman Guest

    Go in to device manager, update driver, and go in to the list o
    supported devices. You need to make it an HID-compliant mouse, instea
    of an optical browser mouse
     
    Stickman, Apr 4, 2008
    #7
  8. Dmitriy

    simrick405 Guest

    Thanks for the suggestions. I had tried making it HID-compliant prior to
    installing SP1 and was unsuccessful. But I installed SP1 last night, and
    tried again to get this mouse to work. VOILA! SP1 and HID-compliant
    mouse driver did the trick!

    Thanks everyone for your help.
     
    simrick405, Apr 4, 2008
    #8
  9. Dmitriy

    simrick405 Guest

    Eugen
    I have tried a Belkin USB wired mouse, a Dynex USB wireless mouse and
    Logitec V320 USB wireless mouse. I have tried both the Belkin and th
    Dynex with and without SP1 installed - it made no difference with th
    scrolling issues I have. I can only scroll in IE and nothing else.
    believe it is a Vista issue, but no one here seems to have an answer.
    don't think uninstalling SP1 will help. But, as it was suggested in
    previous post, you should make the mouse HID-compliant and that may a
    least get it working somewhat. Sorry I can't be of more help
     
    simrick405, Jul 20, 2008
    #9
  10. Dmitriy

    simrick405 Guest

    I was referring to a laptop, therefore I have a touchpad to use. Hav
    you tried going into safe mode to get the mouse to work? (tapping F
    during bootup
     
    simrick405, Jan 4, 2010
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.