[OT] (kind of) Avoid ATI at all costs

Discussion in 'Windows 64 Bit' started by Wayne Wastier, Jun 7, 2005.

  1. I have sent email to ATI for almost a year now on their stupidity in
    their handling of Drivers and Software for their AIW 9600XT and up cards
    for Windows XP x64. I just emailed them again about how the Catalyst 5.5
    drivers for Windows XP Pro x64 trash the WDM drivers that come with
    Windows. There response was, go here to such and such to get drivers.
    What a load of crap. They told me to download the same drivers that I
    just got through telling them didn't work.

    As a matter of fact, every time I do a ticket with ATI, the first
    response always only deals with the subject line, not the content. Just
    like they didn't bother reading what I wrote, just the subject line. How
    lame can they get?


    I am so mad I want to go to Canada and punch their CEO in the face.


    Later,
    Wayne
     
    Wayne Wastier, Jun 7, 2005
    #1
    1. Advertisements

  2. Wayne Wastier

    Kevin Panzke Guest

    Something is indeed wrong with the 5.5 Driver's on ATI's Website. Everytime
    I try to install them (after a clean windows installation) I get a File Copy
    Failed Pop Up Error Dialog Box, when I try to install their 64 Bit Driver's
    for my ATI Radeon X300.
     
    Kevin Panzke, Jun 7, 2005
    #2
    1. Advertisements

  3. Wayne Wastier

    NoNoBadDog! Guest

    I have 3 AMD64 based computers, each running an different ATI card (9700 Pro
    AIW, 9600XT, 9800 Pro), and I have not had any issues with the Catalyst 5.5
    drivers. The cards run fine on all three systems (two A64, one FX 64), on
    three different motherboards. I had no problem with either of the BETA
    driver suites that were on the website prior to the Catalyst 5.5 drivers.
    It is unfortunate that you are having issues, but it would appear that the
    problem is not universal, as I cannot reproduce the symptoms you describe.


    Bobby
     
    NoNoBadDog!, Jun 7, 2005
    #3
  4. Hello Kevin,

    I have had the same "File Copy Failed" error message when trying to install
    the 5.5 Catalyst drivers. After clicking OK the software continues to
    install. One of the things that I found out about the 5.5 drivers is that
    after installation of the drivers under the Administrator account I can
    access the Catalyst panel in the Advanced Settings of the Display properties
    in the usual way. However, after logging into my limited account and trying
    to access the Catalyst drivers in the same way they don't appear. Then if I
    go back into the Administrator account and try and access the Catalyst
    control panel, the Catalyst Control panel doesn't appear at all even though
    the driver's are still installed and working properly. I can only get the
    Catalyst control panel back by reinstalling the 5.5 Catalyst drivers. This
    being the case, I unchecked the option(s) to have the Catalyst icon appear
    in the system tray. This will help me remember to use the Administrator
    account to make any necessary changes in the Catalyst control panel. BTW, I
    have an ATI Radeon 9600 AGP card.

    I have heard that the 5.6 final release was scheduled to be released today
    on 6/7/2005 but they are not posted as of yet. You can probably find more on
    that discussion at www.planetamd64.com.



    Regards,

    Steve
     
    Steve Thompson, Jun 7, 2005
    #4
  5. [snip]

    To all,

    Also, I did a little snooping and found the reference that I mentioned
    regarding the 5.6 Catalyst drivers. The reference can be found here:
    http://www.theinquirer.net/?article=23594 .


    Regards,

    Steve
     
    Steve Thompson, Jun 7, 2005
    #5
  6. Wayne Wastier

    Joel Guest

    You should not write off ATI so quickly.
    Sure I was upset when the WDM driver were not included in the package. Guess
    they didn't included the actually drivers, but forgot to let the installer
    now this.

    After uninstalling 5.5, installing 5.4, then over again after speaking to an
    ATI tech. She said that they decided not to include them due to the fact
    that the 64bit version of the ATI-MMC was not ready, and it would be a
    smaller download.

    I expessed my disappointment. I have used the drivers to watch TV, though
    rudimentary through the MS Movie Maker, even if in an unsizable window in
    the app.

    I also expressed the concern that they took the sound out through the
    theater chip and replaced it with the sound converted to a wave out, which
    stumbles all the time. Leaving the connector from my ATI-AIW to my Audigy 2
    ZS useless in TV mode.

    It is funny that it was still through the connector in the win64 5.4 driver.
    I hope it stays that way.

    I just wish they would finish porting the MMC to 64bit
     
    Joel, Jun 7, 2005
    #6
  7. Don't do it Wayne, you might hurt your hand. ;-)
     
    Andre Da Costa [Extended64], Jun 7, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.