PC's in different subnets not showing in Unassigned Computers -WSU

Discussion in 'Update Services' started by Keith, Aug 14, 2007.

  1. Keith

    Keith Guest

    Hey Everyone -

    I searched through the forums and I can't seem to find the exact issue of
    what I'm trying to figure out so I thought I might try a new thread. Here's
    the situation.

    I've been using WSUS 2.0 for awhile now and the server we had it on before
    we decommissioned and I started over with WSUS 3.0. I have 4 sites:

    Site A - Main Site (DC,DNS Server on Windows 2k3) All PC's populate
    Site B - Remote Site (DC,DNS Server on Windows 2k3) Just the DC has populated
    Site C - Remote Site (DC, DNS Server on Windows 2000) Nothing has popluated
    Site D - Remote Site (No DC, points to Main Site for DNS) All PC's populate

    Each remote site has a T1 connection back to the main site. As you can see
    Site A and D have all popluated just fine. Site B has only the DC populated
    and none of the other PC's. Site C has nothing popluating. I even went into
    the registry to put the http://servername:8530 into that server and it still
    doesn't popluate. I've tried gpupdate /force to try and make them refresh
    the group policies but it still doesn't help. Also, all of the desktop PC's
    are in the same OU and some obviously get it and some done. The remote DC's
    show the group policy and the correct changes, but again nothing. I'm not
    sure if this is a WSUS, DNS, or Group Policy issue, but I was hoping someone
    might have ran into the similar situation and had a solution.

    Thank you!
     
    Keith, Aug 14, 2007
    #1
    1. Advertisements

  2. These are some steps you should use for troubleshooting on an affected client to
    determine what sort of problem it is. You probably should check at least one
    client in each of sites B and C.

    A) gpresult to show you whether the client is seeing the group policy.

    B) examine the registry on the client, using this documentation to see what
    settings should be present:

    <http://technet2.microsoft.com/Windo...0ffd-400c-b722-aeafdb68ceb31033.mspx?mfr=true>

    C) use the client diagnostics tool:

    <http://technet.microsoft.com/en-us/wsus/bb466192.aspx>

    D) look at WindowsUpdate.log in the system directory, usually c:\windows.

    If after doing this you can't tell what the problem is, post the relevant
    results here (or in the group policy newsgroup if that turns out to be the
    problem) and someone should be able to help.

    Harry.
     
    Harry Johnston, Aug 14, 2007
    #2
    1. Advertisements

  3. I have the same problem. Close to 500 PCs, but only about 200 show on the
    server.

    No problem with the group policy. No problem with the registry neither.

    Ran client diag:

    ******************************

    WSUS Client Diagnostics Tool

    Checking Machine State
    Checking for admin rights to run tool . . . . . . . . . PASS
    Automatic Updates Service is running. . . . . . . . . . PASS
    Background Intelligent Transfer Service is running. . . PASS
    Wuaueng.dll version 7.0.6000.374. . . . . . . . . . . . PASS
    This version is WSUS 2.0

    Checking AU Settings
    AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
    Option is from Policy settings

    Checking Proxy Configuration
    Checking for winhttp local machine Proxy settings . . . PASS
    Winhttp local machine access type
    <Direct Connection>
    Winhttp local machine Proxy. . . . . . . . . . NONE
    Winhttp local machine ProxyBypass. . . . . . . NONE
    Checking User IE Proxy settings . . . . . . . . . . . . PASS
    User IE Proxy. . . . . . . . . . . . . . . . . NONE
    User IE ProxyByPass. . . . . . . . . . . . . . NONE
    User IE AutoConfig URL Proxy . . . . . . . . . NONE
    User IE AutoDetect
    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
    WUServer = http://lmiwsus01t
    WUStatusServer = http://lmiwsus01t
    UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
    Connection to server. . . . . . . . . . . . . . . . . . PASS
    SelfUpdate folder is present. . . . . . . . . . . . . . PASS

    Press Enter to Complete

    ************************************

    The way it looks the client has no problem with the configuration.

    Why do I have a problem seeing some PCs?
     
    George Stoykov, Aug 15, 2007
    #3
  4. Are all the PCs receiving updates?

    Run

    wuauclt /detectnow

    on one of the missing PCs and see whether it then appears on the server,
    possibly replacing another (this behaviour is typical of cloned PCs, though
    normally you wouldn't see as many as 40% of your machines at once when this has
    happened).

    You should also look in WindowsUpdate.log for any clues.

    Harry.
     
    Harry Johnston, Aug 15, 2007
    #4
  5. Thanks Harry!

    You're absolutely correct. The SUSClientID had to be re-registered. I
    deleted the corresponding reg key with this command:

    REG DELETE
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
    /v SusClientId /f

    rebooted the PC and ran: wuauclt /detectnow

    FYI: Running the /detectnow without deleting the registry key didn't do the
    trick.
     
    George Stoykov, Aug 16, 2007
    #5
  6. You're most welcome.
    Theoretically this shouldn't happen if you are using sysprep in preparing your
    images, however I have seen some reports of this failing lately. Are your
    machines running Windows 2000 by any chance? Are you using WSUS 2 on the server
    with the WSUS 3 client?
    No, it wouldn't, although I hoped it might point us the right way.

    Harry.
     
    Harry Johnston, Aug 16, 2007
    #6
  7. I upgraded the server to WSUS 3.0

    When I run ClientDiag.exe on the client machines, it shows WSUS 2.0.

    Is there any way I can upgrade it?

    The PCs are running Windows XP.


     
    George Stoykov, Aug 16, 2007
    #7
  8. This is normal behaviour; the current version of client diagnostic tool doesn't
    know about WSUS 3.0, so it interprets the client version incorrectly. So long
    as the version number is 7.0.something you have the WSUS 3.0 client installed.

    All the other information produced by the CDT is still useful.

    Since you're running Windows XP, and WSUS 3.0, you shouldn't be troubled by
    duplicate client IDs - unless you failed to sysprep the master machine before
    cloning it?

    Were you using a WSUS 2.0 server prior to upgrading to WSUS 3.0? Did you have
    the same problem with the 2.0 server, or only since the upgrade?

    Harry.
     
    Harry Johnston, Aug 16, 2007
    #8
  9. I upgraded to from 2.0 to 3.0.

    Didn't have the same problem with 2.0, but still had a problem. I was
    getting the same PC registering multiple times.
     
    George Stoykov, Aug 17, 2007
    #9
  10. That's normal for WSUS 2.0 whenever a PC is being reinstalled. Each distinct
    instance of the operating system counts as a separate machine from WSUS's
    perspective.

    Harry.
     
    Harry Johnston, Aug 17, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.